Unusable submittodebian

Bug #738118 reported by Andrea Carpineti on 2011-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-dev-tools

apt-cache show ubuntu-dev-tools lists submittodebian as a tool included in the installation. Trying to use submittodebian with ubuntu-dev-tools installed I obtain a message which say to install the reportbug package (recommended in the ubuntu-dev-tools package). After I installed the reportbug package submittodebian works correctly.

andrea@Lynn:~$ dpkg -l |egrep ubuntu-dev-tools
ii ubuntu-dev-tools 0.120 useful tools for Ubuntu developers
andrea@Lynn:~$ submittodebian
This utility requires the «reportbug» package, which isn't currently installed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntu-dev-tools 0.120
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
Architecture: i386
Date: Sat Mar 19 10:20:29 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-dev-tools
UpgradeStatus: Upgraded to natty on 2011-02-14 (32 days ago)

Andrea Carpineti (acarpine) wrote :
Benjamin Drung (bdrung) wrote :

submittodebian behaved as it was expected. What did you expect?

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Incomplete
Andrea Carpineti (acarpine) wrote :

Thanks for the prompt reply Benjamin! Since ubuntu-dev-tools lists submittodebian among the included package I believed it should work also without install the recommended packages. Also in the wiki is said that ubuntu-dev-tools includes submittodebian. Logically speaking if a package A includes the package B I believe is reasonably think that if I have A then I also have B (without install other stuff).

Benjamin Drung (bdrung) wrote :

You mix packages and scripts. ubuntu-dev-tools (the package) contains submittodebian (a script) and a bunch of other scripts. When you install all packages that ubuntu-dev-tools recommends (which is the default!), you should be able to run all ubuntu-dev-tools scripts without the need to install additional packages.

We want to give the user the change to uninstall the recommended packages if the user do not use the scripts that depend on it.

Andrea Carpineti (acarpine) wrote :

You are absolute right! I forgot that I installed ubuntu-dev-tools using the --no-install-recommends option and that's why I don't have submittodebian. Thanks for your time Benjamin

Benjamin Drung (bdrung) wrote :

> I don't have submittodebian

You have submittodebian. Otherwise it couldn't complain that reportbug is not installed.

I am closing this bug. If you find a dependency that is not in Recommends, let us know.

Changed in ubuntu-dev-tools (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers