[pull-lp-source] crashes if wrong target release is specified

Bug #695523 reported by Benjamin Drung on 2010-12-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Low
Stefano Rivera

Bug Description

Binary package hint: ubuntu-dev-tools

$ pull-lp-source vlc maverick-update
Traceback (most recent call last):
  File "/usr/bin/pull-lp-source", line 109, in <module>
    main()
  File "/usr/bin/pull-lp-source", line 75, in main
    Logger.error(error)
  File "/usr/lib/python2.6/dist-packages/ubuntutools/logger.py", line 45, in error
    print >> cls.stderr, "%s: Error: %s" % (cls.script_name, message % args)
TypeError: unsupported operand type(s) for %: 'PocketDoesNotExistError' and 'tuple'

Stefano Rivera (stefanor) wrote :

I'm touching pull-lp-source in my syncpackage branch, so I'll fix this there.

Changed in ubuntu-dev-tools (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
importance: Undecided → Low
status: New → In Progress
Benjamin Drung (bdrung) on 2011-01-19
Changed in ubuntu-dev-tools (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.112

---------------
ubuntu-dev-tools (0.112) unstable; urgency=low

  [ Robert Collins ]
  * manage-credentials: Finish migrating away from the Launchpad 'edge' service
    root. (LP: #704657)

  [ Stefano Rivera ]
  * New source package downloading framework in ubuntutools.archive. Use in
    many scripts.
  * pull-lp-source: str() exceptions before passing to Logger (LP: #695523)
 -- Benjamin Drung <email address hidden> Thu, 20 Jan 2011 10:25:57 +0100

Changed in ubuntu-dev-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers