[requestsync] crashed with UnicodeEncodeError in edit_report()

Bug #553795 reported by Micah Gersten on 2010-04-02
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Low
Stefano Rivera

Bug Description

Binary package hint: ubuntu-dev-tools

Here's the whole console output:
requestsync phpmyadmin lucid unstable
Do you have upload permissions for the 'universe' component or the package 'phpmyadmin' in Ubuntu lucid?
If in doubt answer 'n'. [y/N]?
Please check on https://bugs.launchpad.net/ubuntu/+source/phpmyadmin/+bugs
for duplicate sync requests before continuing.
Press [Enter] to continue or [Ctrl-C] to abort.
Traceback (most recent call last):
  File "/usr/bin/requestsync", line 206, in <module>
    (title, report) = edit_report(title, report, changes_required = need_interaction)
  File "/usr/lib/pymodules/python2.6/ubuntutools/requestsync/common.py", line 90, in edit_report
    print 'Currently the report looks as follows:\n%s' % report
UnicodeEncodeError: 'ascii' codec can't encode character u'\u010c' in position 652: ordinal not in range(128)

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: ubuntu-dev-tools 0.96
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic x86_64
Architecture: amd64
Date: Fri Apr 2 00:07:01 2010
ExecutablePath: /usr/bin/requestsync
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/requestsync phpmyadmin lucid unstable
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=C
PythonArgs: ['/usr/bin/requestsync', 'phpmyadmin', 'lucid', 'unstable']
SourcePackage: ubuntu-dev-tools
Title: requestsync crashed with UnicodeEncodeError in edit_report()
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev sambashare vboxusers video

Micah Gersten (micahg) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Michael Bienia (geser) wrote :

I could reproduce this with "LANG=C requestsync ...". It works with a UTF-8 locale.

I guess requestsync needs to check if it's running in a UTF-8 locale and exit otherwise. Else it can't display the report with the UTF-8 encoded changelog.

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Benjamin Drung (bdrung) on 2010-12-18
summary: - requestsync crashed with UnicodeEncodeError in edit_report()
+ [requestsync] crashed with UnicodeEncodeError in edit_report()
Stefano Rivera (stefanor) wrote :

Yeah I don't really see how else we can handle this in LANG=C.
Similar issue in http://bugs.debian.org/613114

"Fixed" (with an error message) in r1026.

Changed in ubuntu-dev-tools (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.117

---------------
ubuntu-dev-tools (0.117) unstable; urgency=low

  [ Benjamin Drung ]
  * dgetlp, import-bug-from-debian, suspicious-source:
    Show error messages instead of having the import errors for
    recommended packages (Closes: #613101, LP: #693813).
  * update_maintainer.py: Update Maintainer field if it is set to
    "Ubuntu Core Developers <email address hidden>".

  [ Stefano Rivera ]
  * ubuntutools/archive.py: Rewrite launchpadlib redirects to https when
    fetching dscs.
  * debian/control:
    - Suggest qemu-user-static | qemu-kvm-extras-static. Ubuntu provides a
      qemu-user-static package, like Debian, since natty.
    - Drop Build-Depend on Recommend on libapt-pkg-perl. No longer used.
  * grab-merge: Show help when no arguments are provided.
  * pull-revu-source: Check for the availability of libwww-perl, and print a
    more helpful error.
  * requestsync, grep-merges: Require a UTF-8 locale. (Closes: #613114,
    LP: #553795)
 -- Benjamin Drung <email address hidden> Tue, 22 Feb 2011 00:42:33 +0100

Changed in ubuntu-dev-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.