lp-set-dup crashes

Bug #525539 reported by Rolf Leggewie on 2010-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubuntu-dev-tools

lp-set-dup crashed twice on me today. I'm not exactly sure what triggers it, but it may be that the bug to be closed as dupe being set to private triggers this. FWIW, I can make the change in LP itself without any further problems. Below is a trace.

$ lp-set-dup 243344 274469
Setting up Launchpad
Launchpad setup complete
Processing 274469
Traceback (most recent call last):
  File "/usr/bin/lp-set-dup", line 75, in <module>
    bug = launchpad.bugs[b]
  File "/usr/lib/python2.6/dist-packages/lazr/restfulclient/resource.py", line 820, in __getitem__
    representation = simplejson.loads(self._root._browser.get(url))
  File "/usr/lib/python2.6/dist-packages/lazr/restfulclient/_browser.py", line 214, in get
    response, content = self._request(url, extra_headers=headers)
  File "/usr/lib/python2.6/dist-packages/lazr/restfulclient/_browser.py", line 204, in _request
    raise HTTPError(response, content)
lazr.restfulclient.errors.HTTPError: HTTP Error 401: Unauthorized

Michael Bienia (geser) wrote :

As far I can tell this crash happens if two conditions are met:
1) the bug is private
2) you gave the "ubuntu-dev-tools" access token only access "to change non-private data" which is the most common setup

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Michael Bienia (geser) wrote :

Fix committed in r589.

Changed in ubuntu-dev-tools (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.93

---------------
ubuntu-dev-tools (0.93) lucid; urgency=low

  [ Scott Moser ]
  * rename mk-sbuild-lv to mk-sbuild, support union-type=aufs

  [ Emmet Hikory ]
  * Support qemu-arm-static -> qemu-kvm-extras-static transition
  * mk-sbuild: automatically install qemu-kvm-extras-static if requested
  * mk-sbuild: conditionally install lvm2 only for lvm-snapshot schroots
  * mk-sbuild: rationalise architecture variables
  * mk-sbuild: Generalise --type support and add "file" SCHROOT_TYPE
  * mk-sbuild.1: Document the --type argument

  [ Loïc Minier ]
  * Demote qemu-kvm-extras-static to a Suggests since most people don't build
    for armel.

  [ Kees Cook ]
  * requestsync: add -C to allow manually adding changelog when missing
    (LP: #518574).
  * mk-sbuild: clean up and make slight adjustments to new lvm/dir/file logic.
  * mk-sbuild.1: update documentation to reflect alternative config file
    names for distro and schroot type overrides.
  * mk-sbuild, docs/mk-sbuild.1: document DEBOOTSTRAP_MIRROR for good
    measure, thanks to Paul Holcomb.

  [ Michael Bienia ]
  * ubuntutools/requestsync/mail.py: Encode the report to utf-8 before passing
    it to gpg for signing (LP: #522316).
  * Add support for the other LP service roots (edge is still default)
  * Depend on python-launchpadlib >= 1.5.4
  * Also check package sets for upload permissions.
  * lp-set-dup: Don't crash when accessing private bugs (LP: #525539)
  * requestsync: Subscribe 'ubuntu-release' to Feature Freeze exceptions
    (updated to current policy; LP: #532740)

  [ Michael Vogt ]
  * edit-patch: add wrapper around cdbs-edit-patch, dpatch-edit-patch, quilt
    to transparently deal with the various patch systems.

  [ Colin Watson ]
  * lp-shell: Disable default apport excepthook, as this is intended for
    interactive use.
 -- Steve Langasek <email address hidden> Fri, 05 Mar 2010 19:16:32 -0800

Changed in ubuntu-dev-tools (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

thanks

Rolf Leggewie (r0lf) wrote :

Thanks. I am indeed now receiving a proper warning:

$ lp-set-dup 243344 274469
Setting up Launchpad
Launchpad setup complete
Processing 274469
W: Don't have enough permissions to access bug 274469
W: Bug 274469 is private
Would set the following bugs as duplicates of 243344:
Proceed? [y/N]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers