mk-sbuild-lv creates ~/ubuntu/{logs,build} even if you choose different directories

Bug #342154 reported by Ryan Niebur on 2009-03-13
2
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Wishlist
Kees Cook

Bug Description

Binary package hint: ubuntu-dev-tools

If I set $log_dir to something else, it still creates ~/ubuntu/logs/. It'd be nice if it created the directory I specify instead, or at least didn't create the one I didn't specifiy :)

Jonathan Davies (jpds) on 2009-03-13
Changed in ubuntu-dev-tools:
assignee: nobody → jpds
importance: Undecided → Wishlist
status: New → Confirmed
Jonathan Davies (jpds) wrote :

------------------------------------------------------------
revno: 346
committer: Jonathan Davies <email address hidden>
branch nick: trunk.jpds
timestamp: Fri 2009-03-13 09:25:03 +0000
message:
  * mk-sbuild-lv: Changed default behaviour so that the initial build and log
    directories are not created on first run; instead read settings file and
    check if they exist (LP: #342154).

Changed in ubuntu-dev-tools:
status: Confirmed → Fix Committed
Ryan Niebur (ryan52) wrote :

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.67

---------------
ubuntu-dev-tools (0.67) jaunty; urgency=low

  [ Jonathan Davies ]
  * mk-sbuild-lv: Changed default behaviour so that the initial build and log
    directories are not created on first run; instead read settings file and
    check if they exist (LP: #342154).
  * requestsync: Reverted old madison.php workaround (LP: #183346).

  [ Ryan Kavanagh ]
  * mk-sbuild-lv: Added support for Debian chroots. Updated manpage.
    (LP: #342158)

  [ Mitsuya Shibata ]
  * pull-debian-source: Detect existence of dget in multi-path environment.

 -- Jonathan Davies <email address hidden> Sat, 14 Mar 2009 22:40:05 +0000

Changed in ubuntu-dev-tools:
status: Fix Committed → Fix Released
Kees Cook (kees) wrote :

Current fix does not actually create any directories since the .sbuildrc file contents are not know to the script.

Changed in ubuntu-dev-tools (Ubuntu):
assignee: jpds → kees
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.72

---------------
ubuntu-dev-tools (0.72) jaunty; urgency=low

  [ Jonathan Davies ]
  * README.updates: Added - lists steps to take when updating this package.
  * grab-merge: Added --help option and manpage (LP: #349109).

  [ Siegfried-Angel Gevatter Pujals ]
  * pbuilder-dist:
     - Add squeeze as a Debian distribution. Thanks to Marco Rodrigues.

  [ Nathan Handler ]
  * pull-debian-source:
    - Add support for etch/oldstable
    - Make script work for codenames (etch, lenny, squeeze, sid)

  [ Ryan Kavanagh ]
  * Ported devscripts' build-rdeps to Ubuntu and replaced
    reverse-build-depends. Updated it's manpage. (LP: #272273)

  [ Kees Cook ]
  * mk-sbuild-lv:
    - Fully handle missing build log directories (LP: #342154).
    - More generalized approach to Distro-specific logic (LP: #342158).

  [ Scott Kitterman ]
  * dgetlp:
    - Port to hashlib module instead of md5 (deprecated in Python 2.6)
  * Bump minimum python-all-dev version to 2.5

 -- Scott Kitterman <email address hidden> Wed, 15 Apr 2009 22:51:14 -0400

Changed in ubuntu-dev-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers