requestsync -n fails

Bug #312297 reported by Laurent Bigonville on 2008-12-29
2
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Medium
Jonathan Davies

Bug Description

Binary package hint: ubuntu-dev-tools

Running "requestsync -d experimental -n mumudvb jaunty" give me the following backtrace:

Traceback (most recent call last):
  File "/usr/bin/requestsync", line 490, in <module>
    checkExistingReports(srcpkg)
  File "/usr/bin/requestsync", line 96, in checkExistingReports
    pkgBugList = bugList("https://bugs.launchpad.net/ubuntu/+source/%s" % package)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/connector.py", line 124, in __call__
    progress_hook=self.__progress_hook)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/html_buglist.py", line 269, in __init__
    BugPage, progress_hook)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/buglistbase.py", line 96, in __init__
    self._add(self.baseurl)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/buglistbase.py", line 150, in _add
    bugpage = self._fetch(url)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/buglistbase.py", line 135, in _fetch
    connection=self.__connection, all_tasks=self.__all_tasks)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/buglistbase.py", line 30, in __init__
    self.batchsize, self.length) = self.find_parse_function(connection, url, all_tasks)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/html_buglist.py", line 63, in find_parse_function
    lp_content = connection.get(url)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/http_connection.py", line 253, in get
    return self._safe_urlopen(url, None, False)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/http_connection.py", line 352, in _safe_urlopen
    raise exceptions.choose_LaunchpadError(error, url)
launchpadbugs.exceptions.LaunchpadURLError:
    * message: Page not found
    * url: https://bugs.launchpad.net/ubuntu/+source/mumudvb

I guess requestsync shouldn't test if a previous sync requests have already been made when invoqued with -n

Jonathan Davies (jpds) wrote :

I'll get to work on this first thing tomorrow.

Thank you for your report, I should have really thought of his when I implemented the existing bugs checker.

Changed in ubuntu-dev-tools:
assignee: nobody → jpds
importance: Undecided → Medium
status: New → In Progress
Jonathan Davies (jpds) wrote :

Just so I remember: the problem is at:

http://bazaar.launchpad.net/~ubuntu-dev/ubuntu-dev-tools/trunk/annotate/head%3A/requestsync

...line 492, where the checkExistingReports(srcpkg) is called. This call looks up the package's Launchpad bug list, which does not exist if the package is not in Launchpad, as it is so in the case of a new package.

Putting "if not newsource:" in front of this statement ought to fix the bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.50

---------------
ubuntu-dev-tools (0.50) jaunty; urgency=low

  [ Nathan Handler ]
  * Add pull-debian-source script (LP: #289141)
    - debian/copyright:
      + Add myself to the Upstream Authors and Copyright sections
      + Add pull-debian-source to the License section
    - Add doc/pull-debian-source.1

  [ Siegfried-Angel Gevatter Pujals ]
  * debian/control: Add perl-modules and libwww-perl as Recommended packages

  [ Iain Lane ]
  * pbuilder-dist.new: Add 'experimental' to list of known Debian releases.
    pbuilder-experimental works fine with pbuilder-dist.new.

  [ Jonathan Davies ]
  * buildd: Show which architectures are available in help and created a
    list of them for easy addition of new ones.
  * requestsync:
    - Readd sponsorship flag and related documentation in
      doc/requestsync.1 (LP: #270605).
    - Do not check package's Launchpad bug list page if the package to be
      synced is a new package. As this page does not exist for
      it (LP: #312297).

 -- Jonathan Davies <email address hidden> Mon, 29 Dec 2008 18:45:02 +0000

Changed in ubuntu-dev-tools:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers