ubuntu-upload-permission TypeError crash

Bug #1862372 reported by Andreas Hasenack on 2020-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

focal
ubuntu-dev-tools 0.175

$ ubuntu-upload-permission -a procps
Loading KWallet
Loading SecretService
Loading Windows
Loading chainer
Loading macOS
All upload permissions for procps:

Component (main)
================
* Ubuntu Core Development Team (ubuntu-core-dev) [team]
Traceback (most recent call last):
  File "/usr/bin/ubuntu-upload-permission", line 144, in <module>
    main()
  File "/usr/bin/ubuntu-upload-permission", line 90, in main
    sourcepackagename=package))
TypeError: '<' not supported between instances of 'Packageset' and 'Packageset'

Dan Streetman (ddstreet) wrote :

This is a result of the change from python2 -> python3.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.175ubuntu1

---------------
ubuntu-dev-tools (0.175ubuntu1) focal; urgency=medium

  [ Dan Streetman ]
  * lpapicache: remove new requirement to pass arch to getBinaries()
    (LP: #1862286)
  * ubuntu-upload-permission: sort packagesets by name to fix py3
    (LP: #1862372)
  * submittodebian: open with 'b' before writing utf-8 encoded bytes
    (LP: #1863119)

  [ Colin Watson ]
  * Use +sourcefiles URLs where possible (LP: #1860456)

 -- Dan Streetman <email address hidden> Thu, 20 Feb 2020 17:20:23 -0500

Changed in ubuntu-dev-tools (Ubuntu Focal):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers