[FFe] ubuntu-dev-tools

Bug #1843543 reported by Gianfranco Costamagna on 2019-09-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Undecided
Ubuntu Release Team

Bug Description

Ubuntu dev tools is now Python3 ready!

I uploaded in my ppa and I'll start using it, but having it in the archive would be a big improvement in Python2 removal effort :)

Stefano Rivera (stefanor) wrote :

I don't think the python3 port really brings anything to users of eoan. The advantage is to us, in being able to pull out python2 libraries from source packages. And that won't be FFed.

I'd also be very surprised if I didn't break *something* in the port.

Dan Streetman (ddstreet) wrote :

I'd prefer if this wasn't added to 19.10, this is late in the cycle to add this and I have quite a lot of changes I'll be pushing soon, that are taking a while to rebase on this, plus not all my py3 conversion was covered in the existing changes.

Mattia Rizzolo (mapreri) wrote :

I also disagree with this FFe. Despite it seems to be working for now I would be suprised if no regressions pop up in a few days/weeks in unstable.

@ddstreet: I'm still waiting on your MR(s)! The more you wait it's obvios the more it gets harder to rebase… Can't you start with a few changes at least?

Dan Streetman (ddstreet) wrote :

> I'm still waiting on your MR(s)

yes, I'm working on that this week...I hope to start opening MRs this or next week

Iain Lane (laney) wrote :

OK, let's close this then, thanks.

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Won't Fix

at least pbuilder-dist is broken now.

pbuilder-dist eoan login
Traceback (most recent call last):
  File "/usr/bin/pbuilder-dist", line 506, in <module>
    main()
  File "/usr/bin/pbuilder-dist", line 431, in main
    app = PbuilderDist(parts[0])
  File "/usr/bin/pbuilder-dist", line 123, in __init__
    self.system_architecture = ubuntutools.misc.host_architecture()
  File "/usr/lib/python3/dist-packages/ubuntutools/misc.py", line 97, in host_architecture
    if not arch or 'not found' in arch[0]:
TypeError: a bytes-like object is required, not 'str'

Dan Streetman (ddstreet) wrote :

> TypeError: a bytes-like object is required, not 'str'

this is already fixed in my working tree, but i don't know when i'll have the first MRs ready to open to fix this and other stuff. this week hopefully.

looks like it has been syncd in the meanwhile... I prefer to push a revert TBH

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.173ubuntu1

---------------
ubuntu-dev-tools (0.173ubuntu1) eoan; urgency=medium

  * Revert changes in 0.173, too much stuff broke in Ubuntu
    LP: #1843543

 -- Gianfranco Costamagna <email address hidden> Fri, 20 Sep 2019 21:27:03 +0200

Changed in ubuntu-dev-tools (Ubuntu):
status: Won't Fix → Fix Released

the 0.174 version is working really better, I tried around ~20 tools and they work as expected.
I suspect I'll sync post-eoan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers