[ubuntu-archive-assistant] not installed

Bug #1799568 reported by Mattia Rizzolo on 2018-10-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

Hi

So I'm now releasing version 0.166, since there is an RC bug.

ubuntu-archive-assistant is not being installed, and after I looked at why, I saw you:

* didn't add the required build-deps (I fixed this myself)
* didn't add the script to setup.py
* the new module is not within ubuntutools/ - this is actually a bothersome issue, since adding a separate top-level module would require a new binary package to comply with the debian python policy.

These are some of the issues I would have expected to catch if you had used a MR instead of pushing straight to master.

So please now actually integrate your work within the rest of the package, instead of just dumping it there.

In the meantime, the new script is not installed.

That's fine, thanks for assigning it to me.

Changed in ubuntu-dev-tools (Ubuntu):
importance: Low → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers