[seeded-in-ubuntu] crashed with IOError in _read_eof(): CRC check failed 0x282b98f1 != 0xdff779cL

Bug #1008783 reported by Jeremy Bicha on 2012-06-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Low
Unassigned

Bug Description

seeded-in-ubuntu stopped working today after updates; it worked this morning though.

history.log excerpt attached.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: ubuntu-dev-tools 0.142
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic x86_64
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
CrashCounter: 1
Date: Mon Jun 4 19:31:03 2012
ExecutablePath: /usr/bin/seeded-in-ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/seeded-in-ubuntu vinagre
PythonArgs: ['/usr/bin/seeded-in-ubuntu', 'vinagre']
SourcePackage: ubuntu-dev-tools
Title: seeded-in-ubuntu crashed with IOError in _read_eof(): CRC check failed 0x282b98f1 != 0xdff779cL
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sbuild sudo

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
tags: removed: need-duplicate-check
Stefano Rivera (stefanor) wrote :

Works for me.

Try deleting ~/.cache/ubuntu-dev-tools/seeded.json.gz and trying again.

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Incomplete
Jeremy Bicha (jbicha) wrote :

Thanks. That fixed it.

I guess there's still a bug here in that the error message isn't very helpful. Do you want to leave the bug open for that?

Changed in ubuntu-dev-tools (Ubuntu):
status: Incomplete → Invalid
Stefano Rivera (stefanor) wrote :

Yeah, we could make it handle broken data a little better.

Changed in ubuntu-dev-tools (Ubuntu):
status: Invalid → Triaged
Benjamin Drung (bdrung) on 2012-06-16
summary: - seeded-in-ubuntu crashed with IOError in _read_eof(): CRC check failed
+ [seeded-in-ubuntu] crashed with IOError in _read_eof(): CRC check failed
0x282b98f1 != 0xdff779cL
Changed in ubuntu-dev-tools (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-dev-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-dev-tools - 0.143

---------------
ubuntu-dev-tools (0.143) unstable; urgency=low

  [ Iain Lane ]
  * backportpackage: Fix filenames searched when looking for existing
    .orig.tar.foo files (to determine if we need to upload it again or not).
    (LP: #1007908)
  * backportpackage: Unset DEBEMAIL when building source package. Fixes error
    when building backports for packages with no Ubuntu changes.
    (LP: #1007042)

  [ Mathieu Trudel-Lapierre ]
  * mk-sbuild: use and update messages to suggest using the source:$chroot way
    of referring to source chroots instead of $chroot-source; since the latter
    does not work with btrfs snapshot-based chroots. (LP: #1014669)

  [ Lars Düsing ]
  * Corrected brackets in man-page for sponsor-patch.

  [ Stefano Rivera ]
  * pbuilder-dist: Don't try to enable -updates for the current codename
    referring to Debian testing, either (LP: #1011870)
  * Correct spelling mistakes in package description, thanks Logan Rosen for
    the patch (Closes: #678245)
  * Correct metavar for --mirror in backportpackage (LP: #999727)
  * submittodebian: Explitictly UTF-8 encode the bug body (LP: #1005834)
  * backportpackage.1: Document --key and --dont-sign (LP: #1007564)
  * seeded-in-ubuntu: Catch errors in parsing data, and don't keep unreadable
    data cached (LP: #1008783)
  * ubuntutools.archive: Improve error handling around rmadison calls
    (LP: #1010951)
  * submittodebian; Unset DEBEMAIL when building source package.
    (LP: #1015066)

  [ Benjamin Drung ]
  * Add a man page for the reverse-build-depends wrapper script.

 -- Benjamin Drung <email address hidden> Fri, 22 Jun 2012 13:34:43 +0200

Changed in ubuntu-dev-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers