[zh_CN] Language packages not installed completely

Bug #1036994 reported by Elsa Wang on 2012-08-15
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-defaults-zh-cn (Ubuntu)
Undecided
Unassigned
Precise
Medium
Stéphane Graber
Quantal
Undecided
Unassigned

Bug Description

Summary:
Install Qin precise image without network connection, after finish installation and log in to system, there will be a dialog pop up which indicates some language packages haven't been installed.
We'd better include all zh_CN language packages in Qin build.

Steps to reproduce:
1. Install Qin precise image without any network connection
2. Log in to system

Test case:
 - Check that ubuntu-defaults-zh-cn now depends on thunderbird-locale-zh-cn and not only thunderbird-locale-zh-hans

Expected results:
No error dialog.

Actual results:
There is an pop up dialog for the first boot which indicates language packages not installed completely.

Elsa Wang (elsawang) wrote :
Gary Ekker (gekker) wrote :

Sebastien, Martin,

Looks like we might not be getting ubuntu-defaults-zh-cn installed in the Chinese image for 12.04.1. We saw this regression with 12.04 as well...

Kate Stewart (kate.stewart) wrote :

Please cut and paste the text into the bug, so we can find the affected strings. (translation as well, if possible)

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

This is not about ubuntu-defaults-zh-cn, which is present on the Qin images. Some other packages are missing. Can we get output showing what packages Ubuntu wants to install to fix this?

affects: ubiquity (Ubuntu) → ubuntu-defaults-zh-cn (Ubuntu)
Changed in ubuntu-defaults-zh-cn (Ubuntu):
importance: High → Undecided
description: updated
Changed in ubuntu-defaults-zh-cn (Ubuntu Quantal):
status: New → Invalid
Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Stéphane Graber (stgraber)
importance: Undecided → Medium

Hello Elsa, or anyone else affected,

Accepted ubuntu-defaults-zh-cn into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-defaults-zh-cn/0.8.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

root@tpl-precise-amd64-temp-SkzbPsC:~# apt-get install ubuntu-defaults-zh-cn
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  thunderbird-locale-zh-cn
The following NEW packages will be installed:
  thunderbird-locale-zh-cn
The following packages will be upgraded:
  ubuntu-defaults-zh-cn
1 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 19.2 kB of archives.
After this operation, 128 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://archive.ubuntu.com/ubuntu/ precise-updates/main thunderbird-locale-zh-cn all 1:14.0+build1-0ubuntu0.12.04.1 [14.4 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ precise-proposed/main ubuntu-defaults-zh-cn all 0.8.3 [4852 B]
Fetched 19.2 kB in 14s (1371 B/s)
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 2.)
debconf: falling back to frontend: Teletype
Selecting previously unselected package thunderbird-locale-zh-cn.
(Reading database ... 21292 files and directories currently installed.)
Unpacking thunderbird-locale-zh-cn (from .../thunderbird-locale-zh-cn_1%3a14.0+build1-0ubuntu0.12.04.1_all.deb) ...
Preparing to replace ubuntu-defaults-zh-cn 0.8.2 (using .../ubuntu-defaults-zh-cn_0.8.3_all.deb) ...
Leaving 'diversion of /usr/lib/firefox/distribution/distribution.ini to /usr/lib/firefox/distribution/distribution.ini.ubuntu-defaults by ubuntu-defaults-zh-cn'
Unpacking replacement ubuntu-defaults-zh-cn ...
Processing triggers for libglib2.0-0 ...
Setting up thunderbird-locale-zh-cn (1:14.0+build1-0ubuntu0.12.04.1) ...
Setting up ubuntu-defaults-zh-cn (0.8.3) ...

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-defaults-zh-cn - 0.8.3

---------------
ubuntu-defaults-zh-cn (0.8.3) precise-proposed; urgency=low

  * depends: Add thunderbird-local-zh-cn as systems installed without
    internet access complain that it's missing post-installation.
    This package is just a transitional package to thunderbird-locale-zh-hans
    which was added as a dependency in 0.8.1. (LP: #1036994)
 -- Stephane Graber <email address hidden> Thu, 16 Aug 2012 13:24:36 -0400

Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: Fix Committed → Fix Released
Elsa Wang (elsawang) wrote :

I can still see this issue happens with latest build, and the following packages are installed if updating missing packages:

ibus-sunpinyin
fonts-arphic-uming
ttf-arphic-ukai
cmap-adobe-gb1

Stéphane Graber (stgraber) wrote :

Re-opening. Confirmed that these packages are indeed missing, unfortunately, adding these to the media would bring it 20MB over the CD capacity, so we need to discuss whether we prefer to have the CD fit on a 703MB media or if we prefer to have these packages and require a DVD.

Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: Fix Released → Triaged

Hello Elsa, or anyone else affected,

Accepted ubuntu-defaults-zh-cn into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-defaults-zh-cn/0.8.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-defaults-zh-cn - 0.8.4

---------------
ubuntu-defaults-zh-cn (0.8.4) precise-proposed; urgency=low

  * Add the following packages to get all the needed Chinese packages on
    the media. This will make the media to go oversized.
    cmap-adobe-gb1, fonts-arphic-uming, ibus-sunpinyin, ttf-arphic-ukai
    (LP: #1036994)
 -- Stephane Graber <email address hidden> Wed, 22 Aug 2012 14:23:02 -0400

Changed in ubuntu-defaults-zh-cn (Ubuntu Precise):
status: Fix Committed → Fix Released

This bug is about the popup window about missing language support.

Steps for verification:
1. Install 0822 amd64 image on http://china-images.ubuntu.com/precise/daily-live/current/
2. Log in to desktop, wait for a minute
3. Connect to the network and apt-get update
4. do 'check-lauguage-support -l zh_CN' from the terminal

Expected result:
check-language-support should return nothing. There should not be a popup window saying missing language support

Actual result:
In step 2, missing language support window appears. In step 4, nothing returns so there is no missing language packages.

Stéphane Graber (stgraber) wrote :

The remaining packages are for language-pack-en which is included on all Ubuntu systems and Chinese users are unlikely to care about, so having these out of the CD is reasonable.

Elsa Wang (elsawang) wrote :

Verified with 0822 i386 image, same result as Samantha reported in comment #13, the popup window still exist and if clicking buttons from popup window to update missing packages there will be nothing to update, so in this case, the popup window is a little bit weird for users.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments