ubuntu-defaults-builder: all builds fail

Bug #998351 reported by Redmar on 2012-05-12
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-defaults-builder (Ubuntu)
Undecided
Unassigned

Bug Description

The problem:
It looks like all iso-builds fail. I've tried both the Dutch customisation package which worked before, and the example package. Both builds fail with "E: config/chroot_local-hooks/00_language-support failed (exit non-zero). You should check for errors."

How to reproduce: try to build the example package using

/usr/share/doc/ubuntu-defaults-builder/examples/make-example
ubuntu-defaults-image --package ./defaults-builder-test_0.1_all.deb --components main,restricted,universe

I will attach the log of the build for the example package.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntu-defaults-builder 0.31
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sat May 12 09:26:13 2012
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120426-23:52
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-defaults-builder
UpgradeStatus: No upgrade log present (probably fresh install)

Redmar (redmar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-defaults-builder (Ubuntu):
status: New → Confirmed
Paolo Sammicheli (xdatap1) wrote :

Confirmed, the Italian image doesn't build anymore. It looks like it's a regression in the ubuntu-defaults-builder 0.31

Paolo Sammicheli (xdatap1) wrote :

Reverted to 0.30 and it worked. It's definitely a regression. Bye

Alkis Georgopoulos (alkisg) wrote :

I saw that you have "it complete" in langpacks.txt, which I think is what breaks the build, like it does with "el complete" as well.

I proposed a patch in LP bug #1048207, so I'm marking this as a duplicate, try out the patch if you want and confirm that it works or not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers