Ubuntu

[needs-packaging] [MIR] ubuntu-default-settings

Reported by Jeremy Bicha on 2012-08-21
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
ubuntu-default-settings (Ubuntu)
Wishlist
Unassigned
ubuntu-meta (Ubuntu)
Wishlist
Didier Roche
ubuntustudio-meta (Ubuntu)
Wishlist
Len Ovens

Bug Description

Ubuntu has customized several GNOME packages with gsettings overrides. Moving these overrides to a separate package, recommended by ubuntu-desktop would have these advantages:

1. Reduce our diff with Debian
2. Make it easier for those who want a pure/custom GNOME experience to get it
3. Give the GNOMEbuntu project more independence to ship a purer GNOME, or possibly tweak GNOME defaults without needing to affect the flagship Ubuntu desktop.

This was discussed at UDS:
http://summit.ubuntu.com/uds-q/meeting/20832/desktop-q-gnome-flavor/

And "reducing the delta with Debian" is a recurring UDS discussion.
https://blueprints.launchpad.net/ubuntu/+spec/desktop-q-gnome-plans-review

Code is temporarily at https://code.launchpad.net/~ubuntu-desktop/+junk/ubuntu-default-settings and will be uploaded shortly.

This will also need to be promoted to main. However since it only contains copies of gsettings overrides (most of which are already in main), there's not really any code to review.

There's also an ubuntu-artwork package which maybe should be merged into this one.

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

Moving Ubuntu GNOME customizations (gsettings overrides, Control Center changes, etc) to a separate package (e. g. ubuntu-default-settings) would also make other Ubuntu-based distributions developer's live easier.
I'm Baltix GNU/Linux distribution developer and it was pretty hard for me to find all Ubuntu GNOME customizations in 12.04 version, I need to know these changes because since 2012 Baltix has both - Unity and Gnome desktop environments in one CD, see lp:~baltix-members/baltix-default-settings/ubuntu-defaults-baltix

Jeremy Bicha (jbicha) wrote :

ubuntu-default-settings is now in Quantal. Now we just need it to get into main and have ubuntu-desktop depend or recommend it.

affects: ubuntu → ubuntu-default-settings (Ubuntu)
Changed in ubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released

From a MIR perspective, this is fine.

summary: - [needs-packaging] ubuntu-default-settings
+ [needs-packaging, MIR] ubuntu-default-settings
Changed in ubuntu-default-settings (Ubuntu):
status: Fix Released → Fix Committed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - [needs-packaging, MIR] ubuntu-default-settings
+ [needs-packaging] [needs-packaging, MIR] ubuntu-default-settings
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Wishlist

Adding an ubuntustudio task. It was suggested that ubuntustudio could simply depend on ubuntu-default-setttings to keep the status quo. Alternatively, they could be more selective about what settings they'd like to copy to ubuntustudio-default-settings.

See also https://lists.ubuntu.com/archives/ubuntu-release/2012-September/001875.html

Michael Terry (mterry) on 2012-09-07
summary: - [needs-packaging] [needs-packaging, MIR] ubuntu-default-settings
+ [needs-packaging] [MIR] ubuntu-default-settings
Changed in ubuntustudio-meta (Ubuntu):
assignee: nobody → Len Ovens (len-ovenwerks)
status: New → In Progress
Changed in ubuntustudio-meta (Ubuntu):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntustudio-meta (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2012-09-11
Changed in ubuntustudio-meta (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

ubuntu-default-settings 12.10.0 in quantal: universe/x11 -> main
ubuntu-default-settings 12.10.0 in quantal amd64: universe/x11/optional -> main
ubuntu-default-settings 12.10.0 in quantal armel: universe/x11/optional -> main
ubuntu-default-settings 12.10.0 in quantal armhf: universe/x11/optional -> main
ubuntu-default-settings 12.10.0 in quantal i386: universe/x11/optional -> main
ubuntu-default-settings 12.10.0 in quantal powerpc: universe/x11/optional -> main
Override [y|N]? y
6 publications overridden.

Changed in ubuntu-default-settings (Ubuntu):
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-09-11
Changed in ubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-09-11
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.281

---------------
ubuntu-meta (1.281) quantal; urgency=low

  * Refreshed dependencies
  * Added ubuntu-default-settings to desktop (LP: #1039792)
 -- Didier Roche <email address hidden> Tue, 11 Sep 2012 19:48:15 +0200

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Julien Olivier (julo) wrote :

It seems like some overrides are still in their original package in addition to being into ubuntu-settings. For example, /usr/share/glib-2.0/schemas/10_gsettings-desktop-schemas.gschema.override is still installed by gsettings-desktop-schemas but its content is already present in ubuntu-settings.

Julien Olivier (julo) wrote :

Please see bug #1052464 about the presence of the file /usr/share/glib-2.0/schemas/10_gsettings-desktop-schemas.gschema.override in gsettings-desktop-schemas.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers