network config feature (please export /etc/network/interfaces.d to writable)

Bug #1405795 reported by Mitsuya Shibata on 2014-12-26
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Snappy
High
Unassigned
ubuntu-core-config (Ubuntu)
Undecided
James Hunt

Bug Description

At the moment /etc/network/interfaces.d/ is read-only, and eth0 only works with
dhcp server.

---
/etc/network/interfaces.d/eth0:
auto eth0
iface eth0 inet dhcp
---

However I would like to setup static ip address to eth0 via cloud-init or any
like so.

Please to export /etc/network/interfaces.d as writable, or symbolic link this
directory to /writable/interfaces.d.

Related branches

description: updated
Alexander Sack (asac) wrote :

agreed that we should have something for network config.

cloud-init sounds like valid idea to look into.

Changed in snappy-ubuntu:
status: New → Confirmed
importance: Undecided → High
summary: - please export /etc/network/interfaces.d to writable
+ network config feature (please export /etc/network/interfaces.d to
+ writable)
Alexander Sack (asac) wrote :

middleware/service options we should check out:

 1. ifupdown - oldschool debian style
 2. systemd-network - http://www.freedesktop.org/software/systemd/man/systemd.network.html
 3. NM - probably not really wanted for server style networking
 4. ... others like connman etc.

2015-01-01 20:55 GMT+09:00 Alexander Sack <email address hidden>:
> agreed that we should have something for network config.
>
> cloud-init sounds like valid idea to look into.

FYI, cloud-init does not support network config yet?
LP: #1225922

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-core-config (Ubuntu):
status: New → Confirmed

any news about this bug?

James Hunt (jamesodhunt) on 2015-03-06
Changed in ubuntu-core-config (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
status: Confirmed → In Progress
Michael Vogt (mvo) on 2015-03-31
Changed in snappy-ubuntu:
status: Confirmed → Invalid
Changed in ubuntu-core-config (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-core-config - 0.6.8

---------------
ubuntu-core-config (0.6.8) vivid; urgency=low

  [ James Hunt ]
  * Add /etc/network/interfaces.d to writable paths (LP: #1405795).
 -- Michael Vogt <email address hidden> Tue, 31 Mar 2015 14:11:59 +0200

Changed in ubuntu-core-config (Ubuntu):
status: Fix Committed → Fix Released
Michael Terry (mterry) on 2015-05-18
affects: snappy-ubuntu → snappy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers