Ubuntu

FFE: Use font='Ubuntu' as default UI font in default themes

Reported by Paul Sladen on 2010-09-28
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kubuntu-default-settings (Ubuntu)
High
Jonathan Thomas
Maverick
High
Jonathan Thomas
kubuntu-netbook-default-settings (Ubuntu)
High
Jonathan Riddell
Maverick
High
Jonathan Riddell
ubufox (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
ubuntu-artwork (Ubuntu)
High
Ken VanDine
Maverick
High
Ken VanDine

Bug Description

If there is a desire to use the now-seeded 'Ubuntu' font as a default user interface font, then this should be investigated and weighed up, along with the social impacts of doing so.

If the desire was taken to do this, a patch would need to be prepared, and a FFe justified.

This is a FFE request, and the request is to set Ubuntu as the default font for Application, Desktop, and Window Title, and *not* for Document or Fixed Width. This FFE applied originally only to Ubuntu. The same request was made by the Kubuntu Council for Kubuntu, and also implemented.

Paul Sladen (sladen) on 2010-09-28
Changed in light-themes (Ubuntu):
assignee: nobody → Ivanka Majic (ivanka)
description: updated
Changed in light-themes (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Saurabh Gupta (bhaismachine) wrote :

Ah I had no Idea that I could actually change the status of the bug. Please somebody revert it back to the required status since I am unable to do that ! I apologize for this inconvenience caused because of me.

Changed in light-themes (Ubuntu):
status: Triaged → Opinion
description: updated
Paul Sladen (sladen) on 2010-09-28
Changed in light-themes (Ubuntu):
status: Opinion → Triaged
Mark Shuttleworth (sabdfl) wrote :

Am targeting for Maverick as we'd certainly like the font in and as the default. By way of rationale, it's received widespread testing, bug reports are being well triaged and addressed, the fallback pathways for cases where the font does not have characters have been proven to be smooth and non-controversial; all in all, we're ready to do it and the font is looking fantastic!

Appreciate it's, erm, late, but we made the font available for screenshotters through membership and participation in ubuntu-font-interest teams, and the guidance was to produce materials based on the font. It's already in widespread use on the Ubuntu and community websites, like OMG.

Mark

Changed in light-themes (Ubuntu):
importance: Wishlist → High
Salih EMIN (salih-emin) wrote :

Ubuntu Fonts is one of the best things that I've ever came across after so many years using it as my primary and only Linux OS. I am using it in Lucid, through the private PPA available for members and I love it. It distinguish the professional and matured Ubuntu form the old "playground" Ubuntu.
 I hope, and looking forward to see it as default in 10.10
By the way you I think, that every body have to read the hard process that Canonical and Ubuntu community went through accomplishing those beautiful fonts : http://www.markshuttleworth.com/archives/537

Changed in light-themes (Ubuntu Maverick):
assignee: Ivanka Majic (ivanka) → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-10.10

I definitely think we should turn on the font by default for the UI, but not for documents, and not for monospace. In fact, it's my understanding that this was the plan from the outset. It seems the release team is supportive of this change as well.

Changed in light-themes (Ubuntu Maverick):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)

seb - could you please assign this to someone to adjust the setting as appropriate?

@sladen - would you be preparying the freeze exception?

Paul Sladen (sladen) on 2010-09-30
summary: - Consider using font 'Ubuntu' as default
+ FFE: Consider using font 'Ubuntu' as default
Paul Sladen (sladen) on 2010-09-30
summary: - FFE: Consider using font 'Ubuntu' as default
+ FFE: Consider using font='Ubuntu' as default

I think this might have got stuck in a loop where the FFE hasn't been asked for because there isn't a patch, and the patch hasn't been written because there isn't a definite FFE. Lets try to break that vicious cycle and nudge things along.

Kubuntu have decided it's too late for them and that they don't wish to adjust their themes this time again, so this applies solely to GNOME/Ubuntu/light-themes.

Between comment #2 (Mark), action #3.5 (Robbie) comment #4 (Rick) there's pobably enough grounds for requesting a FFE. If the release-team (subscribed) need more justification or background, could I ask one of those people driving this to provide it.

summary: - FFE: Consider using font='Ubuntu' as default
+ FFE: Use font='Ubuntu' as default UI font in light-themes
Changed in light-themes (Ubuntu Maverick):
assignee: Sebastien Bacher (seb128) → Ken VanDine (ken-vandine)

Approved for enabling as default for everything except Documents and Fixed Width.

Changed in light-themes (Ubuntu Maverick):
status: Triaged → Confirmed
description: updated
Ken VanDine (ken-vandine) wrote :

Changing this to ubuntu-artwork, that is the most appropriate package for setting these sort of defaults.

affects: light-themes (Ubuntu Maverick) → ubuntu-artwork (Ubuntu Maverick)
Changed in ubuntu-artwork (Ubuntu Maverick):
status: Confirmed → Triaged
status: Triaged → Confirmed

In comment #4 I said what I think we should do, but here I'll mention why I think we should do this for completeness:

1. The Ubuntu font is a major contribution to Ubuntu and makes the desktop look (in my opinion) significantly nicer.
2. The plan of record has been to set it as default (though the plan was for it to be delivered in the UIF time frame).
3. Guidance had been given to documentation teams, and other folks taking screenshots to use the Ubuntu font, as it would most likely be default.
4. The font is well tested in UI.
5. Setting of default fonts is a simple patch, and easily reverted.

Thanks for your consideration of this late change.

Is there any guidance on the appropriate sizes? I use 11 for each of
these pieces, but I'm not sure if that's the standard for the previous
default font, or just what I've converged on. A quick test suggests 10.5
is good too, 10 being too small.

If there's no existing guidance, I'd ask Otto and MPT to give opinions.

Mark

I use size 10 and it's not too small for me.

fosk (oscarrdg) wrote :

I use 10.5...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-artwork - 53.7

---------------
ubuntu-artwork (53.7) maverick; urgency=low

  * debian/gconf-defaults
    - Set default Application, Window title, and Desktop fonts
    to "Ubuntu" (LP: #649616)
 -- Ken VanDine <email address hidden> Thu, 30 Sep 2010 14:34:06 -0400

Changed in ubuntu-artwork (Ubuntu Maverick):
status: Confirmed → Fix Released
Omer Akram (om26er) wrote :

should this font also be used at gdm level?

After a quick review of the experience folks would have going from Sans
10 to Ubuntu 10, it was decided to go to Ubuntu 11, which is visually
closer in size to the previous default. We may want to go to 10.5 in the
next release, but did not want to do that in this case because the font
size chooser only gives whole-unit measurements in the dropdown (it
accepts x.5 in the text though).

We'll do more rigorous testing during Natty, across more screens, and
take a firmer view for 11.04.

Mark

Mark Shuttleworth (sabdfl) wrote :

 On 30/09/10 20:24, Omer Akram wrote:
> should this font also be used at gdm level?

Yes - good catch.

Ken: could you also investigate/possibly prepare (but not upload) what would need to be done in order to change the default hinting level (the posh manual hinting doesn't get used below "fullhint"). it probably possible to do this either via gconf, or dropping a font-specific match into '/etc/fonts/conf.d/*'.

Again, I'd prefer not to be drawn on the merits, but if the manual hinting is deemed important in order to "show off" the UI font, then it would be good to have this in-hand, ready (it may be more of a case of changing the hinting level on new-installs rather than seeking to change user-selections).

 On 30/09/10 20:37, Paul Sladen wrote:
> Again, I'd prefer not to be drawn on the merits, but if the manual
> hinting is deemed important in order to "show off" the UI font, then it
> would be good to have this in-hand, ready (it may be more of a case of
> changing the hinting level on new-installs rather than seeking to change
> user-selections).

Thanks for raising it Paul. My preference is "Slight" unless we have a
documented rationale for something else.

Mark

A little question: why do you choose to not enable new fonts for "Documents" category?

Just to clarify, note that "Document" here is a GNOME only category for fonts and will be used in Yelp (help viewer), Devhelp (developer help viewer), maybe in Empathy chat window and other GNOME apps. It will not used as default font for OpenOffice.org documents, for instance.

So, what's the matter with "Document" category?

Bilal Akhtar (bilalakhtar) wrote :

I agree with Mark on the fact that Sans 10 is larger than Ubuntu 10 and we need Ubuntu 11 instead. Would definitely be good to see a smooth migration from Sans to Ubuntu, when users upgrade to maverick .

Paul Sladen (sladen) wrote :

Browser defaults too.

Changed in ubufox (Ubuntu Maverick):
status: New → Incomplete
Ken VanDine (ken-vandine) wrote :

Changing the hinting would be trivial, the default it "medium" but for me "slight" does look better. I don't know what kind of implications there are changing this.

Any font gurus want to point out the good/bad of changing the default hinting?

 On 30/09/10 20:56, Luca Ferretti wrote:
> A little question: why do you choose to not enable new fonts for
> "Documents" category?
>
> Just to clarify, note that "Document" here is a GNOME only category for
> fonts and will be used in Yelp (help viewer), Devhelp (developer help
> viewer), maybe in Empathy chat window and other GNOME apps. It will not
> used as default font for OpenOffice.org documents, for instance.

The Regular font is quite assertive, by contrasdt the Ubuntu Light
weight, which we'll have for 11.04, is more elegant. We'll probably use
Light for the Document font.

Mark

Under no circumstance should we change away from slight hinting. That would be nothing less than disastrous.

Many a flamewar was fought around hinting level in the past and after a poll of the community run by Keybuk it was changed to slight with an exception on monospace below 12px for people like mjg59, who categorically refused to accept antialias in the terminal.

I find it hair raising to hear people call for showing off the TrueType instructions. Go ahead if you want to show off that we can now match Win95. TrueType hinting is very much last century tech. I have no idea how many people will find the bytecode hinting useful, but as a default it will be disliked by most. That’s obvious.

Considering the majority of target devices and audience, nothing can beat FreeType autohinter at light setting with default subpixel filter. I.e., no change, please.

The UI font should be 10 again, the 11 font looks ugly...

Halvor, please check that you're using subpixel rendering with "Slight"
hinting.

Mark

Mmh... 11 is to big for me, especially in the menus.

Cedric F. (c-fachinetti) wrote :

ok 10.5 looks good !
Wait for the next release...

Jonathan Riddell (jr) wrote :

Today's kubuntu-default-settings upload sets the Ubuntu font as default in Kubuntu.

https://edge.launchpad.net/ubuntu/+source/kubuntu-default-settings/1:10.10ubuntu10

Thanks for a lovely font!

Thanks Jonathan, and thanks for taking it up despite the late offer :-)

11 is huge for 1024x768 (14"), let alone 1024x600 (10"). The first time I cranked my font size up (to, ahem, eleven) in a long time was when I upgraded to 2560x1440 on 27". (All with slight subpixel rendering.)

Ultimately the answer is not choosing the right font size, it's displaying it correctly based on your DPI. Wonder if it's safe to rely on Xorg DPI reports yet... or determine the likelihood of incorrect responses.

I'd suggest sticking with 10 and try to deal with better behaviour for higher DPI screens in Natty.

Jeff, agreed, we need to be much smarter about picking sizes based on
what screen they are using.

kubuntu-default-settings (1:10.10ubuntu10) maverick; urgency=low

  * Switch to the Ubuntu font as the default font, as approved by the
    Kubuntu Council (bug #649616)
  * Add a dependency on ttf-ubuntu-font-family for the above
 -- Jonathan Thomas <email address hidden> Thu, 30 Sep 2010 18:12:38 -0400

Changed in kubuntu-default-settings (Ubuntu Maverick):
importance: Undecided → High
milestone: none → ubuntu-10.10
status: New → Fix Released
summary: - FFE: Use font='Ubuntu' as default UI font in light-themes
+ FFE: Use font='Ubuntu' as default UI font in default themes
description: updated
Changed in kubuntu-default-settings (Ubuntu Maverick):
assignee: nobody → Jonathan Thomas (echidnaman)
Paul Sladen (sladen) wrote :

kubuntu-netbook-default-settings (10.10.5) maverick; urgency=low

  * Switch Netbook to Ubuntu font too, LP: #649616
 -- Jonathan Riddell <email address hidden> Fri, 01 Oct 2010 12:10:04 +0100

Changed in kubuntu-netbook-default-settings (Ubuntu Maverick):
assignee: nobody → Jonathan Riddell (jr)
importance: Undecided → High
milestone: none → ubuntu-10.10
status: New → Fix Released
Paul Sladen (sladen) wrote :

Sounds like document-viewing fonts will be looked at when eg. Ubuntu Light and Ubuntu Medium are available.

Changed in ubufox (Ubuntu Maverick):
status: Incomplete → Invalid
Luca Ferretti (elle.uca) wrote :

11 pt for could too big for netbook (1024 pixels width) and Unity. The attached picture shows Unity in Italian language: as you can see there is a "Altro" label falling outside the header area. Note that when translated in non-english language, strings could increase their length up to 30%

Paul Sladen (sladen) wrote :

If people are suggesting sizes like 10.5 pt, perhaps the answer is that the offered menu of sizes would be based on using the *pixels-per-em* as the granularity (these are ultimately the hint choices that the rendering infrastructure is going to be rounding/working to).

Based on the "standard" 72 pt/96 dpi (72pt == 1 inch), we have a one 1 pt increase equal to 4/3 pixels-per-em increase:

  * 9.0 pt -> 12 ppm (12.00)
  * 10.0 pt -> 13 ppm (13.33)
  * 10.5 pt -> 14 ppm (14.00) <-- one that is wanted, being skipped
  * 11.0 pt -> 15 ppm (14.67)

Since this bug is fixed, it would probably be more productive to move
discussion of further changes to a different bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers