[regression] ubuntu-app-launch doesn't launch apps any more

Bug #1654915 reported by Daniel van Vugt on 2017-01-09
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
ubuntu-app-launch (Ubuntu)
Medium
Unassigned

Bug Description

[regression] ubuntu-app-launch doesn't launch apps any more:

$ ubuntu-app-launch mir_demo_client_egltriangle

** (process:6198): WARNING **: Unable to start app 'mir_demo_client_egltriangle': AppID is empty

<HANGS>
^C

$ mir_demo_client_egltriangle -- --desktop_file_hint=unity8
<WORKS>

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: ubuntu-app-launch 0.9+17.04.20161110.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
Date: Mon Jan 9 10:32:29 2017
InstallationDate: Installed on 2016-11-03 (67 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161102)
SourcePackage: ubuntu-app-launch
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
tags: added: unity8-desktop
Changed in canonical-devices-system-image:
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-app-launch (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

The error message has changed very slightly now, but still the same bug:

$ ubuntu-app-launch mir_demo_client_egltriangle
terminate called after throwing an instance of 'std::runtime_error'
  what(): AppID is empty
Aborted (core dumped)

dobey (dobey) on 2017-02-01
Changed in ubuntu-app-launch (Ubuntu):
importance: Critical → Medium
dobey (dobey) wrote :

This never would have worked, as the mir demos do not have .desktop files for them. Also App IDs cannot have _ in the appname or package name portion of the ID, as it is a separator. The format for App IDs is "${packagename}_${appname}_${version}" and so _ is not a valid character.

If you want to launch these apps via ubuntu-app-launch, then they need to have .desktop files named as "mir-demo-client-egltriangle.desktop" for your example, then you could do "ubuntu-app-launch mir-demo-client-egltriangle" and it would work.

You can only run applications with ubuntu-app-launch which appear in the list output by ubuntu-app-launch-appids.

Changed in ubuntu-app-launch (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

That's a very surprising (and possibly incorrect?) answer.

I believed that the whole purpose of ubuntu-app-launch is to run apps that don't have desktop files. If my app had a desktop file then I would not bother using ubuntu-app-launch :)

Changed in ubuntu-app-launch (Ubuntu):
status: Incomplete → Confirmed
Daniel van Vugt (vanvugt) wrote :

Actually it sounds like you're describing snaps. I am describing the deb-based Ubuntu 17.04 desktop here.

Gerry Boland (gerboland) wrote :

@duflu dobey is correct, UAL only launches apps with a valid desktop file.

Daniel van Vugt (vanvugt) wrote :

OK, well last time I asked (a long time ago) saviq said ubuntu-app-launch was the way to launch apps that have no desktop file. And until this year it worked too.

So what's the correct way now? Is there one? Should we try and modify `mirrun'?

Ted Gould (ted) wrote :

ubuntu-app-test will launch a utility under Unity8.

Changed in ubuntu-app-launch (Ubuntu):
status: Confirmed → Incomplete
Changed in canonical-devices-system-image:
status: Confirmed → Won't Fix
Changed in ubuntu-app-launch (Ubuntu):
status: Incomplete → Won't Fix
Daniel van Vugt (vanvugt) wrote :

Thanks for the hint but it seems ubuntu-app-test fails too: bug 1662400

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers