[SRU] ubuntu-advantage-tools (27.1 -> 27.2) Xenial, Bionic, Focal, Hirsute

Bug #1934902 reported by Grant Orndorff
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-advantage-tools (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Fix Released
Undecided
Unassigned
Bionic
Fix Released
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
Hirsute
Fix Released
Undecided
Unassigned
Impish
Fix Released
Undecided
Unassigned

Bug Description

[Impact]
This release sports both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these
improvements. The notable ones are:

  * Schema of `ua status --format=json` has been updated to include more
    information and better organize the information already present.
  * `yaml` is now a format option for `ua status`
  * `http_proxy` and `https_proxy` configuration fields were added
      - When set, `ua` will use the specified proxy.
      - When set, `ua` will configure snap (if installed) and livepatch
        (if enabled) to use the specified proxy
  * `apt_http_proxy` and `apt_https_proxy` configuration fields were added
      - When set, `ua` will configure apt to use the specified proxy
  * `ua refresh` now accepts optional sub commands: `ua refresh contract`
    and `ua refresh config`. `ua refresh contract` does what `ua refresh`
    used to do. `ua refresh config` re-processes the uaclient config file.
    `ua refresh` with no sub command does the equivalent of `ua refresh
    config && ua refresh contract`.
  * `ua config set key=val` is a new command that edits a key in
    uaclient's config file.
  * `ua config unset key` is a new command that removes the value of a key
    uaclient's config file
  * `ua config show` is a new command that shows the current value of
    uaclient config options.

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/UbuntuAdvantageToolsUpdates

The ubuntu-advantage-tools team will be in charge of attaching the artifacts and console output of the appropriate run to the bug. ubuntu-advantage-tools team members will not mark ‘verification-done’ until this has happened.

* Automated Test Results
<TODO>
Attach or link the following automated integration test runs for ubuntu-advantage-tools on each affected LTS release:

- lxd.container platform
- lxd.kvm platform
- AWS Ubuntu PRO
- AWS Ubuntu cloud-images (non-Pro)
- Azure Ubuntu PRO
- Azure Ubuntu cloud-images (non-Pro)
- GCP Ubuntu PRO
- GCP Ubuntu cloud-images (non-Pro)
</TODO>

* Additional Manual tests:
 - upgrade LTS -> LTS attached container + post-upgrade operations
 - upgrade LTS -> LTS unattached container + post-upgrade operations
 - package dependency validation verification for distro-info

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

The changes most likely to produce an unexpected regression are the changes to the output of `ua status --format=json`. We had (and still have) a notice in the output that tools should _not_ rely on the structure of the output of this command; however, we know of at least one tool that does, and others may as well despite the warning. We have avoided changes that we know will break others, but it is possible that we broke some unknown integration.

The behavior of `ua refresh` has slightly changed. It now processes the proxy configuration before refreshing the contract. Since the proxy configuration is also new with this release, it is unlikely that any existing use of `ua refresh` will start doing anything new, unless the user also adds the new proxy config fields.

This update also changes the schema of some of our state that we keep in a json file. We're introducing a basic migration mechanism specifically to avoid anything breaking if the json file on disk is the old version. In the worst case if the migration script doesn't work, then running `ua status` with root privileges will overwrite the existing json file with the new version, which will resolve any problems.

[Discussion]

In this release, we're starting to lay the foundation for more proper schema versioning of `ua status` output. In the future when we need to change the output again, we plan to properly bump the schema version and implement a way to select the version the caller expects. At that time we will remove our warning from the output and start to guarantee version compatibility.

[Changelog]

Release 27.2.1

  * d/control:
    - remove unnecessary distro-info dependency from build-depends
  * d/rules:
    - pick right version of distro-info based on release
  * docs:
    + add information about proxy auth to manpage and readme
  * lib:
    + handle missing configStatus key in patch status json script

Release 27.2

  * d/control:
    - add comments to explain complex build-depends
    - add version requirement to distro-info (LP: #1932028)
  * d/tools.postinst:
    - run status.json schema patch script to avoid non-root status errors
  * New upstream release 27.2:
    - attach: print contract server reason for 403 (GH: #1630)
    - cli: add ua config set, unset and show subcommands
    - config:
      + add default ua_config setting values
      + only allow some fields to be set by envvar
      + use defaults for contract and security url
    - docs:
      + add proxy config options to man page
      + add instructions to generate MOTD messages
      + add support matrix info
      + remove broken api link
    - enable: allow downgrading packages during enable (GH: #1659)
    - fips:
      + add focal test for fips-updates
      + alert if wrong fips package installed on gov clouds
      + install correct fips package on gov clouds
      + only install conditional_packages if necessary and available
    - logs: log env vars that affect config on cli runs
    - proxy:
      + add config options to set proxies
      + print message when setting proxy
      + support configuring apt proxies
      + support configuring snap and livepatch proxies
      + support setting proxy for web requests
      + validate urls before setting as proxies
    - refresh: support refreshing config and contract separately
    - status
      + add config info to json output
      + add env vars to json output
      + do not show unavailable services in json output
      + support yaml format with same content as json format
      + update account info in json output
      + update contract info in json output
      + update root level keys of json output
    - refactor:
      + remove side effects from can_enable (GH: #1654, #1571)
      + use DatetimeAwareJSONDecoder to parse date strings
    - tests:
      + add additional enable test for incompatible services
      + add flag to enable proposed pocket
      + add test to check and print version being tested
      + drop trusty specific tests

description: updated
description: updated
description: updated
Revision history for this message
Chad Smith (chad.smith) wrote :

27.2~21.10.1 released to impish

Changed in ubuntu-advantage-tools (Ubuntu Impish):
status: New → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

As per discussion on IRC, I checked the packages and didn't like the debian/control change of adding a hard-equal version dependency on distro-info (mostly for the xenial case). Since this will break with an update of distro-info then. I'd recommend doing a Depends + Breaks/Conflicts with the unsupported versions of distro-info instead.

Revision history for this message
Chad Smith (chad.smith) wrote :

Thanks again for this. We determined we didn't need to have distro-info in our Build-Depends, which then opened up the possibility to use subst vars via debian/rules to make more simple Depends on Xenial vs Bionic++. This changeset is represented here https://github.com/canonical/ubuntu-advantage-client/commit/4d35b5c4445dc6dba28f7daa3f11ba8c212ea6b2

Chad Smith (chad.smith)
description: updated
Revision history for this message
Steve Langasek (vorlon) wrote : Please test proposed package

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.1~21.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.1~20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Changed in ubuntu-advantage-tools (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Lucas Albuquerque Medeiros de Moura (lamoura) wrote :

This are the test results for the ubuntu-advantage-tools 27.2.1 package.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-hirsute verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-hirsute verification-needed-xenial
description: updated
Revision history for this message
Grant Orndorff (orndorffgrant) wrote :

In addition to the integration test logs. Here are manual test logs verifying the correct versions of distro-info are installed on xenial and bionic, as described in https://bugs.launchpad.net/ubuntu/+source/ubuntu-advantage-tools/+bug/1932028

Revision history for this message
Grant Orndorff (orndorffgrant) wrote :

Please note that this release also fixes #1932028 and #1930741 even though they don't show up on the Pending SRU Page under Changelog Bugs.

Revision history for this message
Brian Murray (brian-murray) wrote :

Dear fellow Ubuntu SRU team member please confirm that LP: #1932028 and LP: #1930741 are also verified before releasing this package to -updates for any release. Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.1~21.04.1

---------------
ubuntu-advantage-tools (27.2.1~21.04.1) hirsute; urgency=medium

  * Backport new upstream release: (LP: #1934902) to hirsute

 -- Chad Smith <email address hidden> Fri, 16 Jul 2021 12:49:23 -0600

Changed in ubuntu-advantage-tools (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for ubuntu-advantage-tools has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.1~20.04.1

---------------
ubuntu-advantage-tools (27.2.1~20.04.1) focal; urgency=medium

  * Backport new upstream release: (LP: #1934902) to focal

 -- Chad Smith <email address hidden> Fri, 16 Jul 2021 12:48:51 -0600

Changed in ubuntu-advantage-tools (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.1~18.04.1

---------------
ubuntu-advantage-tools (27.2.1~18.04.1) bionic; urgency=medium

  * Backport new upstream release: (LP: #1934902) to bionic

 -- Chad Smith <email address hidden> Fri, 16 Jul 2021 12:48:22 -0600

Changed in ubuntu-advantage-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.1~16.04.1

---------------
ubuntu-advantage-tools (27.2.1~16.04.1) xenial; urgency=medium

  * Backport new upstream release: (LP: #1934902) to xenial

 -- Chad Smith <email address hidden> Fri, 16 Jul 2021 12:47:53 -0600

Changed in ubuntu-advantage-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Robie Basak (racb) wrote :

This update is being pulled from all stable releases due to regression bug 1936833.

Changed in ubuntu-advantage-tools (Ubuntu Xenial):
status: Fix Released → Triaged
Changed in ubuntu-advantage-tools (Ubuntu Bionic):
status: Fix Released → Triaged
Changed in ubuntu-advantage-tools (Ubuntu Focal):
status: Fix Released → Triaged
Changed in ubuntu-advantage-tools (Ubuntu Hirsute):
status: Fix Released → Triaged
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.2~21.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Hirsute):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-hirsute
removed: verification-done verification-done-hirsute
Changed in ubuntu-advantage-tools (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed-focal
removed: verification-done-focal
Revision history for this message
Robie Basak (racb) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.2~20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Revision history for this message
Robie Basak (racb) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.2~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-advantage-tools (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed-xenial
removed: verification-done-xenial
Revision history for this message
Robie Basak (racb) wrote :

Hello Grant, or anyone else affected,

Accepted ubuntu-advantage-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-advantage-tools/27.2.2~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-hirsute verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-hirsute verification-needed-xenial
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.2~16.04.1

---------------
ubuntu-advantage-tools (27.2.2~16.04.1) xenial; urgency=medium

  * Backport new upstream fix: (LP: #1936833) to xenial
    - Fix regression introduced on 27.2.1 (LP: #1934902)

ubuntu-advantage-tools (27.2.2~21.10.1) impish; urgency=medium

  * d/tools.postinst:
    - Do not fail in postinst if cloud-init did not run.
      This fixes the regression introduced in 27.2.1. (LP: #1936833)

 -- Lucas Moura <email address hidden> Tue, 27 Jul 2021 10:50:52 -0300

Changed in ubuntu-advantage-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.2~20.04.1

---------------
ubuntu-advantage-tools (27.2.2~20.04.1) focal; urgency=medium

  * Backport new upstream fix: (LP: #1936833) to focal
    - Fix regression introduced on 27.2.1 (LP: #1934902)

ubuntu-advantage-tools (27.2.2~21.10.1) impish; urgency=medium

  * d/tools.postinst:
    - Do not fail in postinst if cloud-init did not run.
      This fixes the regression introduced in 27.2.1. (LP: #1936833)

 -- Lucas Moura <email address hidden> Tue, 27 Jul 2021 10:54:59 -0300

Changed in ubuntu-advantage-tools (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.2~18.04.1

---------------
ubuntu-advantage-tools (27.2.2~18.04.1) bionic; urgency=medium

  * Backport new upstream fix: (LP: #1936833) to bionic
    - Fix regression introduced on 27.2.1 (LP: #1934902)

ubuntu-advantage-tools (27.2.2~21.10.1) impish; urgency=medium

  * d/tools.postinst:
    - Do not fail in postinst if cloud-init did not run.
      This fixes the regression introduced in 27.2.1. (LP: #1936833)

 -- Lucas Moura <email address hidden> Tue, 27 Jul 2021 10:53:16 -0300

Changed in ubuntu-advantage-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-advantage-tools - 27.2.2~21.04.1

---------------
ubuntu-advantage-tools (27.2.2~21.04.1) hirsute; urgency=medium

  * Backport new upstream fix: (LP: #1936833) to hirsute
    - Fix regression introduced on 27.2.1 (LP: #1934902)

ubuntu-advantage-tools (27.2.2~21.10.1) impish; urgency=medium

  * d/tools.postinst:
    - Do not fail in postinst if cloud-init did not run.
      This fixes the regression introduced in 27.2.1. (LP: #1936833)

 -- Lucas Moura <email address hidden> Tue, 27 Jul 2021 10:57:27 -0300

Changed in ubuntu-advantage-tools (Ubuntu Hirsute):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers