After upgrade from 16.04 LTS (ESM with disabled UA) to 18.04 LTS (supported) all mentions of ESM should be removed from the system

Bug #1928531 reported by Norbert
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
distro-info (Ubuntu)
Undecided
Unassigned
ubuntu-advantage-tools (Ubuntu)
Low
Unassigned
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

It is really strange to have ESM enabled on the 18.04 LTS which is supported.

Currently I have:

```
$ dpkg -S esm | grep ubuntu-advantage-tools
ubuntu-advantage-tools: /usr/lib/ubuntu-advantage/apt-esm-hook
ubuntu-advantage-tools: /usr/share/keyrings/ubuntu-advantage-esm-apps.gpg
ubuntu-advantage-tools: /etc/update-motd.d/91-contract-ua-esm-status
ubuntu-advantage-tools: /usr/lib/ubuntu-advantage/apt-esm-json-hook
ubuntu-advantage-tools: /usr/lib/python3/dist-packages/uaclient/entitlements/esm.py
ubuntu-advantage-tools: /etc/apt/apt.conf.d/20apt-esm-hook.conf
ubuntu-advantage-tools: /usr/share/keyrings/ubuntu-advantage-esm-infra-trusty.gpg
ubuntu-advantage-tools: /etc/update-motd.d/88-esm-announce

$ sudo grep -r esm /etc/
/etc/update-motd.d/88-esm-announce:stamp="/var/lib/ubuntu-advantage/messages/motd-esm-announce"
/etc/update-motd.d/91-contract-ua-esm-status:stamp="/var/lib/ubuntu-advantage/messages/motd-esm-service-status"
/etc/ubuntu-advantage/help_data.yaml:esm-apps:
/etc/ubuntu-advantage/help_data.yaml: its end of life. You can find out more about the esm service at
/etc/ubuntu-advantage/help_data.yaml: https://ubuntu.com/security/esm
/etc/ubuntu-advantage/help_data.yaml:esm-infra:
/etc/ubuntu-advantage/help_data.yaml: esm-infra provides access to a private ppa which includes available high
/etc/ubuntu-advantage/help_data.yaml: You can find our more about the esm service at
/etc/ubuntu-advantage/help_data.yaml: https://ubuntu.com/security/esm
/etc/apt/sources.list.d/ubuntu-esm-infra.list.distUpgrade:deb https://esm.ubuntu.com/infra/ubuntu xenial-infra-security main
/etc/apt/sources.list.d/ubuntu-esm-infra.list.distUpgrade:# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-security main
/etc/apt/sources.list.d/ubuntu-esm-infra.list.distUpgrade:deb https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates main
/etc/apt/sources.list.d/ubuntu-esm-infra.list.distUpgrade:# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates main
/etc/apt/sources.list.d/ubuntu-esm-infra.list:deb https://esm.ubuntu.com/infra/ubuntu bionic-infra-security main
/etc/apt/sources.list.d/ubuntu-esm-infra.list:# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-security main
/etc/apt/sources.list.d/ubuntu-esm-infra.list:deb https://esm.ubuntu.com/infra/ubuntu bionic-infra-updates main
/etc/apt/sources.list.d/ubuntu-esm-infra.list:# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates main
/etc/apt/apt.conf.d/20apt-esm-hook.conf: "[ ! -f /usr/lib/ubuntu-advantage/apt-esm-hook ] || /usr/lib/ubuntu-advantage/apt-esm-hook post-invoke-stats || true";
/etc/apt/apt.conf.d/20apt-esm-hook.conf: "[ ! -f /usr/lib/ubuntu-advantage/apt-esm-hook ] || /usr/lib/ubuntu-advantage/apt-esm-hook post-invoke-success || true";
/etc/apt/apt.conf.d/20apt-esm-hook.conf: "[ ! -f /usr/lib/ubuntu-advantage/apt-esm-hook ] || /usr/lib/ubuntu-advantage/apt-esm-hook pre-invoke || true";
/etc/apt/apt.conf.d/20apt-esm-hook.conf: "[ ! -f /usr/lib/ubuntu-advantage/apt-esm-json-hook ] || /usr/lib/ubuntu-advantage/apt-esm-json-hook || true";
Binary file /etc/apt/trusted.gpg.d/ubuntu-advantage-esm-infra-trusty.gpg matches

```

Having `https://esm.ubuntu.com/infra/ubuntu bionic-infra-updates` in sources.list is strange.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-advantage-tools 27.0.2~18.04.1
ProcVersionSignature: Ubuntu 4.15.0-143.147-generic 4.15.18
Uname: Linux 4.15.0-143-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.23
Architecture: amd64
CurrentDesktop: MATE
Date: Sat May 15 10:59:54 2021
InstallationDate: Installed on 2018-08-07 (1011 days ago)
InstallationMedia: Ubuntu-MATE 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: ubuntu-advantage-tools
UpgradeStatus: Upgraded to bionic on 2021-05-15 (0 days ago)

Revision history for this message
Norbert (nrbrtx) wrote :
summary: - After upgrade from 16.04 LTS (ESM) to 18.04 LTS (supported) all mentions
- of ESM should be removed from the system
+ After upgrade from 16.04 LTS (ESM with disabled UA) to 18.04 LTS
+ (supported) all mentions of ESM should be removed from the system
Revision history for this message
Norbert (nrbrtx) wrote :

The same happens on Ubuntu Desktop 16.04 LTS → 18.04 LTS upgrade.
So using flavor is not an issue.

Revision history for this message
Richard Harding (rharding) wrote :

Thank you for the feedback. We have debated the risk/reward of removing things on upgrade, however since it doesn't do any harm and the end-user has enabled a feature it can carry forward cleanly. Going in and running a `ua disable esm-infra` after the user turned it on seemed a bit too far and the end-user can run the disable command if they'd like to.

We'll do some more research on the best experience here and appreciate the heads up that it struck you as odd.

Changed in ubuntu-advantage-tools (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in distro-info (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in distro-info (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers