ubuntu_qrt_apparmor test failed on T-LTS ARM64 / PowerPC

Bug #1851651 reported by Po-Hsu Lin on 2019-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
ubuntu-advantage-tools (Ubuntu)
Undecided
Unassigned

Bug Description

This issue was spotted on ARM64 / Power8 with T-LTS ESM (passed with AMD64 / i386)

The source ppa was added by the same algorithm across all the arches.

ubuntu_qrt_apparmor test failed in early setup stage with:
W: Failed to fetch https://esm.ubuntu.com/ubuntu/dists/trusty-infra-security/InRelease Unable to find expected entry 'main/binary-ppc64el/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch https://esm.ubuntu.com/ubuntu/dists/trusty-infra-updates/InRelease Unable to find expected entry 'main/binary-ppc64el/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Po-Hsu Lin (cypressyew) on 2019-11-07
tags: added: arm64 ppc64el sru-20191021 ubuntu-qrt-apparmor
tags: added: 4.4
tags: added: trusty
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1851651

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

There is a /etc/apt/sources.list.d/ubuntu-esm-infra-trusty.list that's causing this issue.

# Written by ubuntu-advantage-tools
deb https://esm.ubuntu.com/ubuntu trusty-infra-security main
# deb-src https://esm.ubuntu.com/ubuntu trusty-infra-security main

deb https://esm.ubuntu.com/ubuntu trusty-infra-updates main
# deb-src https://esm.ubuntu.com/ubuntu trusty-infra-updates main

Therefore I will include ubuntu-advantage-tools here.

Po-Hsu Lin (cypressyew) wrote :

I can confirm that this list will be added when updating the ubuntu-advantage-tools.

Po-Hsu Lin (cypressyew) wrote :

Looks like a dup of bug 1851858

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers