ubuntu-advantage enable-esm should ensure correct package requirements are met

Bug #1840091 reported by Chris Johnston on 2019-08-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-advantage-tools (Ubuntu)
High
Unassigned

Bug Description

To use ESM for 14.04 you must install 1.0.1ubuntu2.23 of apt apt-transport-https apt-utils libapt-inst1.5 libapt-pkg4.12

These should be checked and warn/error/install the correct packages when running enable-esm

Chris Johnston (cjohnston) wrote :

I've seen this easily > a dozen times

Steve Langasek (vorlon) wrote :

I agree, this should be addressed with appropriate versioned dependencies from the package so that selective installation of packages from trusty-updates doesn't leave you with a broken package.

Changed in ubuntu-advantage-tools (Ubuntu):
importance: Undecided → High
status: New → Triaged
Julian Andres Klode (juliank) wrote :

Just add Depends for the version in updates pocket for

- apt
- apt-transport-https
- libapt-pkg4.12

that should be enough.

Having libapt-inst1.5 and apt-utils in there does not hurt; but it's also not strictly necessary.

Julian Andres Klode (juliank) wrote :

The version in trusty-updates being 1.0.1ubuntu2.23, so you want apt (>= 1.0.1ubuntu2.23), and so on

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers