Update notification bar pushes content down

Bug #910448 reported by Eric Keppel on 2011-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 11.10
Release: 11.10
Installed: 11.0~a2~hg20111230r83973-0ubuntu1~umd1~oneiric

Expected Behaviour: no content movement when update restart notification appears

Actual Behavior:
The Update Restart Notification appears at random intervals until Firefox is restarted after installation of an update.

When it appears, it pushes the content on the page down along with it.

If a user was about to click on a particular area of the screen and the notification happens to appear near the moment the user clicks, the content gets pushed down by the notification and the click is registered higher up on the content of the page than intended by the user. This could be very dangerous in certain scenarios, for example on a banking or stock trading site where a single click can involve large amounts of money where a BUY and SELL button are near one another vertically on the page, etc..

It is my recommendation that the notification either remain on-screen until the browser is restarted, not push page content down when it appears, or the user be given the ability to dismiss it for the remainder of the browser's open session.

Related branches

Micah Gersten (micahg) wrote :

This behavior is driven by ubufox, so reassigning

affects: firefox (Ubuntu) → ubufox (Ubuntu)
summary: - Dangerous Behavior - Update Restart Notification
+ Update notification bar pushes content down
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 2.2~r319-0ubuntu1

---------------
ubufox (2.2~r319-0ubuntu1) quantal; urgency=low

  * Update to 2.2~r319
    - Fix LP: #910448 - Update notification bar pushes content down.
      Use a panel for update restart notification instead of the infobar
    - Don't poll for file changes, but use inotify instead to determine
      when we need to display a restart notification
    - Reload plugins after changes in any of the system plugin locations
 -- Chris Coulson <email address hidden> Fri, 29 Jun 2012 18:52:35 +0100

Changed in ubufox (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers