Help -> Report a Problem... does nothing

Bug #877993 reported by Victor Engmark on 2011-10-19
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Unassigned
ubufox (Ubuntu)
Undecided
Unassigned

Bug Description

Clicking this does nothing at all. I expected to see a bug reporting form.

User Agent Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: firefox 7.0.1+build1+nobinonly-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: victor 1867 F.... pulseaudio
 /dev/snd/controlC1: victor 1867 F.... pulseaudio
 /dev/snd/controlC0: victor 1867 F.... pulseaudio
BuildID: 20111008085652
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfb9f8000 irq 76'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,104383c0,00100004'
   Controls : 37
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xfbcfc000 irq 77'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card2.Amixer.info:
 Card hw:2 'U0x46d0x8ce'/'USB Device 0x46d:0x8ce at usb-0000:00:1a.7-6, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08ce'
   Controls : 2
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3072
   Mono: Capture 2414 [79%] [27.42dB] [on]
Channel: release
Date: Wed Oct 19 10:41:14 2011
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions: NoScript - ID={73a6fe31-595d-460b-a920-fcc0f8843232}, Version=2.1.5, minVersion=1.9a2, maxVersion=1.9.6, Location=app-profile, Type=extension, Active=Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.3 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=7.0.1/20111008085652 (Running)
RfKill:

RunningIncompatibleAddons: True
SourcePackage: firefox
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (5 days ago)
dmi.bios.date: 10/04/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0405
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P6X58D-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0405:bd10/04/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6X58D-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Victor Engmark (victor-engmark) wrote :
Victor Engmark (victor-engmark) wrote :

When starting Firefox from the shell, no debug output is produced when clicking Help -> Report a Problem...

Victor Engmark (victor-engmark) wrote :

*All* the other help menu items work.

Victor Engmark (victor-engmark) wrote :

Ah, Ubufox. Can't we bleeping bleep that bleep of an extension? At least as far as bleeping defaults go, it bleeps bleep.

Chris Coulson (chrisccoulson) wrote :

Huh?

Victor Engmark (victor-engmark) wrote :

Oh, just out of all the Firefox extensions I've ever used, that's the only one which has caused problems repeatedly, and of all the default software installed with Ubuntu, it's usually the first one to be disabled permanently. IMO it's a POS.

Robert Roth (evfool) on 2011-10-21
Changed in firefox (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Just disable it then rather than being abusive about it.

affects: firefox (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Invalid
Robert Roth (evfool) wrote :

@Chris Coulson: I'm setting this back to Confirmed, as this is still a valid bug, clicking the Report problem item doesn't do anything. It should either be removed or open a new bug report with apport and launchpad.

Changed in ubuntu:
status: Invalid → Confirmed
Chris Coulson (chrisccoulson) wrote :

Setting back to invalid. It's already fixed in bzr anyway and will be fixed in the next upload. I've no interest in keeping bugs open from people who are rude and ignore the CoC

Changed in ubuntu:
status: Confirmed → Invalid

I'm sorry if that's too harsh. It wasn't my intention to insult anyone. My patience with Ubuntu finally snapped with 11.10 (after using it as the main OS for three years), and Ubufox has since its appearance seemed like one of those bad ideas which are allowed to remain because someone has too much invested in it to remove it (like Unity).

The project page <https://launchpad.net/ubufox> simply describes it as "ubuntu tweaks and extensions" with no more explanation, and the three first pages of a Google search didn't seem to show any pages explaining what this means. After uninstalling it I never noticed any difference in Firefox, so it seemed like unnecessary stability / security / [quality measurement du jour] risk for no discernible gain.

If it's just a meta-extension, then why not install the extensions themselves? If I read the open source community right, it's considered very bad form as a software distributor to install by default a package which installs and removes stuff behind the scenes with each release.

If the tweaks are visual (which is totally understandable to keep a unified graphical experience) why not put them into a theme instead of an inscrutable (except for very paranoid programmers who actually read the code) extension? If the tweaks are more fundamental, why not spend the effort on including them in the Firefox base? I assume the Mozilla developers would be eager to incorporate useful changes by Ubuntu developers.

Maybe this is caring too much about a minor piece of software, but after the Golden Years 2008-2010 Ubufox and Unity seem like symptoms of a reckless approach to improve "shine" while ignoring actual usability. I was expecting to be able to recommend Ubuntu whole-heartedly to all family members in 2011, but with the recent developments that's more unlikely than in 2008.

With regard to keeping bugs open, what difference should it make how the request was worded? As a developer I'm used to dealing with swearing and what looks like snarky and sarcastic text in bug reports - It's a natural deficiency of the medium that we can't feel the frustration of the user who loses the panel shortcuts (11.10 upgrade), has crash bugs without any simple way of reporting what precisely went wrong (Banshee, Pidgin, Evolution et al), or who has to jump through hoops to get to commonly used software (Unity). I don't know whether there exists any communications channel to report such major issues *and* come up with solutions to the improvement of what I still deem (because of 10.04) to be the best distro ever, but I'd be happy to work with the developers rather than just submitting bug reports.

Pierre Rudloff (rudloff) wrote :

Here is the error it produces :
Erreur : firefox is not defined
Fichier Source : chrome://ubufox/content/overlay.js
Ligne : 164

Pierre Rudloff (rudloff) wrote :
affects: ubuntu → ubufox (Ubuntu)
Changed in ubufox (Ubuntu):
status: Invalid → Fix Committed
Changed in ubufox:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 1.0.2-0ubuntu0.11.10.1

---------------
ubufox (1.0.2-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream release.
    - Support Firefox 9 and 10 (LP: #906389)
    - Fix LP: #877993 - Help -> Report a Problem does nothing
 -- Chris Coulson <email address hidden> Tue, 20 Dec 2011 00:34:31 -0600

Changed in ubufox (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2012-11-24
Changed in ubufox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers