about:startpage returns 404 Not Found

Bug #790617 reported by Jean-Baptiste Lallement on 2011-05-31
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu Start Page
Undecided
Unassigned
ubufox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

ISO Testing: Ubuntu Alternate i386/amd64 20110531

When firefox is launched after a fresh installation, it displays the page about:startpage which doesn't exist. The content of the 404 page is:
"""
Not Found

The requested URL /11.10/Google/ was not found on this server.
"""

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: firefox 5.0~b2+build1+nobinonly-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Tue May 31 13:05:59 2011
FirefoxPackages:
 firefox 5.0~b2+build1+nobinonly-0ubuntu2
 flashplugin-installer N/A
 adobe-flashplugin N/A
 icedtea-plugin N/A
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110530)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Micah Gersten (micahg) wrote :

This is due to the start page not being there. Moving to the start page project.

Changed in firefox (Ubuntu):
status: New → Invalid
Charlie Kravetz (charlie-tca) wrote :

This bug affects all Xubuntu images as of 2011-05-31.

tags: added: iso-testing
Daniel Polehn (dpolehn-gmail) wrote :

I am seeing this same problem

Changed in ubuntu-start-page:
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Note, this is a consequence of a recent change I made to ubufox to pick up the distro-version automatically at build time. Previously, the distro version was hardcoded and required patching for each release we ship ubufox on.

affects: firefox (Ubuntu) → ubufox (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9.1-0ubuntu2

---------------
ubufox (0.9.1-0ubuntu2) oneiric; urgency=low

  * Hard-code distro version to Natty for now to work around LP: #790617
    - update defaults/preferences/dist.js
 -- Chris Coulson <email address hidden> Wed, 01 Jun 2011 11:37:55 +0100

Changed in ubufox (Ubuntu):
status: Invalid → Fix Released
Changed in ubuntu-start-page:
assignee: nobody → dpolehn (dpolehn-gmail)
status: Confirmed → In Progress
Micah Gersten (micahg) on 2011-06-02
Changed in ubuntu-release-notes:
status: New → Invalid
bpf (br1-an) wrote :

This has happened again with the latest update to Ubufox today, 25/09/11. Also, all search engines have been removed and replaced with Ask.com - /usr/share/xul-ext/ubufox/searchplugins/ask.xml
The /usr/share/xul-ext/ubufox/searchplugins folder is empty.

Ubuntu 11.10 b2
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
<email address hidden> version 1.0-0ubuntu1

Brian Murray (brian-murray) wrote :

bpf - thanks for this information but this is better reported as a bug about ubufox the package in Ubuntu rather than about the Ubuntu Website Project. Please report a new bug about this - thanks in advance!

Changed in ubuntu-start-page:
assignee: Daniel Polehn (dpolehn-gmail) → nobody
Changed in ubuntu-start-page:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers