Please update links and configs for Natty release

Bug #750305 reported by Nobuto Murata on 2011-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Chris Coulson
ubufox (Ubuntu)
High
Chris Coulson
Natty
High
Chris Coulson

Bug Description

Binary package hint: ubufox

Currently ubufox has links and configurations of 10.10(Maverick) or older releases.
Please update these information for Natty release.

ubufox: 0.9~rc2-0ubuntu12

Nobuto Murata (nobuto) on 2011-04-04
Changed in ubufox (Ubuntu):
assignee: nobody → Nobuto MURATA (nobuto)
status: New → In Progress
Chris Coulson (chrisccoulson) wrote :

Note, this is something I'm already working on (I'm looking at a solution which doesn't hard-code links and version numbers )anymore

Nobuto Murata (nobuto) wrote :

Chris,
OK I will unassign myself. I was planning refresh in old way, hard-code.
On working for refresh, could you consider to fix Bug #572114 at the same time?

Changed in ubufox (Ubuntu):
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Confirmed
affects: ubufox (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → High
status: Confirmed → Triaged
affects: Ubuntu Natty → ubufox (Ubuntu Natty)
Changed in ubufox (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
milestone: none → ubuntu-11.04
Changed in ubufox:
status: New → Fix Committed
assignee: nobody → Chris Coulson (chrisccoulson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9-0ubuntu1

---------------
ubufox (0.9-0ubuntu1) natty; urgency=low

  * New upstream release v0.9
  * All patches are merged in to the upstream branch now

  * Fix LP: #750305 - Please update links and configs for Natty release.
    Rather than doing this manually for every release, we add a dist.js with
    distro information (populated at build time with lsb_release) and just
    do all this automatically.
  * Fix LP: #752364 - Plugin Finder Service never finds anything. Use the
    release info in dist.js to construct the URL, now that this got dropped
    from Firefox
  * Fix LP: #728826 - Update icons to new versions.
  * Drop the pluginGlue.js module. This didn't work, as we can no longer
    use a modules registerSelf method to use nsICategoryManager at startup,
    due to the XPCOM registration changes in Firefox 4. Instead, add
    category entries with the chrome.manifest
  * Fix LP: #709125 - User agent doesn't include Ubuntu in it so
    apt.ubuntu.com doesn't work. We add an extra X-Ubuntu HTTP header in
    requests to apt.ubuntu.com, rather than send this information out in
    every request in the UA string

  * Add build-depend on lsb-release so we can create dist.js
 -- Chris Coulson <email address hidden> Sat, 09 Apr 2011 00:08:51 +0100

Changed in ubufox (Ubuntu Natty):
status: Triaged → Fix Released
Changed in ubufox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers