Ubuntu Firefox Modifications 0.9rc2 interferes with toolbar buttons for other add-ons

Bug #579091 reported by ds on 2010-05-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
High
Chris Coulson

Bug Description

Binary package hint: firefox

Toolbar buttons for add-ons (such as AdBlock Plus, NoScript, and Flashblock) added to the toolbar do not appear in additional Firefox windows when Ubuntu Firefox Modifications 0.9rc2 is enabled. The buttons are present in the toolbar when Firefox is initially launched, but if either a second instance of Firefox is started or File->New Window is selected the buttons are absent from the additional window(s). The buttons also do not appear if a restart of Firefox is performed (using a restart button, rather than closing and reopening Firefox). Disabling Ubuntu Firefox Modifications 0.9rc2 results in the toolbar buttons always being present in all windows. This does not affect statusbar icons, only those in the toolbar. The menus themselves are not affected.
This problem is also seen with Torbutton 1.2.5, but either add-on will cause it independently, regardless of the status of the other.
I am using a 64 bit version of Ubuntu and Firefox.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Tue May 11 19:50:55 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu4
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox

ds (ds332) wrote :
Draycen DeCator (ddecator) wrote :

Thank you for reporting this to Ubuntu. I'm switching this to the 'ubufox' package since it seems to be the cause of this bug.

affects: firefox (Ubuntu) → ubufox (Ubuntu)
Dennis L. (dennis2society) wrote :

I can confirm this one.
Opening new Firefox windows or restarting the program (e.g. after installing/updating addons)
will cause custom controls to disappear (in the newly opened window).
This will only happen with the Ubuntu Firefox Modifications 0.9rc2 enabled. All is fine when it is disabled.

I could reproduce this with the Adblock Plus icon in the toolbar or simply by adding a "Open in new tab"
button to the toolbar, both will be vanished in the new window.

The same thing happened in Ubuntu 9.10, too.
Current system:
Ubuntu 10.04
Firefox 3.6.3
LANG=en_US.UTF-8

Changed in ubufox (Ubuntu):
status: New → Confirmed
Stefan Fleiter (stefan-fleiter) wrote :

This prevents the web.de mailcheck toolbar
in version 1.4.1 from showing.
Deactivating this extension and restarting Firefox cures the problem.

The toolbar can be downloaded here:
https://produkte.web.de/mailcheck/
Simply click on the Firefox logo to install it.

Chris Coulson (chrisccoulson) wrote :

I'm confirming this too as it breaks Test Pilot, which we ship with the beta releases in Natty

Changed in ubufox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu8

---------------
ubufox (0.9~rc2-0ubuntu8) natty; urgency=low

  * Fix LP: #579091 - ubufox interferes with toolbar buttons for other add-ons.
    Don't initialize or assign any value to gBrowser in alternatePlugins.js.
    It runs in the context of browser.xul, so gBrowser will always exist
    once the browser window has loaded
    - add debian/patches/07_dont_mess_with_gbrowser.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Thu, 06 Jan 2011 00:51:35 +0000

Changed in ubufox (Ubuntu):
status: Triaged → Fix Released
Stefan Fleiter (stefan-fleiter) wrote :

Should this bugfix be backported to Lucid (LTS) and Maverick (current) since it causes severe usage restrictions for firefox users who install extensions?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers