Disable "Report a Problem" menu item for the stable release

Bug #557240 reported by Chris Coulson on 2010-04-07
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

As per: https://blueprints.launchpad.net/ubuntu/+spec/desktop-lucid-bug-management

The "Report a Problem" menu items are being disabled before RC. This is being disabled in liblaunchpad-integration, which affects most applications, but this also needs disabling in ubufox

Related branches

affects: Ubuntu Lucid → ubufox (Ubuntu Lucid)
Changed in ubufox (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-10.04
Jason J. Herne (hernejj) wrote :

Hopefully this is a simple as this patch? :) Or were you looking for a more elegant solution?

Jason J. Herne (hernejj) on 2010-04-17
tags: added: patch
Steve Langasek (vorlon) wrote :

This fix appears not to have landed in time for final. Chris, should this be done as an SRU?

Changed in ubufox (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
Philip Muškovac (yofel) wrote :

Patch converted into a debdiff.

Philip Muškovac (yofel) on 2010-07-14
tags: added: lucid
Sebastien Bacher (seb128) wrote :

closing the non lucid task since the change is only for lucid

Changed in ubufox (Ubuntu):
status: Triaged → Invalid
Chris Coulson (chrisccoulson) wrote :

Thanks, I uploaded your change to the queue

Changed in ubufox (Ubuntu Lucid):
status: Triaged → Fix Committed
John Dong (jdong) wrote :

ACK from SRU team for the patch in lucid-proposed (for this and bug 606728)

Accepted ubufox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Lucid:
I have reproduced the problem with ubufox 0.9~rc2-0ubuntu2 in lucid and have verified that the version of ubufox 0.9~rc2-0ubuntu2.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu2.1

---------------
ubufox (0.9~rc2-0ubuntu2.1) lucid-proposed; urgency=low

  [ Philip Muskovac ]
  * Disable Report a Problem menu for stable release (LP: #557240)

  [ Chris Coulson ]
  * Backport change to fix URL template used for about:home; this fixes the
    problem that Yahoo about:home cannot be reached; also we get rid of the
    redirect everyone is getting on about:home to the Google/ url (LP: #606728)
    - update components/aboutHome.js
 -- Chris Coulson <email address hidden> Wed, 28 Jul 2010 15:02:57 +0100

Changed in ubufox (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers