FFe: ubufox 0.8 leaves FF 3.0 folder in /etc

Bug #493805 reported by Fernando Miguel on 2009-12-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: ubufox

in a clean lucid install theres a folder in /etc

$ ls -lR /etc/firefox-3.0/
/etc/firefox-3.0/:
total 4.0K
drwxr-xr-x 2 root root 4.0K 2009-11-30 07:56 pref/

/etc/firefox-3.0/pref:
total 8.0K
-rw-r--r-- 1 root root 246 2009-09-18 21:54 apturl.js
-rw-r--r-- 1 root root 299 2009-10-12 15:15 ubufox.js

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 7 22:45:33 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091130)
NonfreeKernelModules: nvidia
Package: ubufox 0.8-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
SourcePackage: ubufox
Tags: lucid
Uname: Linux 2.6.32-6-generic x86_64

Related branches

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

summary: - [lucid] ubufox leaves FF 3.0 folder in /etc
+ ubufox 0.8 leaves FF 3.0 folder in /etc
Changed in ubufox (Ubuntu):
importance: Undecided → Low
status: New → Triaged
milestone: none → ubuntu-10.04-beta-1
kecsap (csaba-kertesz) on 2010-02-17
Changed in ubufox (Ubuntu):
assignee: nobody → kecsap (csaba-kertesz)
kecsap (csaba-kertesz) wrote :
Changed in ubufox (Ubuntu):
status: Triaged → In Progress
tags: added: patch
kecsap (csaba-kertesz) wrote :

Please Alexander, review and merge my previously added patch.

Changed in ubufox (Ubuntu Lucid):
assignee: kecsap (csaba-kertesz) → Alexander Sack (asac)
Steve Langasek (vorlon) on 2010-03-17
Changed in ubufox (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → none
Benjamin Drung (bdrung) wrote :

The patch is not the solution. The ubufox.js configuration is still required, but it's not in the correct directory. It will be moved into /etc/xul-ext sooner or later.

Changed in ubufox (Ubuntu Lucid):
assignee: Alexander Sack (asac) → nobody
Benjamin Drung (bdrung) on 2010-04-13
summary: - ubufox 0.8 leaves FF 3.0 folder in /etc
+ FFe: ubufox 0.8 leaves FF 3.0 folder in /etc
Changed in ubufox (Ubuntu Lucid):
status: In Progress → New
Benjamin Drung (bdrung) wrote :

Because asac considered the changes as new features, I hereby request a freeze exception. It will fix this bug and will increase the consistency of the XUL extensions. I have uploaded it into my PPA [1] and tested. I consider these changes as safe.

[1] https://launchpad.net/~bdrung/+archive/ppa

Martin Pitt (pitti) wrote :

Do we really need to rename the package this close to release? Also note that moving a conffile and renaming a package at the same time needs a much more complicated conffile handling. In particular, you must pay very close attention to the package names that you specify in the mv_conffile function calls.

Please note that you call "prep_mv_conffile mypackage", which is guaranteed to not work :)

Also, is specifying MOZ_EXTENSION_PKG in debian/rules really obsolete now? (I don't know, just checking)

The other changes look fine to me, thanks!

Steve Langasek (vorlon) wrote :

> * Rename binary package from ubufox to xul-ext-ubufox according to new policy.

Please drop this change. It's an obviously correct thing to do, but much too late in this cycle for us to be messing with the names of seeded packages.

Otherwise, the changes look fine wrt FF, though this is definitely a low-priority bugfix - I assumed the file would be moved to some other existing directory, rather than to a new directory used just for this, but I guess there's no good directory for that. If you feel it's important to have this for lucid, then go ahead with the upload.

Changed in ubufox (Ubuntu Lucid):
status: New → Confirmed
Benjamin Drung (bdrung) wrote :

Ups, I forgot to subscribe to this bug.

MOZ_EXTENSION_PKG is not required, because the first binary package will be used by default.

Every xul extension that has a config file (e.g. xul-ext-adblock-plus or xul-ext-notify) will put it into /etc/xul-ext.

I will drop the rename and fix prep_mv_conffile mypackage.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu2

---------------
ubufox (0.9~rc2-0ubuntu2) lucid; urgency=low

  * Bump Standards-Version to 3.8.4.
  * Drop XS- prefix from Vcs-Bzr.
  * Drop zip from Build-Depends.
  * Use new features of mozilla-devscripts 0.16.
  * Simplify debian/rules.
  * Refer to versioned license file.
  * Add Homepage field.
  * Add set -e and debhelper token to preinst script.
  * Move configuration file from /etc/firefox-3.0/pref/ubufox.js to
    /etc/xul-ext/ubufox (LP: #493805).
  * Remove unused patch system.
  * Switch to dpkg-source 3.0 (quilt) format.
 -- Benjamin Drung <email address hidden> Thu, 15 Apr 2010 14:22:58 +0200

Changed in ubufox (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers