Ubufox should list Adobe flash as first choice

Bug #371800 reported by slavic on 2009-05-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
Wishlist
Alexander Sack

Bug Description

Ubuntu 9.04

When i first started firefox ubuntu asked me to find necessary plug-ins for showing full content.

it installed shockwave flash player. And firefox began to run slowly and wasn't able to show all flash content.
I deleted that package and installed adobe flash player and now firefox run smoothly...

Better install by default adobe flash instead of shockwave flash player. shockwave is not compatible with most flash content.

TEST CASE:
1. Go to Flash Site without any flash plugin installed with ubufox installed
2. Click Install Missing Plugins
3. 1st on list is swfdec, user thinks this should be Adobe Flash

slavic (slavic-oe) on 2009-05-04
description: updated
Adam Niedling (krychek) wrote :

There is no shockwave plugin for Linux. Maybe you're thinking about the open source flash player which is not as good as the adobe one. Since the user is allowed to choose freely I don't think this is a bug.

slavic (slavic-oe) wrote :

well.. in my plug-in list from firefox it was named as Shockwave Flash ver.9 .

Problem is that Firefox can't see adobe flash player ver.10 when default plug-in is installed, and i spent a lot of time searching that plug-in in synaptic.

I think is better to not provide any plug-in , instead of installing a plug-in that doesn't work properly...

Micah Gersten (micahg) wrote :

Ubufox controls the plugins search.

affects: ubuntu → ubufox (Ubuntu)
summary: - firefox and flash player
+ Ubufox should install Adobe flash by default
C de-Avillez (hggdh2) on 2009-05-12
Changed in ubufox (Ubuntu):
importance: Undecided → Wishlist
Micah Gersten (micahg) on 2009-05-12
description: updated
C de-Avillez (hggdh2) on 2009-05-12
Changed in ubufox (Ubuntu):
status: New → Triaged

I don't know if the plugins show up in random order, but Adobe was first in the list in Intrepid, and now Swfdec is first in the list in Jaunty.

Swfdec really shouldn't be first, since unsuspecting users might be misled into thinking that it works and actually install it.

summary: - Ubufox should install Adobe flash by default
+ Ubufox should list Adobe flash as first choice
Alexander Sack (asac) wrote :

we have a hook in the plugin db that assigns priorities to certain packages. we had that for flashplugin-nonfree, but now that we use flashplugin-installer as the package name thats not true anymore. I will fix this.

Changed in ubufox (Ubuntu):
assignee: nobody → Alexander Sack (asac)
status: Triaged → In Progress
John Vivirito (gnomefreak) wrote :

Akexander i dont have bug numbers handy but this should also fix the upgrade to Jaunty bugs as well i would think.

Alexander Sack (asac) wrote :

Committing to: bzr+ssh://<email address hidden>/~asac/ubufox/main/
modified pfs/db/plugindb.py
Committed revision 165.

Changed in ubufox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.8~a1-0ubuntu1

---------------
ubufox (0.8~a1-0ubuntu1) karmic; urgency=low

  * new upstream snapshot 0.8a1 for karmic; fixes:
    - LP: #363798 - ubufox can't install adobe flash plugin on 64-bit jaunty live-cd
    - LP: #371800 - Ubufox should list Adobe flash as first choice
    - LP: #347972 - Does not work with Shiretoko Web Browser (Firefox 3.5)
    - LP: #394737 - Cannot be installed with firefox-3.5
  * LP: #399227 - update karmic homepage to http://start.ubuntu.com/9.10
    - update content/startpage.html

 -- Alexander Sack <email address hidden> Tue, 14 Jul 2009 13:05:08 +0200

Changed in ubufox (Ubuntu):
status: Fix Committed → Fix Released
Andrew (and471) wrote :

This has broken again for me, swfdec is first (karmic alpha-4)

Changed in ubufox (Ubuntu):
status: Fix Released → Confirmed

On Sun, Aug 16, 2009 at 11:09:18AM -0000, rugby471 wrote:
> This has broken again for me, swfdec is first (karmic alpha-4)
>
> ** Changed in: ubufox (Ubuntu)
> Status: Fix Released => Confirmed
>

Hmm ... please open a new bug for this then.

 status fixreleased

 - Alexander

Changed in ubufox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers