Interpid: FireFox homepage is blank due in part to ubufox

Bug #271443 reported by Dave Morley on 2008-09-17
12
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Unassigned
ubufox (Ubuntu)
High
Alexander Sack
Intrepid
High
Alexander Sack

Bug Description

Binary package hint: ubufox

RELEASE: Intrepid
CD/DVD VARIANT: 32bit Ubuntu desktop cd
ISO BUILD: 20080917.1

SYMPTOMS: The latest FF has a blank homepage chrome://ubufox/content/startpage.html is blank but acts as the homepage.

CAUSE: Unknown

STEPS TO REPRODUCE:
1/ open FF on the latest cds
2/ Note the lack of homepage

Below are the errors from error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getComplexValue]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://ubufox/content/startpage.html :: <TOP_LEVEL> :: line 15" data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getComplexValue]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://ubufox/content/startpage.html :: <TOP_LEVEL> :: line 15" data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getComplexValue]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://ubufox/content/startpage.html :: <TOP_LEVEL> :: line 15" data: no]

Dave Morley (davmor2) wrote :

Assigned to asac at his request

Changed in ubufox:
assignee: nobody → asac
Alexander Sack (asac) wrote :

i assume this blocks alpha-6. Marking accordingly.

It appears to be a regression due to my preference cleanup done during this cycle.

We need to reintroduce the general.useragent.locale previously shipped in ubufox.js

Changed in ubufox:
importance: Undecided → High
milestone: none → intrepid-alpha-6
status: New → Triaged
Alexander Sack (asac) wrote :

fix committed to upstream branch.

Changed in ubufox:
status: New → Fix Committed
Alexander Sack (asac) wrote :

fix committed to lp:~ubuntu-core-dev/ubufox/ubuntu branch - rev 62.

Changed in ubufox:
status: Triaged → Fix Committed
Alexander Sack (asac) wrote :

bumping milestone to beta.

RM wont respin alpha 6 CDs just for this bug. We will upload anyway so an eventual new CD spin would pick this fix up.

Changed in ubufox:
milestone: intrepid-alpha-6 → ubuntu-8.10-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.6~b1-0ubuntu2

---------------
ubufox (0.6~b1-0ubuntu2) intrepid; urgency=low

  (cherry-pick rev 111 from lp:ubufox)
  * reintroduce general.useragent.locale pref dropped in 0.6~b1.
    Without that pref the current startpage.html
    breaks and displays a blank page. LP: #271443
    - update defaults/preferences/ubuntu-mods.js

 -- Alexander Sack <email address hidden> Wed, 17 Sep 2008 20:53:43 +0200

Changed in ubufox:
status: Fix Committed → Fix Released
Alexander Sack (asac) wrote :

this was fixed a while ago.

Changed in ubufox:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers