[Hardy] Page should be refreshed after plugin installation

Bug #202790 reported by Stéphane Graber on 2008-03-16
2
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
High
Unassigned
ubufox (Ubuntu)
Low
Unassigned
xulrunner-1.9 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubufox

When going to a website which needs the flash plugin, the plugin manager pops up and install the flash plugin.
Then you close the plugin wizard but the page still shows that no flash plugin is available.
You then need to go to about:plugins so firefox detects the new plugin and then go back to the website which now detects that flash is available.

This shouldn't be needed, firefox should detect the plugin right after this one is installed and should refresh the page so the user can use the plugin.

Changed in ubufox:
importance: Undecided → Low
status: New → Confirmed
Alexander Sack (asac) wrote :

fixed in package branch.

Changed in ubufox:
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :

xulrunner part committed on .head and .dev branch.

Changed in xulrunner-1.9:
status: New → Fix Committed
Alexander Sack (asac) wrote :

fix committed to firefox.head and firefox.dev branch

Changed in firefox-3.0:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.5~rc1-0ubuntu1

---------------
ubufox (0.5~rc1-0ubuntu1) hardy; urgency=low

  Upstream Changes integrated
  * make apturl dependency versioned (>= 0.1.2ubuntu1) - LP: #162609
  * multi distro capability of DB creation script and web service
    (LP: #204435, #177514)
  * simplify ffox 3 code for dispatching NewPluginInstalled events
  * fix plugin Installer Wizard for ffox 3 (LP: #202790)
  * point ubufoxReportBug to firefox-3.0 source package
  * point online help and translate menu entry to firefox-3.0 package and hardy
    distribution (LP: #138968, #203729)
  * merge greek-translation contributed by Athanasios Lefteris
  * LP: #139380, #175969 - merge translations contributed by ubuntu community;
    thanks to Saïvann Carignan for his work on collecting and integrating most
    of them.
    - Added Greek locale - submitted by Athanasios Lefteris (LP: #211404)
    - add Slovenian locale
    - add Swedish locale (LP: #207666)
    - add Portuguese locale
    - add Lithuanian locale (LP: #206133)
    - add Italian locale (LP: #207372)
      + fix mispelled word in Italian translation
    - add Afrikaans locale (LP: #206733)
    - add fr-FR and fr-CA translations
    - add polish translations (LP: #202248)
  * merge fix for LP: #176658 - by Saïvann Carignan <email address hidden>
    - fix ubufox to use the png icon

  Package changes:
  * append &distributionID=8.04 to pfs.datasource.url shipped as defaults
    preference
    - update defaults/preferences/ubufox-pfs.js

 -- Alexander Sack <email address hidden> Sat, 05 Apr 2008 06:35:40 +0200

Changed in ubufox:
status: Fix Committed → Fix Released
Alexander Sack (asac) wrote :
Download full text (4.1 KiB)

firefox-3.0 (3.0~b5+nobinonly-0ubuntu1) hardy; urgency=low

  * Firefox 3.0 Beta 5 package - "ready for prime-time"!

  * Multiple fixes and improvements to debian/rules: "rewrite substitution
    rules", "bad .autoreg install path makes package ftbfs", "Firefox must not
    ship reporter extension; its shipped in xulrunner-1.9", "enable
    mozilla-devscript's in binary-post-install", "--disable-debug passed twice
    in configure"
    - update debian/rules

       * Alexander Sack < <email address hidden>>
       * Fabien Tassin <email address hidden>

  * Multiple fixes to the apport hook: "remove .pyc file garbage during prerm",
    "bad install path", "bad extension directories used to gather data"
    - update debian/apport/firefox-3.0.py
    - update debian/firefox-3.0.prerm
    - update debian/firefox-3.0.install

       * Alexander Sack < <email address hidden>>
       * Fabien Tassin <email address hidden>

  * Multiple fixes required by libxul linkage with jemalloc: "libjemalloc.so
    cannot be installed - doesn't exist", "-Wl,-Bsymbolic-functions in LDFLAGS
    cause crashes at startup"
    - update debian/firefox-3.0.install
    - update debian/rules

       * Fabien Tassin <email address hidden>

  * Fix multiple misc bugs: "migration creates double dots for abandoned
    profiles", "Wikipedia search plugin shipped upstream", "blocklist.xml not
    installed", "use LIBDIR when touching .autoreg in postinst", "Fix restart
    notification misbehaviour", "Improve package description (LP: #207199)"
    - update debian/firefox.sh.in
    - drop debian/wikipedia.*
    - update debian/firefox-3.0.install
    - update debian/rules
    - update debian/firefox-3.0.postinst.in
    - update debian/firefox-3.0-restart-required.update-notifier

       * Alexander Sack < <email address hidden>>
       * Fabien Tassin <email address hidden>

  * Misc package housekeeping changes: "Bump xulrunner-1.9
    dependencies to b5", "Adjust patches", "desktop files not valid
    (LP: #194970)", "relax dependencies on xulrunner. no upper bounds":
    - update debian/control
    - update debian/patches/dont_depend_on_nspr_sources.patch
    - update debian/patches/nspr_flags_by_pkg_config_hack.patch

       * Fabien Tassin <email address hidden>

  * Multiple Translation related fixes and improvements: "Reuse translations
    from firefox 2 .desktop file", "include lp-export-xpi.mk from
    mozilla-devscripts and export en-US.xpi to debian/lp-export-xpis/
    directory"
    - update debian/firefox-final.desktop
    - update debian/rules
    - update debian/control

       * Alexander Sack < <email address hidden>>
       * Fabien Tassin <email address hidden>

  * Fixing chrome registration issues by properly shipping
    $(DEBIAN_FF3_DIR)/.autoreg and touching it in postinst maintainer scripts
    - update debian/rules
    - update debian/firefox-3.0.postinst.in
    - add debian/firefox-3.0-gnome-support.postinst

       * Alexander Sack < <email address hidden>>
       * Fabien Tassin <email address hidden>

  * fix LP: #185622 - "Firefox 3 doesn't act as the default browser"; we
    always check for and...

Read more...

Changed in firefox-3.0:
status: Fix Committed → Fix Released
Alexander Sack (asac) wrote :
Download full text (3.1 KiB)

xulrunner-1.9 (1.9~b5+nobinonly-0ubuntu1) hardy; urgency=low

  [ Fabien Tassin <email address hidden> ]
  * Drop patch applied upstream
    - drop debian/patches/bz333308_attXXXX_make_clean_cleaner.patch
    - update debian/patches/series
  * Set LDFLAGS so dpkg-buildpackage doesn't use -Wl,-Bsymbolic-functions
    - update debian/rules
  * Add support for a defaults/syspref directory containing system wide
    preferences that will not be silently overwritten at each upgrade
    (LP: #207281, #203538).
    It works for both libxul apps such as firefox 3 and xulrunner
    applications such as prism
    - add debian/patches/add_syspref_dir.patch
    - update debian/patches/series
  * Fix broken RSS subscription
    - add debian/patches/bz423060_att312807_fix_rss_subscription.patch
    - update debian/patches/series
  * Bump depends to libnspr4-dev >= 4.7.1~beta2 and libnss3-dev >= 3.12.0~beta3
    - update update debian/control
  * Hook up mozilla-devscript's compare module to binary-post-install
    - update debian/rules

  [ Alexander Sack < <email address hidden>> ]
  * switch to in-source jpeg to fix rendering issues at zoom levels
    (LP: #182038); this measure should give us some performance
    improvements.
    - update debian/rules
  * make pref extensions read defaults/autoconfig from NS_GRE_DIR instead
    of NS_APP_DEFAULTS_50_DIR. If it turns out to be a bad decision, we should
    reconsider this patch.
    - add debian/patches/bzXXX_autoconfig_in_gre.patch
    - update debian/patches/series
  * install system-greprefs in /etc/xulrunner-1.9/ and create the proper
    link in $pkglibdir/greprefs to it (LP: #139543)
    - add debian/system-greprefs.js
    - update debian/rules
  * ship versioned link libsqlite3.so.0 => libsqlite3.so in $pkglibdir to
    allow liferea workaround for LP: #203413 - "Liferea creates many corrupt
    copies of places.sqlite in" by setting LD_LIBRARY_PATH properly
    - update debian/rules
  * ship .autoreg file in pkglibdir to allow autoreg touches by
    plugins/extensions et al.
    - update debian/rules
  * touch .autoreg in xulrunner-1.9.postinst and
    xulrunner-1.9-gnome-support.postinst
    - update debian/xulrunner-1.9.postinst
    - add debian/xulrunner-1.9-gnome-support.postinst
  * hook in lp-export-xpi.mk from mozilla-devscript to export en-US
    translation templates to debian/lp-export-xpis/; in turn, make
    mozilla-devscripts a hard build-depends
    - update debian/rules
    - update debian/control
  * consider NS_GRE_DIR/.autoreg to trigger component registry upgrades.
    - add debian/patches/bzXXX_gre_autoreg.patch
    - update debian/control/series
  * Fix "Dom Inspector not compatible" by bumping maxVersion field in
    extension install.rdf
    - add debian/patches/inspector_maxversion_bump.patch
    - update debian/patches/series
  * Fix xulrunner side for bug "firefox needs restart after plugin install to
    detect and activate them"; we scan for new plugins in GRE at startup runtime
    - update debian/patches/bzXXX_gre_extension_plugin_support.patch

 -- Fabien Tassin <email address hidden> Fri, 04 Apr 2008 23:11:10 +0...

Read more...

Changed in xulrunner-1.9:
importance: Undecided → High
milestone: none → ubuntu-8.04
status: Fix Committed → Fix Released
Changed in firefox-3.0:
importance: Undecided → High
milestone: none → ubuntu-8.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers