plugin finder wizard and apturl don't use the same http proxy

Bug #162609 reported by Alexander Sack on 2007-11-14
4
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Unassigned
apturl (Ubuntu)
High
Michael Vogt
Gutsy
Undecided
Unassigned
Hardy
High
Michael Vogt
ubufox (Ubuntu)
High
Alexander Sack
Gutsy
Medium
Unassigned
Hardy
High
Alexander Sack

Bug Description

Binary package hint: ubufox

the plugin finder wizard and apturl don't share the same proxy information.

1. The short term solution to fix gutsy is to pass a --http-proxy host:port parameter to apturl if firefox has any proxy configured.

2. The long term solution would be to all applications honour system proxy settings (aka gconf).

Testcase:
 1. ensure that your network setup does only allow access to the internet through http proxy
 2. configure the http proxy in firefox
 3. remove any flash player installed on your system
 4. visit the multi content example page: http://people.ubuntu.com/~asac/pfs/test/2_multicontent.html
 5. try to install the plugin through "install missing plugins ..."
 6. see how apturl doesn' honour the http proxy settings and cannot get the packages.

Alexander Sack (asac) on 2007-11-14
Changed in ubufox:
importance: Undecided → Medium
status: New → Confirmed
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :
Alexander Sack (asac) wrote :

confirmed that the latest apturl branch works well with --http-proxy host[:port]

Changed in apturl:
status: New → Fix Committed
Changed in ubufox:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Both packages accepted into gutsy-proposed. To go ahead, please:

 * add a TEST CASE: to the description (see current SRU policy)
 * get this fixed in Hardy
 * get it verified from sru-verification.

Thank you!

Alexander Sack (asac) wrote :

I reuploaded ubufox with a versioned depends on apturl

description: updated
Pedro Villavicencio (pedro) wrote :

Verification done, I've set up a squid proxy in my laptop and did the test with another gutsy machine connected to it by the ethernet card.

- Test with apturl 0.1ubuntu1 and ubufox 0.4~beta1-0ubuntu4, I've configured the http proxy in firefox, visited the page on point 4 and i wasn't able to install the flashplugin because it doesn't honour the proxy settings.
- Test with apturl 0.1ubuntu2 and ubufox 0.4~beta1-0ubuntu6. Started firefox (the proxy setting already configured) and went to the site on point 4, I was able to install the flashplugin didn't have any problem, the bug is fixed, thanks.

Martin Pitt (pitti) wrote :

Copied to -updates.

Changed in ubufox:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Alexander, please upload this to Hardy ASAP.

Changed in ubufox:
assignee: nobody → asac
importance: Medium → High
milestone: none → hardy-alpha-2
Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in apturl:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Michael, please upload this to Hardy ASAP.

Changed in apturl:
assignee: nobody → mvo
importance: Undecided → High
milestone: none → hardy-alpha-2
status: New → In Progress
Steve Langasek (vorlon) on 2007-12-15
Changed in ubufox:
milestone: hardy-alpha-2 → none
Changed in apturl:
milestone: hardy-alpha-2 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.1.2ubuntu1

---------------
apturl (0.1.2ubuntu1) hardy; urgency=low

  * support --http-proxy for better integration with the
    proxy settings of firefox (LP: #162609)
  * merged patch from Andy Owen to display a description

 -- Michael Vogt <email address hidden> Wed, 16 Jan 2008 14:51:24 +0100

Changed in apturl:
status: In Progress → Fix Released
Alexander Sack (asac) wrote :

ubufox needs to ship a versioned dependency in hardy as well.

Alexander Sack (asac) wrote :

fixed in bzr

Changed in ubufox:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.5~rc1-0ubuntu1

---------------
ubufox (0.5~rc1-0ubuntu1) hardy; urgency=low

  Upstream Changes integrated
  * make apturl dependency versioned (>= 0.1.2ubuntu1) - LP: #162609
  * multi distro capability of DB creation script and web service
    (LP: #204435, #177514)
  * simplify ffox 3 code for dispatching NewPluginInstalled events
  * fix plugin Installer Wizard for ffox 3 (LP: #202790)
  * point ubufoxReportBug to firefox-3.0 source package
  * point online help and translate menu entry to firefox-3.0 package and hardy
    distribution (LP: #138968, #203729)
  * merge greek-translation contributed by Athanasios Lefteris
  * LP: #139380, #175969 - merge translations contributed by ubuntu community;
    thanks to Saïvann Carignan for his work on collecting and integrating most
    of them.
    - Added Greek locale - submitted by Athanasios Lefteris (LP: #211404)
    - add Slovenian locale
    - add Swedish locale (LP: #207666)
    - add Portuguese locale
    - add Lithuanian locale (LP: #206133)
    - add Italian locale (LP: #207372)
      + fix mispelled word in Italian translation
    - add Afrikaans locale (LP: #206733)
    - add fr-FR and fr-CA translations
    - add polish translations (LP: #202248)
  * merge fix for LP: #176658 - by Saïvann Carignan <email address hidden>
    - fix ubufox to use the png icon

  Package changes:
  * append &distributionID=8.04 to pfs.datasource.url shipped as defaults
    preference
    - update defaults/preferences/ubufox-pfs.js

 -- Alexander Sack <email address hidden> Sat, 05 Apr 2008 06:35:40 +0200

Changed in ubufox:
status: Fix Committed → Fix Released
Changed in ubufox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers