firefox flash-plugin automatic installation fails on youtube

Bug #161818 reported by Marcus Granado on 2007-11-10
70
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubufox (Ubuntu)
Wishlist
Unassigned

Bug Description

Problem occurs with:
* Ubuntu 8.04 LTS
* Ubuntu 9.04
* Ubuntu Karmic, all updates installed

1. From a fresh Ubuntu installation, go to <http://www.youtube.com/>.
2. Go to any of the videos.

What happens: "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player."
What should happen: Firefox's plug-in finder bar appears.

Sites like YouTube query firefox about the availability of the flash plugin, and if not found, display fallback text (usually including a link to Adobe's download page) instead of triggering the browser's native <embed> behavior for uninstalled plug-ins. This is usually implemented using the Adobe Flash Player Detection Kit <http://www.adobe.com/products/flashplayer/download/detection_kit/> and, more recently, SWFObject <http://code.google.com/p/swfobject/>. SWFObject will be included in upcoming versions of Adobe Flash Catalyst and Adobe Flash Builder, and since May 2009 it has consistently been used by about 13% of the top 10 000 Web site front pages sampled by Builtwith. <http://trends.builtwith.com/?tag=javascript&tech=b9f773e8-12b1-46ee-ab08-bafa6c8d0c6f>

Ubuntu's plug-in finder bar works only for <embed> elements, and therefore it is working for fewer and fewer Flash sites over time.

A simple solution might be to hack firefox to always provide the information that the flash capability is present, even when the flash plugin is not yet installed. Therefore, the site would provide the flash object, and the automatic flash plugin installation would kick in.

Nanley Chery (nanoman) wrote :

This issue has been solved in Gutsy Final.

Changed in ubufox:
assignee: nobody → nanoman
status: New → Invalid
Nanley Chery (nanoman) wrote :

If i didn't understand correctly and your problem is the same as bug 173890 then please mark this bug as a duplicate of said bug. If I am still wrong, feel free to remove the Invalid status.

David Balažic (xerces8) wrote :

Confirming this is still the case on ubuntu 8.04.1 (amd64 version):
 - make a fresh install
 - start firefox
 - goto youtube.com

The youtube page will say it detected that flash is not installed and offers a link to adobe.com, which offers download of RPM/DEB packages.

David Balažic wrote:
> Confirming this is still the case on ubuntu 8.04.1 (amd64 version):
> - make a fresh install
> - start firefox
> - goto youtube.com
>
> The youtube page will say it detected that flash is not installed and
> offers a link to adobe.com, which offers download of RPM/DEB packages.
>
>
This is a duplicate of another bug already filed on LP. The reason it is
happening is because you are trying to use flash's plugin finder not
ours. We are working on getting ours to trump Adobe's but we are not
sure of Mozilla's stand on it nor Adobe's

I will look to see if i can find the orig. report.

The one you found that you thought was same its not.

Nanley Chery (nanoman) on 2008-08-27
Changed in ubufox:
assignee: nanoman → nobody
Matthew Paul Thomas (mpt) wrote :

Problem reproduced with Ubuntu Karmic alpha 5.

Changed in ubufox (Ubuntu):
status: Invalid → New
Micah Gersten (micahg) wrote :

@mpt

I'm returning this bug to invalid as there seems to be a problem with ubufox itself on the Alpha 5 CD.

I've opened bug #427734 to track that.

Changed in ubufox (Ubuntu):
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

Reproduced in Ubuntu 9.10 beta; reopening.

From the duplicate bug 387444, apparently this is deliberate behavior on the part of the ubufox developers: YouTube uses the Adobe Flash Player Detection Kit instead of standard <embed> code, and therefore ubufox does not put up the plug-in finder bar.

The Canonical Design team has just discussed this. Even if the Adobe Flash Player Detection Kit is "stupid" as described in bug 387444, we do not think that merely calling it stupid and doing nothing else is a reasonable or sustainable approach in the face of YouTube using it. And the experience of installing Flash via adobe.com is much less obvious or pleasant (.yum? .tar.gz? .rpm? .deb? .wtf?), and presumably less updatable too, than the experience of installing it from the Ubuntu (or Canonical partner) repository via the plug-in finder.

There are several ways this might be fixed.

One way would be to persuade YouTube to switch to standard <embed> code, like Google Video uses, possibly using the more complex Flash detection only for browsers where standard <embed> does not produce a reasonable installation invitation; and to persuade Adobe to change the Flash Player Detection Kit code accordingly. Have any Ubuntu developers done anything about this so far? If so, what?

A second way would be to special-case youtube.com video pages so that if Flash is not installed, the plug-in finder bar appears regardless of what is actually on the page. Yes, this would be a hack (for example, it would produce false positives if YouTube adopted HTML5 <video>), but no more of a hack than Safari's special-casing of youtube.com pages on an iPhone.

A third way would be for ubufox to patch the Firefox code that is triggered by the Adobe Flash Player Detection Kit, to pretend that the Flash plug-in is installed regardless of whether it actually is. Again, this would be a hack, but it would continue in a grand tradition of Web browsers pretending they do or don't support particular things for Web site compatibility.

Changed in ubufox (Ubuntu):
status: Invalid → Confirmed
description: updated
description: updated
Alexander Sack (asac) wrote :

well ... the ideas i had about detecting a flash detection kit would require hooks/code changes at quite central places of firefox ... i am not sure we will be able to do that upstream.

that said, there might be other - more workaround'ish - ways of doing this through maybe checking if there is a link to the adobe flashsite somewhere or maybe in some other way. needs some more thinking ...

Alexander Sack (asac) wrote :

this bug is triaged as its understood why this happens.

Changed in ubufox (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
tags: added: iso-testing
description: updated
Thomas Hotz (thotz) wrote :

This bug is saved now.

I would suggest you to use Firefox with HTML 5 player on Youtube because for Firefox Adobe said they only provide 5 years security updates for flash and then they'll drop Flash support. So HTML 5 will be the future.

Changed in ubufox (Ubuntu):
status: Triaged → Fix Released
Thomas Hotz (thotz) wrote :

At least here on Ubuntu 12.10 LTS.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers