Ubuntu

Untranslated strings in ubufox

Reported by Timo Jyrinki on 2007-09-13
8
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Unassigned
ubufox (Ubuntu)
Medium
Saivann Carignan

Bug Description

Binary package hint: ubufox

The following strings are untranslated (and I'm unable to find a place they could be translated) in ubufox:
"Choose a plugin for media type"
"installer" (after "Adobe Flash Player" text)
"Install additional software?"
"Do you want to install the package XXX"

On the installation succesful page, everything is translated, though, as are the other strings on the first page.

Alexander Sack (asac) wrote :

i am happy to accept translation contributions for ubufox. If you want to contribute ping me in #ubuntu-mozillateam IRC channel on irc.freenode.net or drop a note here.

Changed in ubufox:
status: New → Confirmed
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

Attached is a translation of the locale/en-US directory for Finnish (fi). However, I didn't find the following strings in there:
"installer" (after "Adobe Flash Player" text)
"Install additional software?"
"Do you want to install the package XXX"

Timo Jyrinki (timo-jyrinki) wrote :

I think the directory should be locale/fi-FI instead. However, even if using that and building + installing the resulting new ubufox package, I still don't see any stuff translated in the locale directory (Launchpad link strings in Help menu, Ubufox extension description in Extensions dialog or "Choose a plugin for media type").

Timo Jyrinki (timo-jyrinki) wrote :

Ah, well, I also found that the properties file should use escaped unicode, so using that now. I tried changing the en-US dir with the now-attached fi-FI dir, which worked and I got those strings translated!

But if I don't overwrite the en-US directory, I can't seem to get the translations working even though fi-FI locale is also installed by the deb package. Is the locale being set correctly?

Timo Jyrinki (timo-jyrinki) wrote :

Adding:

locale ubufox fi-FI locale/fi-FI/

to chrome.manifest helped! Thanks, asac. Modified file attached.

Timo Jyrinki (timo-jyrinki) wrote :

Here are the both as a patch.

Alexander Sack (asac) wrote :

i committed this to my local branch. We will at least do one ubufox upload; this bug will be fixed in there.

Changed in ubufox:
status: Confirmed → Fix Committed
Daniel Abramov (ex) wrote :

Russian translation of
http://archive.ubuntu.com/ubuntu/pool/main/u/ubufox/ubufox_0.4~beta1.orig.tar.gz

There is updated chrome.manifest (you will have to merge it with yours 'cause there is also fi-FI translation which I did not download) and locale\ru-RU folder.
Let me know if you update the source and need translations of new strings or if something goes wrong.

Timo Jyrinki (timo-jyrinki) wrote :

Could hardy (at least) have an upload where the Finnish and Russian translations would be included? Of course gutsy-updates (via gutsy-proposed) would be welcome too, but not absolutely necessary.

Karoly Gossler (connor) wrote :

please apply this patch too

Timo Jyrinki (timo-jyrinki) wrote :

Here's updated Finnish translation as a patch against current bzr. No translation has yet been included in the ubufox main development tree.

Timo Jyrinki (timo-jyrinki) wrote :

Putting back to "Confirmed", since the locales are not included in the bzr yet.

Changed in ubufox:
status: Fix Committed → Confirmed

It would be nice if this was translatable via Launchpad...

The content of the .dtd and .properties files is quite strange... Is there only 4 strings (entities) to translate? and why "Hello World !" (sounds like a programming exercise ;-) ) in the .properties file?

Changed in ubufox:
importance: Undecided → Medium
status: Confirmed → Triaged
Alexander Sack (asac) wrote :

ok, ubufox 0.5~beta2-0ubuntu1 contains the translations for fi-FI and ru-RU (which i could merge from a bzr branch).

i oversaw the hungarian translation though. can someone create a branch based on https://code.edge.launchpad.net/~asac/ubufox/main for that?

Thanks,
 - Alexander

Saivann Carignan (oxmosys) wrote :

I added fr-FR and fr-CA translations to bzr branch https://code.launchpad.net/~saivann/ubufox/fr-FR-fr-CA

Saivann Carignan (oxmosys) wrote :

All translations inside this bug report are now in the main branch of ubufox except the hungarian but I will take care of this personally. Setting status to Fix Committed. I will send a email to all ubuntu translation mailing list for the missing translations. Thanks for your contribution!

Changed in ubufox:
assignee: nobody → saivann
status: Triaged → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Hi. Thanks, but reopening: could you update the Finnish translation with the one in my comment from 2008-02-12. The current merged one was from a branch that had it in October, lacking URLs and thus breaking showing home page.

Changed in ubufox:
status: Fix Committed → Confirmed
Saivann Carignan (oxmosys) wrote :

Timo Jyrinki : Thanks, I will make sure that your latest translation is merged soon.

Hi!

I just got the notice from the mailing lists.

Here are the translated files for basque (eu-ES).

Regards

Saivann Carignan (oxmosys) wrote :

Mikl Pascual Aldabaldetraku : Thank you very much, your translations will be merged into ubufox.

I noticed that you did not change

file:///usr/share/ubuntu-artwork/home/index.html
for
file:///usr/share/ubuntu-artwork/home/locales/index-eu.html

I changed it for you. Please tell me if for any reason I should set back these URLs to the generic english one.

Oh
You're right. I missed that.

Thanks for pointing it out.

On 3/15/08, Saïvann Carignan <email address hidden> wrote:
>
> Mikl Pascual Aldabaldetraku : Thank you very much, your translations
> will be merged into ubufox.
>
> I noticed that you did not change
>
> file:///usr/share/ubuntu-artwork/home/index.html
> for
> file:///usr/share/ubuntu-artwork/home/locales/index-eu.html
>
> I changed it for you. Please tell me if for any reason I should set back
> these URLs to the generic english one.
>
>
> --
> Untranslated strings in ubufox
> https://bugs.launchpad.net/bugs/139380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Timo Jyrinki (timo-jyrinki) wrote :

To make it easier, here's the Finnish (fi-FI) translation diff against current bzr main branch.

Timo Jyrinki (timo-jyrinki) wrote :

(also deleted obsolete 3 attachments)

Saivann Carignan (oxmosys) wrote :

Timo Jyrinki : Thanks you. I'm waiting to have more translations before I create a new branch and contact Alexander Sack to merge these branches.

Václav Čermák (kingskid) wrote :

Hi,

here is cs-CZ ubuntu.dtd

Václav Čermák (kingskid) wrote :

and here ubufox.properties cs-CZ

Saivann Carignan (oxmosys) wrote :

Thank your very much. I replaced

file:///usr/share/ubuntu-artwork/home/index.html
by
file:///usr/share/ubuntu-artwork/home/locales/index-cs_CZ.html

to use the correct welcome page. Thanks!

Changed in ubufox:
status: Confirmed → Fix Committed
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.5~rc1-0ubuntu1

---------------
ubufox (0.5~rc1-0ubuntu1) hardy; urgency=low

  Upstream Changes integrated
  * make apturl dependency versioned (>= 0.1.2ubuntu1) - LP: #162609
  * multi distro capability of DB creation script and web service
    (LP: #204435, #177514)
  * simplify ffox 3 code for dispatching NewPluginInstalled events
  * fix plugin Installer Wizard for ffox 3 (LP: #202790)
  * point ubufoxReportBug to firefox-3.0 source package
  * point online help and translate menu entry to firefox-3.0 package and hardy
    distribution (LP: #138968, #203729)
  * merge greek-translation contributed by Athanasios Lefteris
  * LP: #139380, #175969 - merge translations contributed by ubuntu community;
    thanks to Saïvann Carignan for his work on collecting and integrating most
    of them.
    - Added Greek locale - submitted by Athanasios Lefteris (LP: #211404)
    - add Slovenian locale
    - add Swedish locale (LP: #207666)
    - add Portuguese locale
    - add Lithuanian locale (LP: #206133)
    - add Italian locale (LP: #207372)
      + fix mispelled word in Italian translation
    - add Afrikaans locale (LP: #206733)
    - add fr-FR and fr-CA translations
    - add polish translations (LP: #202248)
  * merge fix for LP: #176658 - by Saïvann Carignan <email address hidden>
    - fix ubufox to use the png icon

  Package changes:
  * append &distributionID=8.04 to pfs.datasource.url shipped as defaults
    preference
    - update defaults/preferences/ubufox-pfs.js

 -- Alexander Sack <email address hidden> Sat, 05 Apr 2008 06:35:40 +0200

Changed in ubufox:
status: Fix Committed → Fix Released
Changed in ubufox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers