package description needs rewrite [ubufox]

Bug #123713 reported by Alexander Sack on 2007-07-03
42
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Vish
ubufox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubufox

The package description for 0.2-0ubuntu1 reads like:

Description: modifications for ubuntu firefox (default) install
 Extension package for firefox, that ships various modifications
 for the ubuntu default install of firefox.
 .
 You can uninstall this package if you prefer to use a genuine
 firefox install.

Changes definitly needed:
  s/firefox/Firefox/
  s/ubuntu/Ubuntu/

Any other suggestions welcome.

Related branches

Alexander Sack (asac) on 2007-07-03
Changed in ubufox:
assignee: nobody → mozilla-bugs
status: New → Confirmed
Mario Vukelic (mario-vukelic) wrote :

Would it be possible to list what those changes are?

Also, would you consider to change the package name? "Ubufox" IMHO needlessly obfuscates the package's purpose and make it hard to find in the package manager. Maybe "firefox-adjustments-ubuntu" or some such, analogous to the themes package?

William Grant (wgrant) on 2007-07-05
Changed in ubufox:
importance: Undecided → Low
VF (vfiend) wrote :

Yes, also seeing it named 'ubufox' in the Firefox Add-ons window is sort of surprising, sounds unpolished

On Sun, Jul 15, 2007 at 09:38:14AM -0000, VF wrote:
> Yes, also seeing it named 'ubufox' in the Firefox Add-ons window is sort
> of surprising, sounds unpolished
>

Well, the name of this package is not open for discussion here. This
is about package description.

 - Alexander

'Not open for discussion'? Well, I was just making a quick comment of what I personally thought to a related thing (The description in the add-on of firefox as opposed to the deb's description)

VF (vfiend) wrote :

I mean, I don't care if the package is named ubufox, but it should be described as something more descriptive than 'ubufox' in the firefox add-ons window (like gnome-app-install's application title isn't 'gnome-app-install')

Mario Vukelic (mario-vukelic) wrote :

Well, a bad package name and a bad package description have the same result, confused users, so i don't know why one would be open for discussion but not the other. Seems irrational to me.

Alexander Sack (asac) wrote :

In addons dialog it reads for me:

ubufox
Ubuntu Firefox Extension

... isn't that descriptive enough?

Mario Vukelic (mario-vukelic) wrote :

I dunno, it seems there is a pretty consistent naming convention for packages that contain ubuntu specifics:
'aptitude search ubuntu' gives:
...
edubuntu-addon-kde
edubuntu-addon-legacy
edubuntu-addon-light
edubuntu-addon-science
...
kubuntu-artwork-kbfx
kubuntu-artwork-usplash
kubuntu-default-settings
kubuntu-desktop
kubuntu-docs
kubuntu-grub-splashimages
kubuntu-konqueror-shortcuts
kubuntu-restricted-extras
linux-ubuntu-modules-2.6.22-7-...
...
ubuntu-artwork
ubuntu-calendar
ubuntu-calendar-december
ubuntu-calendar-february
ubuntu-calendar-january
ubuntu-calendar-march
ubuntu-calendar-november
ubuntu-calendar-october
ubuntu-desktop
ubuntu-docs
ubuntu-keyring
ubuntu-laptop-mode
ubuntu-minimal
ubuntu-mobile
...

You get the picture. What's to gain by breaking this pattern?

VF (vfiend) wrote :

Well, I mean, it would be nice if it read

Ubuntu Firefox Extension
Adds [whatever ubufox adds].

So users could actually know what it does from the description, like other extensions seem to work.

Colin Watson (cjwatson) wrote :

Moving milestone forward. Alexander? We can't change the package name so close to 7.10, but at least the description fixes are trivial.

Jan Claeys (janc) wrote :

As someone asked before: "Would it be possible to list what those changes are?"

I think the most important changes (those that significantly influence people's browsing experience) should be listed in the package description.

VF (vfiend) wrote :

Even something like "This package installs an extension which integrates Firefox's extension and plugin managers with Ubuntu's package system." would be good

Alexander Sack (asac) on 2007-10-08
Changed in ubufox:
assignee: mozilla-bugs → asac
Alexander Sack (asac) on 2007-10-08
Changed in ubufox:
status: Confirmed → In Progress
Alexander Sack (asac) wrote :

OK, is this ok:

Package: ubufox
Architecture: all
Depends: firefox, apturl
Description: Ubuntu Firefox specific configuration defaults and apt support
 Extension package for Firefox provides ubuntu specific configuration defaults
 as well as apt support for firefox plugins/extensions.
 .
 You can uninstall this package if you prefer to use a pristine firefox
 install.

and in addons dialog:

<em:name>Ubuntu Firefox Modifications</em:name>
<em:description>Ubuntu configuration defaults and apt support for firefox extensions/plugins.</em:description>

if nobody complains, I will upload this.

Thanks,
 - Alexander

VF (vfiend) wrote :

Seems good to me in Hardy now

Changed in ubufox:
status: In Progress → Fix Released
Loye Young (loyeyoung) wrote :

The description still doesn't describe what ubufox does. You've said it changes firefox configuration, but that's no help. I've been asked about this package, but I don't have a good explanation for what the package does or whether the package is needed or not, because it is not documented at all (which is another bug that needs reporting).

1. After reading the description, the user is left with no idea about what "specific configuration defaults" are being changed. As one user remarked, "If they know what the 'specifics' are, why don't they just tell us?"

2. "apt support for firefox plugins / extensions" is meaningless to someone who doesn't already know what ubufox does. It is also a bit misleading because apturl requires gnome-app-install and synaptic. Users of adept, dpkg-www, aptitude, or other apt frontends will not receive "apt support".

3. It is ESPECIALLY IMPORTANT to note in the description that ubufox depends on GNOME (via the dependency on apturl). The phrase "ubuntu specific" is not sufficiently descriptive because "ubuntu" is an ambiguous term: sometimes it means the GNOME desktop, and sometimes it means the superset distribution of all the *buntu flavors.

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://www.iycc.biz

Loye Young (loyeyoung) wrote :

Not fixed

Changed in ubufox:
status: Fix Released → Confirmed
John Vivirito (gnomefreak) wrote :

GRaphael:
Mozilla has nothing to do with Ubufox that is Ubuntu's code. Alexander is the one that's maintains it.

John Vivirito (gnomefreak) wrote :

Can someone please give a detailed description of what they would like to see what they do see and how they see it. There is way too many reports on this bug that are not the same. screenshot of what you see is also a good idea.

On Fri, Apr 3, 2009 at 7:53 AM, John Vivirito <email address hidden> wrote:

> Can someone please give a detailed description of what they would like
> to see what they do see and how they see it.

If you want to see what the current package description looks like, type the
following from a command line:

# aptitude show ubufox

The Hardy LTS release shows this:

"Description: Ubuntu Firefox specific configuration defaults and apt support
 Extension package for Firefox provides ubuntu specific configuration
defaults
 as well as apt support for firefox plugins/extensions.
 You can uninstall this package if you prefer to use a pristine firefox
install."

Unfortunately, because the package is undocumented, there is no way to tell
you what should be in the description. I can tell you that the current
description is completely unhelpful about what "ubuntu specific
configuration defaults" means.

In addition, reading the original report of this bug would give you some
idea of what is desired.

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://start.iycc.net

Loye Young (loyeyoung) wrote :

John,

For more guidance on this bug, you might also take a look at my comments
here:
https://bugs.launchpad.net/ubuntu/+source/ubufox/+bug/123713/comments/15.

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://start.iycc.net

Something like stated in

https://bugs.edge.launchpad.net/ubuntu/+source/ubufox/+bug/123713/comments/15

We are pretty much unble to get less general since ubufox has default settings that we ship and there are way too many..
 It already states that:

Description: Ubuntu Firefox specific configuration defaults and apt support
 Extension package for Firefox provides ubuntu specific configuration defaults
 as well as apt support for firefox plugins/extensions.

That tells users that it is used to add extensions as well as has configurable settings. We are unable to list all settings but it allows you to change settings in the advanced setting page "about:config" But as to explain exactly what it does and what can be changed is not really able to happen since there are too many settings that can be changed.
Now if you mean that the Description is not user friendly than i can understand

What did you mean by the following from comment 15 link above:

2. "apt support for firefox plugins / extensions" is meaningless to someone who doesn't already know what ubufox does. It is also a bit misleading because apturl requires gnome-app-install and synaptic. Users of adept, dpkg-www, aptitude, or other apt frontends will not receive "apt support".

As for the above. It is not possible at this point to install firefox without GTK apps/libs since there is not yet a qt version. This is being worked on upstream but i think they came to a point they had to stop. Once QT support is added than we can redo the depends on it to use QT apps/libs
and ubufox is installed with firefox | abrowser | firefox-3.0 | firefox-2
I have also changed the browsers a bit remove 2.0 and added a few other versions. as well as updated it to work with 3.5 3.6 and such. This is only in my PPA at this time but i will most likely merge what i have to the main branch.

So to have a complete description of what you would like it to be We are flying blind on it, If you can give me a reasonible way of how deep you want to go with the description than maybe we can come to a compromise but just saying what does this mean and what does that mean is a bit too open, Examples above about not being able to list everything it does is not really reasonible since it allows you to change Ubuntu config options instead of us having to ship with all/none enabled.
The word "unhelpful" doesn't really tell us anything except a few people didnt understand it. It tells you you can remove it if you want the firefox we ship without the configure changes that we made using ubufox to please most people

Point me to something, anything, that documents what ubufox does and I'll be
happy to write a description.

>it allows you to change settings in the advanced setting page
"about:config"
Firefox already allows changing settings in about:config, without ubufox.
The question is what changes are made by ubufox.

>We are pretty much unable to get less general since ubufox has default
settings that we ship and there are way too many
Saying that the package does too much to document is pretty lame, IMHO.
Rather, it's even more important to document them.

>It is not possible at this point to install firefox without GTK apps/libs
since there is not yet a qt version.
No one is suggesting to install firefox without GTK, and trying to write it
in QT is silly. In fact, the problem isn't firefox at all.

The description says that it's adding "apt support", but that description is
misleading. The problem is the additional GNOME dependencies that apturl
drags in. What's really going on is that ubufox depends on a GNOME graphical
interface to the apt protocol. There are three alternative tacks to take.
(1) If ubufox and apturl don't do anything that is specific to GNOME, drop
the dependency on the GNOME packages in apturl; (2) Change apturl to a
Recommends dependency rather than a Depends (which probably makes sense in
any event); and (3) (germane to this bug report) Provide a more accurate
description of what the apturl dependency does. E.g., "ubufox also depends
on apturl, which is a GNOME graphical interface to the apt protocol allowing
installation of software using a URL of the software repository."

Again, if ubufox were documented somewhere, the community could help.

--
Loye Young
Isaac & Young Computer Company
Laredo, Texas
<email address hidden>
956.857.1172

Probably meaningful to consider the comment from bug 222283 what I have been marked as duplicate of this bug:

"What are "various modifiications"? Oh, here they are:

https://answers.launchpad.net/ubufox/+question/12077"

kecsap (csaba-kertesz) wrote :

Comments from the bug 503782 marked as duplicate of this bug:

Question thread about these issues:

https://answers.launchpad.net/ubufox/+question/84439

and

"For example, it appears to have some link into package management for plugins. Something like
"When a missing plugin is detected, it runs ??? to try to install a package for the missing plugin."

A bullet list for each added feature with that level of detail would be sufficient.

If it does something with fonts, what does it change or add (from the base)?"

tz (thomas-mich) wrote :

Thanks kecsap for taking this up.

Just for security and consistency, I like to know what changes in Firefox for anything I install (and I have lots of extensions). But extensions and plugins can conflict or do strange things.

There is no real hurry, but something should be in the next release. The more detail the better, but something which was very brief but a fairly complete list would be better than the current nothing.

John Vivirito (gnomefreak) wrote :

tz:
What you are referring to is not the same as this bug. This bug is about typo in package description, please file a new bug on that bug or comment on the bug already posted for that issue

@John Vivirito,
TZ and Kecsap are on the right track. This bug is not about typos. This bug
is about the substance of the description.

I modified the package description as follows, feel free to comment it:

Package: ubufox
Architecture: all
Depends: firefox | abrowser | firefox-3.0 | firefox-2, apturl (>= 0.1.2ubuntu1) | apturl-kde
Description: Ubuntu Firefox specific changes and apt support
 A package for Firefox which modifies the following things: Searching missing plugins
 from ubuntu package repositories; Help menu/new items: report problems,
 get help on-line and help translating firefox; Ubuntu version of the start page;
 Restart notification after upgrading Firefox; Help menu/Release notes points
 to Ubuntu release notes; Add ask.com to the search engines.
 .
 You can uninstall this package if you prefer to use a pristine firefox
 install.

tags: added: patch
Matthew Paul Thomas (mpt) wrote :

That's much better, kecsap, thank you. You could discard a few words from the start, something like this: "Alters Firefox so that it searches the Ubuntu software catalog when looking for plug-ins; includes Ubuntu items in the Help menu; uses Ubuntu’s start page…" etc.

Vish (vish) wrote :

We missed Ubuntu 7.10-rc a long back . removing milestone ;)

@Luke Faraone, could you update your branch with mpt's suggestion [comment #30]?

summary: - package description needs rewrite
+ package description needs rewrite [ubufox]
tags: added: metadata
Changed in ubufox (Ubuntu):
milestone: ubuntu-7.10-rc → none
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Triaged
Vish (vish) on 2010-08-05
Changed in hundredpapercuts:
assignee: nobody → Vish (vish)
status: Triaged → In Progress
Benjamin Drung (bdrung) on 2010-08-10
Changed in ubufox (Ubuntu):
assignee: Alexander Sack (asac) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu3

---------------
ubufox (0.9~rc2-0ubuntu3) maverick; urgency=low

  [ K. Vishnoo Charan Reddy ]
  * debian/control: Improve description (LP: #123713).

  [ Benjamin Drung ]
  * Rename the binary package to xul-ext-ubufox.
  * Drop Vcs-Bzr field. It's maintained in lp:ubuntu/ubufox now.
  * Bump Standards-Version to 3.9.1 (no changes required).
  * Switch from debhelper 5 to 7.
 -- Benjamin Drung <email address hidden> Wed, 11 Aug 2010 01:03:53 +0200

Changed in ubufox (Ubuntu):
status: Confirmed → Fix Released
Vish (vish) wrote :

Took 3yrs to get this one done ;-)

Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.