Firefox about:home doesn't work right when set with ubuntu-defaults-builder

Bug #1195367 reported by Jeremy Bicha on 2013-06-27
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubufox (Baltix)
Medium
Mantas Kriaučiūnas
ubufox (Ubuntu)
Low
Chris Coulson
ubuntu-gnome-default-settings (Ubuntu)
Low
Unassigned

Bug Description

I used ubuntu-defaults-builder to attempt to set Firefox's homepage to the default since I think it looks better and is more functional than Ubuntu's about:startpage.

However, it's not quite the same. You can verify by entering about:home in the browser address field and then compare with the page you get when you click the Home button in the toolbar.

- Search doesn't work
- None of the buttons on the bottom of the page (Downloads, History, Settings, etc.) work
- The dynamic text under the Google search widget doesn't show up (It's easy to customize your Firefox exactly the way you want it. or Thanks for choosing Firefox! To get the most out of your browser, learn more about the latest features.)

I have verified this issue with Saucy's Firefox 22 and 23.

See the packaging diff at
https://launchpad.net/ubuntu/+source/ubuntu-gnome-default-settings/13.10.1

And I'll attach the customized distribution.ini.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: firefox 23.0~b1+build1-0ubuntu1 [modified: usr/lib/firefox/distribution/distribution.ini]
ProcVersionSignature: Ubuntu 3.9.0-7.15-generic 3.9.7
Uname: Linux 3.9.0-7-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rachel 17488 F.... pulseaudio
BuildID: 20130626174122
Channel: Unavailable
Date: Thu Jun 27 11:38:53 2013
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-06-14 (13 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130613)
IpRoute:
 default via 192.168.2.1 dev wlan0 proto static
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.3 metric 9
MarkForUpload: True
Plugins:
 Gnome Shell Integration - /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so (gnome-shell)
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=23.0/20130626174122
RelatedPackageVersions:
 gnome-shell 3.8.3-2ubuntu1
 rhythmbox-mozilla 2.99.1-0ubuntu1
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
description: updated
affects: firefox (Ubuntu) → ubufox (Ubuntu)
Jeremy Bicha (jbicha) wrote :

I'm adding ubuntu-gnome-default-settings to this bug in case we have to revert for 13.10.

Changed in ubuntu-gnome-default-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Jeremy Bicha (jbicha) on 2013-06-27
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubufox (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-07-06
description: updated
Jeremy Bicha (jbicha) wrote :

What if the model were flipped around so that ubufox by default doesn't change the homepage but the ubuntu-settings package (and similar settings override packages) could change the homepage to about:startpage if they like?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-default-settings - 13.10.5

---------------
ubuntu-gnome-default-settings (13.10.5) saucy; urgency=low

  [ Tim Lunn ]
  * Override ubufox homepage setting and use about:home instead of
    about:startpage (LP: #1195367).

  [ Jeremy Bicha ]
  * Undo the changes from 13.10.1 since we're setting the Firefox
    homepage a different way
 -- Tim Lunn <email address hidden> Tue, 23 Jul 2013 11:41:31 +1000

Changed in ubuntu-gnome-default-settings (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) wrote :

Ubuntu GNOME shipped this solution for 13.10 Alpha2 in ubuntu-gnome-default-settings but I thought it would be better to offer this in a neutral package that anyone can use. I'll need sponsorship for this upload.

Chris Coulson (chrisccoulson) wrote :

This is quite difficult to fix properly. The main issue is that in order to not give privileges to about:home, handling mouse clicks on the buttons at the bottom of the page is done by bubbling an event up in to the main browser UI window, but these are only handled when the document URI is "about:home" (likewise, the snippets don't work because the snippet URL is fetched from preferences and injected in to the document from the browser UI when the document URI is "about:home", because the homepage is not allowed access to preferences).

It may be possible to fix this with a lot of code duplication in ubufox. The other alternative is to just implement our own local homepage which we could add the same UI controls to. This is something I've wanted to try for a while, but never got around to (and it's unlikely I ever will now, seeing as I don't work on this or Firefox anymore)

Jeremy Bicha (jbicha) wrote :

Chris, I think the patch in my previous comment is a pretty good workaround. Could you give it a try?

Martin Pitt (pitti) wrote :

This should really be reviewed by Chris, so unsubscribing sponsors and assigning to him.

Changed in ubufox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in ubufox (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in ubufox (Baltix):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers