New install on laptop installed incorrect version of Grub (Grub-efi)

Bug #996617 reported by David Mandala on 2012-05-08
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

Colin Watson looked at this at UDS and requested bug be filed so he could examine the logs.

Was a new install at 12.04 Beta laptop has a hybrid drive that has a 500 gig rotating media that is SDA and 16Gig SSD that is SDB. Laptop BIOS is efi enabled but was doing a standard bios boot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 8 09:16:22 2012
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

David Mandala (davidm) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Brian Candler (b-candler) wrote :

I have seen what I believe is the same problem several times with ubuntu-server edition.

* Boot up from USB stick (possibly this forces EFI mode?)
* Install, everything looks fine
* Reboot, machine doesn't boot :-(
* Turns out that the machine has msdos partitions but grub-efi was installed, rather than grub-pc

I see the following as possible issues, but beware that I am certainly no EFI expert.

1. If the disk has MSDOS rather than GPT partition table, I don't think EFI booting is possible. In that case I think grub-pc should be installed instead of grub-efi. In fact, it should probably also check that there is a suitable EFI boot partition too.

(Or: perhaps grub-efi should always be subject to confirmation, always giving you the option to install grub-pc instead)

2. The ubuntu-server text-based partitioning doesn't appear to have any option to create a GPT partition table. At least I have just tried this with ubuntu-12.04 server in a VM, and it doesn't offer me this choice in manual partitioning.

This is rather forces people to continue to use legacy partitioning and booting. If you know what you are doing you can boot from a live CD, partition with gparted, and then reboot into the installer.

3. Actually what I said in (2) is not true if you use "expert mode". At the point "Create empty partition table on this device?", you can select gpt. But expert mode is painful and tedious.

Another solution would be if "Create empty partition table?" in non-expert mode could offer the option of GPT. Or to avoid another prompt, it could automatically create a GPT table if you booted in EFI mode and grub-efi is going to be installed later. Maybe it does this already, I haven't tested it. But this still doesn't help if the disk has a pre-existing msdos partition table and you don't remember to overwrite it.

(Aside: I have just tried installing an ubuntu server VM in virtualbox with EFI enabled, using expert mode and gpt, but it wouldn't boot and dropped me into EFI shell instead. I told you I wasn't an EFI expert :-)

John Rose (johnaaronrose) wrote :

I converted my hard disk's partition table to gpt from mbr, using instructions at:
I rebooted successfully & confirmed that the conversion was OK using gparted.

My BIOS is EFI capable so I intend to clean install 64 bit 12.0.2. I currently have 32 bit 12.04.2 but it's not EFI capable. So I tried usng a USB stick containing 12.04.2 64 bit. The BIOS showed it as EFI capable. So I booted from it. That was OK. So I invoked the 'Install Ubuntu' option using its icon. I went into the partitioning and found that no efi partition (at /boot/efi) would be created whether I was to erase the disk or use the default partitions specified initially in the Advanced partitioning option.

Thus, it seems to me that 64 bit 12.04.2 will not be installed (on a BIOS capable of it) unless gparted is used before the installation is started. This seems to contradict
where it states "nothing special is required if you use the automatic installer of Ubuntu ("Install Ubuntu alongside others" or "Erase the disk and install Ubuntu"). ".

Colin Watson (cjwatson) on 2014-12-18
Changed in ubiquity (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
no longer affects: ubiquity
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-aaqibnadeem Edit

Bug watches keep track of this bug in other bug trackers.