Ubiquity fails to create encrypted home directory when no swap if configured

Bug #989279 reported by amay82 on 2012-04-26
64
This bug affects 18 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

[rational]
Ubiquity fails to create encrypted home directory when no swap if configured.

[test case]
1) Begin installing Ubuntu
2) Custom partitions - Don't configure a swap partition
3) When Ubiquity asks for the user name, say that you want an encrypted home folder
4) Ubiquity fails: see screenshot

[regression potential]
Should the check fail (can't see how that could be ...), we'd just be back to the current behaviour, so can't see any real regression potential here.

Last syslog lines:
Apr 26 23:12:02 ubuntu ubiquity[3562]: debconffilter_done: ubiquity.components.install (current: ubi-usersetup)
Apr 26 23:12:05 ubuntu kernel: [ 266.447125] Intel AES-NI instructions are not detected.
Apr 26 23:12:05 ubuntu ubiquity: INFO: You do not currently have any swap space defined.
Apr 26 23:12:05 ubuntu ubiquity:
Apr 26 23:12:05 ubuntu ubiquity: You can create a swap file by doing:
Apr 26 23:12:05 ubuntu ubiquity: $ sudo dd if=/dev/zero of=/swapfile count=12314816
Apr 26 23:12:05 ubuntu ubiquity: $ sudo mkswap /swapfile
Apr 26 23:12:05 ubuntu ubiquity: $ sudo swapon /swapfile
Apr 26 23:12:05 ubuntu ubiquity:
Apr 26 23:12:05 ubuntu ubiquity: And then re-run /usr/bin/ecryptfs-setup-swap
Apr 26 23:12:05 ubuntu ubiquity:
Apr 26 23:12:05 ubuntu ubiquity: /usr/share/ubiquity/user-setup-encrypted-swap: 60: /usr/share/ubiquity/user-setup-encrypted-swap: cannot open /etc/crypttab: No such file
Apr 26 23:12:05 ubuntu ubiquity: cp: cannot stat `/etc/crypttab': No such file or directory

Because of the ecryptfs-setup-swap error I assume that it fails because of the missing swap partition.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.16
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CasperVersion: 1.315
Date: Fri Apr 27 00:16:03 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de keyboard-configuration/layoutcode?=de
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. I can reproduce with your steps. Setting to 'medium' because there is a big warning in the manual partitioner when the user continues without swap.

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: rls-mgr-q-tracking
Daniel Kończyk (drmartens) wrote :

The big warning says nothing about ecryptfs problems, so your reasoning is false. Anyway, this warning has been there like forever and the described problem appeared in this very version. It also affects current users (like me) with plenty of RAM, who know very well that upgrading Ubuntu is asking for problems and want to clean install a new version, while keeping their encrypted home intact. It's the first time since I can remember that it doesn't work.

Alex Wauck (awauck) wrote :

Really, ubiquity shouldn't even try to set up encrypted swap if there is no swap.

Colin Watson (cjwatson) on 2012-07-13
Changed in ubiquity (Ubuntu):
importance: Medium → High
assignee: nobody → Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04.1
Colin Watson (cjwatson) on 2012-07-13
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Changed in ubiquity (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.15

---------------
ubiquity (2.11.15) quantal; urgency=low

  * Drop hw-detect debugging attempts.
  * Terminate status-to-debconf subprocess in DebconfInstallProgress more
    gracefully to avoid desynchronising the debconf protocol if the
    subprocess is killed between sending a command and receiving the
    response (LP: #1023036).
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab (LP: #1024343).
  * Don't try and fail to set up encrypted swap if no swap partitions are
    configured (LP: #989279).
 -- Colin Watson <email address hidden> Sat, 14 Jul 2012 00:17:31 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
description: updated
description: updated

Hello amay82, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Precise:
I have reproduced the problem with ubiquity 2.10.17 in precise-updates and have verified that the version of ubiquity 2.10.18 in -proposed fixes the issue.

I verified that the crash is fixed, after installation there is no swap and home directory is encrypted.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.19

---------------
ubiquity (2.10.19) precise-proposed; urgency=low

  * Automatic update of included source packages: base-installer
    1.122ubuntu7.1, debian-installer-utils 1.88ubuntu2.1, flash-kernel
    2.28ubuntu42.2. (one-time update from precise-proposed) (LP: #1021293)
 -- Stephane Graber <email address hidden> Mon, 30 Jul 2012 10:36:51 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Jacopo (j-ricci) wrote :

the situation is similar to new lubuntu 13.10 x86

this is my /var/log/syslog:

Oct 26 08:47:41 lubuntu ubiquity: 2463
Oct 26 08:47:42 lubuntu ubiquity: WARNING: [/dev/zram0] is a RAM device, skipping.
Oct 26 08:47:42 lubuntu ubiquity: WARNING: There were no usable swap devices to be encrypted. Exiting.
Oct 26 08:47:42 lubuntu ubiquity: /usr/share/ubiquity/user-setup-encrypted-swap: 79: /usr/share/ubiquity/user-setup-encrypted-swap:
Oct 26 08:47:42 lubuntu ubiquity: cannot open /etc/crypttab: No such file
Oct 26 08:47:42 lubuntu ubiquity: cp:
Oct 26 08:47:42 lubuntu ubiquity: impossibile eseguire stat di "/etc/crypttab"
Oct 26 08:47:42 lubuntu ubiquity: : File o directory non esistente
Oct 26 08:47:43 lubuntu ubiquity[2463]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
Oct 26 08:47:43 lubuntu ubiquity[2463]: dbfilter_handle_status: ('ubi-usersetup', 1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers