No "Prepare for shipping ..." option after OEM install from D-I

Bug #987050 reported by Scott Kitterman on 2012-04-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson
Precise
Medium
Colin Watson
Quantal
Undecided
Unassigned

Bug Description

[rational]
oem-config-slideshow-ubuntu is always installed by ubiquity even when it doesn't exist on the media, preventing oem-config-* from being installed.

[test case]
1) Use the Kubuntu installation media
2) Install in OEM mode
3) Post-install check that oem-config-kde is installed and that oem-config-slideshow-ubuntu is NOT installed

[regression potential]
None that I can see. It could regress a system using a non-gtk frontend and require oem-config-slideshow-ubuntu but we don't have any media with that configuration.

Test case http://testcases.qa.ubuntu.com/Install/AlternateOem with http://cdimage.ubuntu.com/kubuntu/daily/20120421.1/precise-alternate-i386.iso

The install goes fine, but after reboot, no prepare for shipping icon available.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/987050

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

Can't reproduce on Ubuntu Alternate i386, looks like it's Kubuntu specific.

Colin Watson (cjwatson) wrote :

A workaround would be to add oem-config-slideshow-ubuntu to the ship seed, if you have room - it's a bit north of 700KB and isn't actually used for the KDE frontend, so it's a bit of a waste, but the alternative is a ubiquity upload which is a bit of a pain at this point in the release.

affects: debian-installer (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

I worked around this for 12.04 with a seed change.

Scott Kitterman (kitterman) wrote :

Medium due to workaround.

Changed in ubiquity (Ubuntu):
importance: High → Medium
milestone: none → ubuntu-12.04.1
Launchpad Janitor (janitor) wrote :
Download full text (6.3 KiB)

This bug was fixed in the package ubiquity - 2.11.0

---------------
ubiquity (2.11.0) quantal; urgency=low

  [ Colin Watson ]
  * Install oem-config-slideshow-ubuntu in a separate pass from
    oem-config-$frontend and ubiquity-frontend-$frontend, since it may be
    missing from images; and only do this for the GTK frontend in any case,
    since other frontends don't currently use the slideshow (LP: #987050).
  * Re-enable alpha warning for quantal.
  * Upgrade to debhelper 9 for improved handling of compiler flags. Make
    sure that /usr/lib/girepository-1.0/ stays where it's supposed to be
    despite changes in the default libdir for multiarch.
  * Port to Python 3:
    - Use Python 3-style print functions.
    - Use "except Exception as e" syntax rather than the old-style "except
      Exception, e".
    - Use reduce from functools rather than relying on the builtin.
    - Use list comprehensions rather than filter or map.
    - Use open() rather than file().
    - Import configparser rather than ConfigParser if available.
    - Use input() rather than raw_input() when running under Python 3.
    - Use set comprehensions.
    - Import quote from urllib.parse rather than urllib if available.
    - Use new-style octal literals.
    - Use test.support rather than test.test_support if available.
    - Add --python2 and --python3 options to tests/run to force running the
      tests under Python 2 or 3 respectively.
    - Handle renaming of __builtin__ to builtins in Python 3.
    - Only pass unicode=1 to gettext.install in Python 2.
    - Port ubiquity.auto_update to python-apt 0.8 progress classes.
    - Use Python 3 names for itertools.izip and itertools.izip_longest if
      available.
    - Use helpers from the six module to deal with some bytes/unicode
      differences.
    - As a general rule, open subprocesses with universal_newlines=True when
      expecting to read text from them. This has no effect on Python 2
      (aside from \r\n conversion and the like, which is mostly a no-op for
      us), but causes Python 3 to read str rather than bytes. The
      exceptions at the moment are: debconf-copydb subprocesses, which
      return mixed-encoding data that needs to be handled specially; and
      when feeding the output of a subprocess to hashlib.
    - Use six.reraise rather than the three-argument form of raise.
    - Adjust test_filteredcommand for Python 3 text handling.
    - Fix test_ubi_partman.question_has_variables to handle templates files
      as binary data, since they're mixed-encoding.
    - Cope with assertItemsEqual/assertCountEqual naming difference between
      Python 2.7 and 3.2.
    - Rearrange ubiquity.i18n.get_translations to treat debconf-copydb
      output as binary data and do field-dependent decoding.
    - Adjust test_misc and test_upower to cope with file type changes in
      Python 3.
    - Use xml.etree.cElementTree instead of libxml2; it's faster, has a
      smaller footprint by virtue of being built into the standard library,
      arguably easier to read, and works with Python 3.
    - Fix a slew of file handle leaks, including making much more liberal
      use of context managers.
   ...

Read more...

Changed in ubiquity (Ubuntu Quantal):
status: New → Fix Released
Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → In Progress
description: updated

Hello Scott, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

OEM install worked and no oem-config-slideshow installed post-install, marking this a pass.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.19

---------------
ubiquity (2.10.19) precise-proposed; urgency=low

  * Automatic update of included source packages: base-installer
    1.122ubuntu7.1, debian-installer-utils 1.88ubuntu2.1, flash-kernel
    2.28ubuntu42.2. (one-time update from precise-proposed) (LP: #1021293)
 -- Stephane Graber <email address hidden> Mon, 30 Jul 2012 10:36:51 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers