[omap4] /etc/network/interfaces not created on a no-network installation

Bug #985305 reported by Michael Casadevall on 2012-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

/etc/network/interfaces is missing on an install where no ethernet connection is available. This causes a 120 second delay on startup due to ifupdown hanging waiting for network interfaces (even if the cable is connected later). This also prevents ifupdown from properly managing lo, although this appears to be initialized by a fallback somewhere else.

Steps to Reproduce:
1. Do a non-network installation
2. cat /etc/network/interfaces

Expected Result:
Basic /etc/network/interfaces with auto lo only.

Changed in oem-config (Ubuntu):
importance: Undecided → High
affects: oem-config (Ubuntu) → ubiquity (Ubuntu)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/985305

tags: added: iso-testing
tags: added: rls-mgr-p-tracking
Colin Watson (cjwatson) on 2012-04-19
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.14

---------------
ubiquity (2.10.14) precise-proposed; urgency=low

  [ Colin Watson ]
  * Install ubiquity-frontend-$frontend along with oem-config-$frontend to
    improve dependency resolution; with the packaging the way it is at the
    moment, apt may sometimes select ubiquity-frontend-kde to resolve
    ubiquity's dependency on a frontend before realising that oem-config-gtk
    already depends on ubiquity-frontend-gtk.
  * Don't default to installing GRUB to a removable device with /cdrom
    mounted from it, even if /cdrom's filesystem isn't iso9660
    (LP: #984989).
  * If encrypting the user's home directory, wipe and enable encrypted swap
    before starting the slideshow, because running the slideshow can use up
    a lot of memory so we won't be able to disable swap once that's in
    progress (LP: #979350).
  * Automatic update of included source packages: apt-setup 1:0.55ubuntu3,
    partman-base 153ubuntu4, user-setup 1.42ubuntu3.
  * If /etc/network/interfaces doesn't exist when configuring the network in
    oem-config, write out a skeleton one (LP: #985305).

  [ Stéphane Graber ]
  * Always install oem-config-slideshow-ubuntu in OEM mode, also for
    alternate installs (LP: #984736)
 -- Colin Watson <email address hidden> Thu, 19 Apr 2012 03:30:44 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers