Installer hangs at step 5

Bug #97081 reported by Tomas on 2007-03-27
14
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

The installer program in Ubuntu 7.04 BETA hangs at a certain stage of the setup. When the installer reaches step 5, the migration assistant wizard, the cursor shape changes indicating busy state and stays like that for an indefinte amount of time.

Installation SHOULD never hang at any stage of the setup. In the event that the installation program may hang, a warning message MUST have been displayed in prior. In addition, in the event of such stalling, the setup should time out and report an error back to the user, or try to recover. Finally, the setup MUST not fail due to an optional setup such as the migration assistant. An option to skip this part of the setup SHOULD be offered.

I was not able to report this problem via Ubuntu because Ubuntu did not recognize my modem. My windows installation resides on a FAT32 partition at /dev/hda3.

description: updated
Colin Watson (cjwatson) wrote :

I don't really need to be told that the installer should never hang. Obviously all such cases I currently know how to fix are already fixed. :-)

Could you please attach /var/log/syslog and /var/log/partman to this bug, following the directions in http://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs? Thanks in advance.

Changed in ubiquity:
status: Unconfirmed → Needs Info
assignee: nobody → kamion

Attached are the log files requested.

Evan (ev) on 2007-03-28
Changed in ubiquity:
assignee: kamion → evand
Colin Watson (cjwatson) on 2007-03-28
Changed in ubiquity:
status: Needs Info → Confirmed
Evan (ev) wrote :

Tomas,
Can you either try a daily live CD build or run `sudo apt-get update; sudo apt-get install ubiquity`? This will ensure the bug you are seeing has not already been fixed. Then could you please run `ubiquity -d` in a console, which will put the installer in debug mode, and then post the /var/log/installer/debug and /var/log/syslog files to this bug report?

Thanks!

Evan (ev) wrote :

To add to that, the /var/log/syslog file attached doesn't tell me enough about what's failing, but the latest migration-assistant outputs much better debugging information, so completing the above steps should give me a much better idea of what's going wrong here.

Evan (ev) on 2007-04-04
Changed in ubiquity:
status: Confirmed → Needs Info
mclay (michael-j-mclay) wrote :

I had the install process stall at the same point when installing on an Emachine desktop running XP. I no longer have access to the machine, so I won't be able to provide additional debugging information. I've attached a copy of the /var/log/messages file that I had saved after the install process stalled.

The following error message appeared at the end of the log message when the program stalled:

  Apr 2 15:47:39 ubuntu ubiquity: Unable to open the registry file.
  Apr 2 15:47:39 ubuntu last message repeated 9 times

There are a few more lines after this message in the log following this entry that occured when I plugged in the usbdrive and loaded a few missing modules.

The error message suggests the assistant was trying to read the registry on the XP partition. Was that the problem. The XP OS that was on the hard drive was infected with viruses, so perhaps the registry was corupted.

Evan (ev) wrote :

mclay,

Your problem is different, however that /var/log/messages appears to be enough to go on to fix it. Thanks very much for this!

Where can I obtain the daily live CD build ?

Could you post a URL link to download it.

Charlie Kravetz (charlie-tca) wrote :

Hardware test; 400 MHz P2; 256MB RAM; NVidia/SGS Thomsom Riva 128 w/4MB memory

I can not reproduce this issue using Lucid Lynx, dated 2010-03-10

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
status: Incomplete → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers