[feisty] Kubuntu timezone page broken

Bug #96958 reported by Graham Moucka on 2007-03-27
46
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Low
Unassigned
ubiquity (Ubuntu)
Low
Jonathan Riddell

Bug Description

Upon clicking next in the kubuntu install program at step 1, the step 2 window didn't display correctly. The lower half of the window which shows your currently selected time zone settings was ok but the upper half was just step 1 with a lot of red dots over it. Also, upon hovering over a city, a tag pops up saying what city it is, this does not disappear when you move the mouse away.
The rest of the screens (step 3-6) are fine.

Colin Watson (cjwatson) wrote :

Jonathan, do you have any idea what's going on here?

Colin Watson (cjwatson) on 2007-03-29
Changed in ubiquity:
assignee: nobody → jr
Jonathan Riddell (jr) wrote :

Reporter: What system were you installing on? Was it a virtual system?

heno has reported this to me as happening on virtual box. I've never been able to recreate it.

Changed in ubiquity:
status: Unconfirmed → Needs Info
Mitch Golden (mgolden) wrote :

I also reported this bug here https://launchpad.net/bugs/97690. Mine was on an old Sony Vaio PCG-XG19, which has a neomagic graphics card. I saw it in both alpha 5 and beta 1. It was not virtual.

Mitch Golden (mgolden) wrote :

On further thought: I have noticed that on some older chipsets, such as the neomagic one in the Vaio, and on a i810 I have in an older Dell, the machine doesn't quite work properly unless I manually edit the xorg.conf file to include XaaNoPixMapCache. (And in the neomagic case, I need to use SWCursor as well.) There are a few other flaky things I see during the install, such as bars across the start menu when I call it up. These persist right after the install, but I have fixed them in the past by adding these flags to xorg.conf after the install.

I don't know if this could have anything to do with the map problem, but there's some chance it's related. Of course, there's no way to edit the xorg.conf file when it's on the CDROM, so I don't know exactly how to test this theory. Is there some way to make an ISO I could burn with a different xorg.conf?

I was installing it into a Parallels virtual machine on a MacBook Pro.

On 4/5/07, Jonathan Riddell <email address hidden> wrote:
>
> Reporter: What system were you installing on? Was it a virtual system?
>
> heno has reported this to me as happening on virtual box. I've never
> been able to recreate it.
>
> --
> [feisty] Kubuntu timezone page broken
> https://bugs.launchpad.net/bugs/96958
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Graham Moucka

<email address hidden>
<email address hidden>
mob: 07841373404

www.closertohim.co.uk
www.moucka.co.uk

Graham Moucka (mouckatron) wrote :

I was installing into a parallels virtual machine under Mac OS X on a MacBook Pro. I shall try it on a non virtual system and see what happens.

Graham Moucka (mouckatron) wrote :

I tried installing onto another box i have and it worked fine on it. The map was perfectly visible so it seems to be something that is emulated in the Parallels VM

Colin Watson (cjwatson) wrote :

Moving milestone forward, unless a fix magically appears soon ...

Mitch Golden (mgolden) wrote :

How is it possible to turn off X acceleration during the install so we can see if that is the source of the problem?

Colin Watson (cjwatson) wrote :

Booting in safe graphics mode would probably do it.

Mitch Golden (mgolden) wrote :

I tried it with the final release of feisty, and here's an amusing datapoint: I tried installing with safe graphics mode and the map was still missing. The video hardware in the KDE system settings was shown as vesa, not neomagic. When I run in non-safe graphics mode there are certain problems I see which I wasn't seeing in safe graphics mode, so XaaNoPixMapCache must have been turned on.

(Then I set it VGA, but the display didn't work at all in that case.)

Henrik Nilsen Omma (henrik) wrote :

Setting this bug to confirmed. The effect has been seen by several people on different virtual machines and older graphics cards. Perhaps the solution is to move to Marble maps for Kubuntu eventually?

Changed in ubiquity:
importance: Undecided → Low
status: Needs Info → Confirmed
Mitch Golden (mgolden) wrote :

I am still seeing this problem in Gutsy tribe 1 (on the same machine).

Mitch Golden (mgolden) wrote :

Even though Gutsy tribe 2 does a better job on the safe graphics mode (e.g. it doesn't use some of the broken acceleration in the Neomagic chipset driver) I am still seeing this problem, even when I install in safe graphics mode.

Mitch Golden (mgolden) wrote :

I saw this fixed in Kubuntu Gutsy Alpha 3, but in Alpha 4 it appears to be back!

Mitch Golden (mgolden) wrote :

Bug is present in Kubuntu Gutsy Alpha 5

Colin Watson (cjwatson) on 2007-10-11
Changed in oem-config:
importance: Undecided → Low
status: New → Confirmed
Mitch Golden (mgolden) wrote :

Hey! In Hardy Alpha 1 the bug is gone!

Colin Watson (cjwatson) wrote :

I've now seen multiple reports of this being fixed in Hardy, so I'm going to close this. If you still see it with recent Hardy alpha releases, please reopen this bug.

Changed in ubiquity:
status: Confirmed → Fix Released
Changed in oem-config:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers