Installation failing with pop-up "The installer encountered an unrecoverable error and will now reboot."

Bug #950282 reported by Christopher Townsend on 2012-03-08
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
Precise
Critical
James M. Leddy
ubiquity (Ubuntu)
High
Stéphane Graber
Precise
High
Stéphane Graber

Bug Description

Running a build of Precise, I'm encountering a failure during the very early stages of installation. I get a pop-up saying "The installer encountered an unrecoverable erro and will now reboot."

It seems to occur when the following is present in syslog:
Mar 8 20:30:10 ubuntu kernel: [ 41.113727] pool[9204]: segfault at 17 ip 00007f022e402bfe sp 00007f0216355a20 error 6 in libc-2.15.so[7f022e2d9000+1b1000]

Note that this is a preseeded installation.

I'm unable to use apport to collect info because it tell tells me "This is not an official Ubuntu package..." and exits.

I have attached the syslog.

Related branches

Christopher Townsend (townsend) wrote :
summary: Installation failing with pop-up "The installer encountered an
- unrecoverable erro and will now reboot."
+ unrecoverable error and will now reboot."
Mario Limonciello (superm1) wrote :

I'm unsure what process called "pool" this is that shows up in dmesg, but it can be continually triggered (with about a 75% success rate on a machine that triggers this) just by running:

# ubiquity --automatic
# echo $?
125

Ubiquity will exit code 125 and the accompanied pool segfault shows again in dmesg and /var/log/syslog.

Now, if pdb is to be trusted, fingers point at GTK.

---------------------------------------------------------------------
# pdb /usr/lib/ubiquity/bin/ubiquity --automatic
> /usr/lib/ubiquity/bin/ubiquity(15)<module>()
-> '''
(Pdb) break 240
Breakpoint 1 at /usr/lib/ubiquity/bin/ubiquity:240
(Pdb) cont
ste> /usr/lib/ubiquity/bin/ubiquity(240)install()
-> wizard = ui.Wizard(distro)
(Pdb) step
--Call--
> /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py(157)__init__()
-> def __init__(self, distro):
(Pdb) break 1019
Breakpoint 2 at /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py:1019
(Pdb) cont
break 84> /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py(1019)allow_change_step()
-> set_root_cursor(cursor)

Breakpoint 3 at /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py:84
cont
> /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py(84)set_root_cursor()
-> gtkwidgets.refresh()
Segmentation Fault
---------------------------------------------------------------------

This is all that's in refresh:
def refresh():
    while Gtk.events_pending():
        Gtk.main_iteration()

tags: added: ubiquity-2.9.24
tags: added: precise
Jean-Baptiste Lallement (jibel) wrote :

Same problem on a DELL n4010 booted from USB. It crashes on the same process whether I let it boot or choose "install ubuntu: on the boot menu

Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Undecided → High
tags: added: qa-manual-testing
Steve Langasek (vorlon) wrote :

Stéphane, could this be related to your recent gtk event loop changes?

Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Stéphane Graber (stgraber)
tags: added: rls-mgr-p-tracking
Stéphane Graber (stgraber) wrote :

It's definitely something to do with gtk but I'm not sure it's related to my change. If my change goes wrong, we'd see a regular exit of the main loop (as I experienced when I was developing the change).

Could you try installing from beta1 and only upgrade ubiquity to 2.9.26?

There was a gtk update recently and I'd like to make sure it's not what's causing the problem here.

Steve Magoun (smagoun) on 2012-03-12
Changed in oem-priority:
status: New → Confirmed
importance: Undecided → Critical
Changed in ubiquity (Ubuntu):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

ubiquity crashes in ubiquity/gtkwidgets.py
 11def refresh():
 12 while Gtk.events_pending():
 13 Gtk.main_iteration()

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

called from frontend.gtk_ui.set_root_cursor()

Jean-Baptiste Lallement (jibel) wrote :

2.9.27 on Beta1 doesn't trigger the segfault.

I was able to reproduce systematically until Ubuntu Desktop build 20120313 (same hardware, booted from usb with persistence). But today's build 20120314 doesn't crash with this segfault any more. ubiquity greeter and ubiquity launched from the command line works fine)

I also upgraded every package from B1 (which worked fine) to today's version and no crash.

Christopher, Mario or anyone else affected by this defect, could you try latest daily build (http://cdimage.ubuntu.com/daily-live/current/) and tell if you can still reproduce this bug.

Thanks in advance.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete

I'm still seeing the crash in the pool process when doing an install with all of the latest packages included in the image.

It hasn't been mentioned here, but an interesting effect is if installing on a laptop and disconnecting the AC power to the laptop, the crash does not occur.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed

Using a build from last night, I'm still seeing this issue. Any progress being made on this?

James M. Leddy (jm-leddy) wrote :

Chris,

I'm going to try to reproduce the problem. Do you have a link to the image handy? Also, are there any special steps or special hardware needed to reproduce other than having the machine plugged in?

@James,

The Beta 1 image or any current daily build should suffice. I have found that it doesn't always happen when installing, but the failure is around 75% of the time or greater.

Also, the only way I've tripped this is to have the laptop plugged in. This has only been seen on Dell equipment, but that is not to say that other machines made by different manufacturers don't have the problem, it just so happens we only have Dell equipment to try this on.

James M. Leddy (jm-leddy) wrote :

Okay, I will try to reproduce on a Vostro V130 I have with a usb-key made with usb-creator-gtk

Matthias Klose (doko) wrote :

can you attach /proc/cpuinfo from these machines where it crashes?

I'm not sure what has changed, but with latest build, this issue is now occurring even with the machine unplugged whereas before, I would only see the failure when the machine was plugged in.

James M. Leddy (jm-leddy) wrote :

Thanks Chris, is this with the daily livecd image? I'll test out today's

James M. Leddy (jm-leddy) wrote :

Also 64 or 32 bit?

@James,

I have two projects that are based on 64-bit 12.04, so this is what I'm using. Both builds are seeing this issue. I have not tried to reproduce with the daily livecd image, but Jean-Baptiste was able to reproduce at one time (not sure if he still can?) with the daily livecd, so I can be pretty certain it's not specific to my projects.

At this time, this has only been seen on Dell machines, but this is not to say that it doesn't occur with other brands, it just hasn't been tested.

Steve Langasek (vorlon) wrote :

Christopher,

Jean-Baptiste indicated he was no longer able to reproduce this with the daily CDs. Can you please test the Ubuntu daily livecd, so we can rule out some delta there, or some bugfix landed on the daily CD that's not yet included in your project?

There don't seem to be other reports of this issue on other hardware, so it's best if we can get direct access to a machine where this is reproducible.

@Steve,

I tested today's daily LiveCD and I cannot reproduce with that image. Based on Jean-Baptist's comments, it looks like a change in Ubiquity 2.9.28 may have fixed it in the LiveCD.

My two projects are pulling from the Ubuntu archive, so I should be getting all of the latest packages.

One thing to note about my projects is that they are using fully preseeded installs, so that is a difference.

I will work on seeing if I can make a machine accessible that can reproduce this.

Thanks!

Today's automated test of Ubuntu Desktop i386 failed with the same segfault in syslog
https://jenkins.qa.ubuntu.com/job/precise-desktop-i386_default/300/

Line 2144 of syslog
Mar 25 08:44:29 ubuntu kernel: [ 41.820561] pool[8129]: segfault at b ip b74ff425 sp affeaaf0 error 6 in libc-2.15.so[b73df000+19f000]

This is an i386 KVM guest.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/950282

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

Fix is now in ubiquity trunk, expected to be uploaded right after beta2 freeze.

I did 3 tests install on a VM reproducing the issue and managed to successfully install every time with the fix.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.4

---------------
ubiquity (2.10.4) precise; urgency=low

  [ Colin Watson ]
  * Add a log entry before running each target-config hook, to make it a bit
    more feasible to debug hangs there.
  * Call check-language-support with locale names, not with language pack
    names (LP: #963460).

  [ Stéphane Graber ]
  * Change the calls in calculate_result to use the same code path as the
    regular UI. (LP: #964472)
  * Actually call detect_bogus_result() in ubi-usersetup
  * Similarly to ubi-console-setup, don't setup any timeout or similar
    background tasks when running in automatic mode. (LP: #950282)
 -- Stephane Graber <email address hidden> Tue, 27 Mar 2012 17:08:29 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Steve Magoun (smagoun) wrote :

Marking the oem-priority tasks 'fix released' based on testing of the release in comment #27. Thanks!

Changed in oem-priority:
status: Confirmed → Fix Released
Ray Wang (raywang) wrote :

Hi, I still got the installer crash in VM. I use the watauga-precise-amd64-iso-20120404-0.iso which includ ubiquity 2.10.6

Ray Wang (raywang) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Steve Langasek (vorlon) wrote :

Ray, does your latest crash show the same segfault in /var/log/syslog?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers