Migrate documents and settings does not detect suitable account

Bug #94571 reported by Huygens on 2007-03-21
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Brian Murray

Bug Description

Binary package hint: ubiquity

Problem: The installer does not detects suitable user account to import documents and settings from.

Background: On my computer, I have Windows XP Home Edition (in French) and Ubuntu 6.10 (in English).

Actions: I was performing a separate installation of Ubuntu Feisty daily-live/20070320.1 in a different disk partition than Ubuntu 6.10. There is a step in the graphical installer about migrating data from existing user account. However, it does not detect my Windows or Ubuntu account.

Evan (ev) wrote :

Are you electing to reformat any of the partitions during the install? If a partition is scheduled for reformat or deletion, the migration program will not import data from it.

If this is not the case for the partitions you're importing from, please run the installer again using the --debug option and attach /var/log/syslog and /var/log/installer/debug. Detailed instructions can be found here: https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Changed in ubiquity:
assignee: nobody → evand
status: Unconfirmed → Needs Info
Huygens (huygens-25) wrote :

For your question, no I was not formatting any of my partitions. I had a free spare disk space which I have been using for installing Feisty. My already existing partitions are just mounted as is under /media.

Therefore, I will redo the installation and do what you are asking for (debug, log, etc.). However, I won't be able to do it before next Monday at least.

Thank you for the information anyway :-)

My installation halted (the only active button was "Cancel") when it tryed to detect the account into the windows partition. It mounted the ntfs partition and then it remained in the migration window doing nothing.
When I've deleted the windows partition with gparted and then I've reload the installer all is gone well.
I had
hda1 with reiserfs (the old /home)
hda3 ntfs with windows xp
hda6 ext3 with some files
hda7 ext3 (the old root)

Evan (ev) wrote :

lincepitagorica,
Can you either try a daily live CD build or run `sudo apt-get update; sudo apt-get install ubiquity`? This will ensure the bug you are seeing has not already been fixed. Then could you please run `ubiquity -d` in a console, which will put the installer in debug mode, and then post the /var/log/installer/debug and /var/log/syslog files to a new bug report?

Thanks!

dark_link (darklink69) wrote :

First I had the same problem, but updating the installer with "sudo apt-get update; sudo apt-get install ubiquity" all went well.

dark_link (darklink69) on 2007-04-02
Changed in ubiquity:
status: Needs Info → Fix Released
Huygens (huygens-25) wrote :

I am performing the test again with the latest Feisty, the one ready for release, and it is still not working. Furthermore, I get an ugly error messaeg just after. Here is the output of syslog: see attached file.
The error message is: MigrationAssistant failed with exit code 1. Further information may be found in /var/log/syslog. Do you want to try running this step again before continuing? If you do not, your installation may fail entirely or may be broken.

I will try again to perform the installation using the --debug flag.

Huygens (huygens-25) wrote :

OK, still the problem with ubuquity and the --debug option. See attached file.

For information, Windows XP is spread over 2 partitions hda1 and hda2.
I have moved the "My Documents" directory to the hda2 partition (D:) but the Application Data thingy should have remained on hda1 (C:) because I have the home edition and it is not possible with this flavour to set the Document & Settings directory elsewhere than C:

I'm changing the status of this bug back to unconfirmed (I understand by that, that it is open but not identified/analysed)

Huygens (huygens-25) wrote :

See the 2 latest comments, the problem is still visible with final release of Feisty.

Changed in ubiquity:
status: Fix Released → Unconfirmed
Evan (ev) wrote :

Huygens,

Can you run the installer again with the --debug option and attach /var/log/installer/debug?

Thanks!

Huygens (huygens-25) wrote :

OK, I will do the test again tonight (for me 19h UTC) then.

PS: a good side note, so I had installed latest Feisty 64bit Desktop yesterday, and it rocks really! It is really speedy and works great... :-)

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in ubiquity:
assignee: evand → brian-murray
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers