keyboard layout screen - Keyboard navigation broken

Bug #942560 reported by Jean-Baptiste Lallement on 2012-02-28
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Stéphane Graber

Bug Description

Ubuntu Desktop 20120228

The following problems occur with keyboard navigation on the keyboard layout screen:
 * Focus is on the layout list, use up/down arrows to navigate the list not too quickly. At some point the focus changes from the layout list to the input field below the list or the variant list.
 * Once the list loses focus, the user cannot go back to the list, tab navigation never gives focus to the lists

When it hqppens, it is not possible to give focus back to the list with the mouse qnd the actual keyboard layout doesn't match the selected keyboard layout. The user must click on 'continue' then 'back' to restore a correct behavior.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.22
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
CasperVersion: 1.304
Date: Tue Feb 28 12:22:44 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120228)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/942560

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

The bug I fixed yesterday apparently trigger some side effects I didn't notice in testing, making this bug the master for that.

I'll poke at this step again trying to make it work for the issues that have been found so far.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Stéphane Graber (stgraber)
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.23

---------------
ubiquity (2.9.23) precise; urgency=low

  * ubi-console-setup: Revert most of the previous change but keep the
    600ms timeout to avoid entering in a gtk main loop quit/start flood.
    Also add some more checks of the current values to prevent the UI
    from refreshing when not needed. (LP: #942560)
  * gtk_ui: Move the pending_quits handling code from being called right
    after the call to main_quit() to right after the main loop actually
    exits. This seems to help quite a bit with the race discovered in
    ubi-console-setup.
 -- Stephane Graber <email address hidden> Wed, 29 Feb 2012 20:42:24 -0500

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers