Partman crashed after deleting partition during Kubuntu 10.04.4 installer manual partitioning

Bug #933434 reported by Andrew McDonnell on 2012-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

What happened:

1. Running Kubuntu 10.04.4 installer (during ISO testing)
2. Deleted sda5 (was XFS partition
3. Deleted sda6 (was swap)
4. Clicked the mouse on the free space to create a new partition
5. The installer went away and did not even produce a stack trace report
6. Kubuntu Live session started up as though nothing happened

Disk was partitioned as follows:
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa0a504ce

   Device Boot Start End Blocks Id System
/dev/sda1 1 784 6297448+ 12 Compaq diagnostics
/dev/sda2 * 785 14267 108295168 7 HPFS/NTFS
/dev/sda3 14267 15969 13670401 5 Extended
/dev/sda5 14267 15726 11717632 83 Linux
/dev/sda6 15726 15969 1951744 82 Linux swap / Solaris

Andrew McDonnell (andymc73) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/933434

tags: added: iso-testing
Andrew McDonnell (andymc73) wrote :
Andrew McDonnell (andymc73) wrote :

Prior to this installation attempt I had encountered bug 933433 but then powered off completely before starting the new test run.

This stacktrace was in the syslog. There are no stacktraces in the partman log.

Feb 17 09:20:06 ubuntu ubiquity[2742]: switched to page Form
Feb 17 09:20:07 ubuntu ubiquity[2742]: Exception in KDE frontend (invoking crash handler):
Feb 17 09:20:07 ubuntu ubiquity[2742]: Traceback (most recent call last):
Feb 17 09:20:07 ubuntu ubiquity[2742]: File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/PartitionModel.py", line 102, in parent
Feb 17 09:20:07 ubuntu ubiquity[2742]: parentItem = childItem.parent()
Feb 17 09:20:07 ubuntu ubiquity[2742]: AttributeError: _ElementInterface instance has no attribute 'parent'
Feb 17 09:20:07 ubuntu ubiquity[2742]:
Feb 17 09:20:07 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9:
Feb 17 09:20:07 ubuntu ubiquity: /lib/partman/choose_partition//do_option: not found

tags: added: kubuntu
tags: added: i386 lucid
tags: added: ubiquity-2.2.27
dino99 (9d9) wrote :

This version has expired long times ago, and so will never get support

Changed in ubiquity (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers