12.04 Installer stuck on 'Removing conflicting operating system files'

Bug #924660 reported by Stephen Rees-Carter on 2012-02-01
284
This bug affects 64 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

When installing 12.04 on a hard drive with two partitions (/ & /home) formatting only the / partition results in the installer hanging on "Removing conflicting operating system files" after it has wiped away the / partition. This leaves an unusable system.

When I install Ubuntu, I format the /(root) partition, but leave the /home unformatted and mount it. This means I can keep all my files and preferences while having a clean Ubuntu install.

My home directory is encrypted, so my theory is that the installer is unable to get into my home dir and hangs. Since this step happens before the login details are provided.

This is a pretty serious regression IMHO, since it breaks the current install and prevents the new install from completing.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.15
ProcVersionSignature: Ubuntu 3.2.0-12.20-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CasperVersion: 1.302
Date: Wed Feb 1 04:31:12 2012
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120131.3)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Stephen Rees-Carter (valorin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
description: updated
Stephen Rees-Carter (valorin) wrote :

Work around:

1) Install Ubuntu on the /(root) partition, and mount your /home partition as /home2
2) When the installer has finished, BEFORE restarting, edit /media/[partition]/etc/fstab to change the home partition to be mounted as /home instead of /home2
3) Delete the current /media/[partition]/home directory, and move the empty /media/[partition]/home2 in its place
4) Restart

This should load up Ubuntu with a clean install and existing home partitions.

Marco Chiappetta (mardurhack) wrote :

I confirm this happens also on i386 version and not only on the x86_64. I tried to install Alpha 2 on an Asus Eee 1201N.

May I suggest to set the importance to "High" since it prevents the user from installing the distribution using a separate home directory? Thank you in advance.

Just downloaded 12.04 today and can confirm this still happens

Nick Callaghan (niknak) wrote :

not to do with the home partition being encrypted. Mine's not and bug also present

flame panther (flamepanther) wrote :

Nick is correct. I am also trying to install from the Beta CD with a separate home partition which is not encrypted. Used to work in Oneiric. Showstopping regression.

Philip Guyton (phil-lxnet) wrote :

I installed with a different username than already existed on the original home partition.
But mounted the original home as home2 as suggested by Stephen Rees-Carter above. Then guided by Stephen's advice, prior to rebooting after the install had finnished I did the following.

A home dir was created by the install in /target/ with the new user's dir in it, ie /target/home/hettie.
This contains the new skeleton users home.
I moved this /target/home/hettie to /target/home2 using:-
sudo mv /target/home/hettie /target/home2/
N.B. the user created during the install was "hettie"
This does leave a /home on what will be the / but that will be mounted over with the existing real home partition.
If you feel confident enought that you are not removing something then also do:-
<bad if you don't know for sure> sudo rm -rf /target/home

I then did the edit suggested by Stephen Rees-Carter above with the following sed command.

sudo sed -i 's/home2/home/' /target/etc/fstab
sync
then rebooted using the dialog indicating that the install had finnished that we have been ignoring this whole time.

This way I get a clean new user and preserve the data of the existing user, and have the existing home partition for both.
Also note that if the original user was the only and first created users from a previous Ubuntu install then you will have all rights to the existing users home directory via /home/originalusername

N.B this is not to be advised unless you know what you are doing or you are prepared to loose all of your existing /home if you make a mistake.

I know this isn't any help with the bug but it might help some get going on the beta so they can help elsewhere.
P.S. one can always re-create the original user in the new system and then (where username=original user name):-
sudo chown -R username.username /home/username
from a Ctrl+Alt+F1 session then return gui login via Ctrl+Alt+F7
Hope this helps someone.

bwat47 (bwat47) wrote :

Same problem here, NON encrypted partition. I had even deleted my previous user before booting the ubuntu livecd and installing. So there was no users setup on the partition I wanted to mount at home, only a folder called "backup" with all my stuff in it.

That didn't happen to me before alpha 2, but I tried the 12.04 beta installer and this bug happened to me.

Peter Harding (phh-hardnet) wrote :

During install this has been happening to me when mounting and ext4 /home partition without format or when I try to install with an unformatted ntfs /windows partition.

robalrr (robalrr) wrote :

I have the same problem and I don't have an encrypted home. I am using the installer downloaded today march 12.

bwat47 (bwat47) wrote :

I'm surprised this isn't a high priority bug. As mentioned above, not only does this stop the install from completing, it also causes the previous install to be broken.

tags: added: regression-release
Marcelo M (mottalli) wrote :

I also reported this issue on https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/946663 (for some reason this ticket didn't appear on Google at the moment I reported it). I has been marked as high priority in there and assigned.

Davim (davim) wrote :

Same problem on a Intel MacBook, not using encrypted partitions.

Same problem confirmed on an Intel MacBook 8,2.
Using Ubuntu-12.04LTS-beta2-desktop-i386 as installation source.
I have attempted to install the os on 8 different plans on my 2 separate partitions ( / and /home ), on the basis of, for each partition, whether it 1) contains old data or not, whether it 2) is formatted already before running the installer or not and whether it 3) is marked in ubiquity "to be formatted" during the installation or not.
The result is that the problem occurs in all scenarios and has no relevance to the three controls I have set.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers