panel crashed with SIGSEGV in indicator_object_get_entries()

Bug #922052 reported by pawarnitins
98
This bug affects 16 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
High
Canonical Foundations Team
Precise
Fix Released
High
Canonical Foundations Team

Bug Description

i m using ubuntu 12.04 through USB, when i m trying t install gstreaner that time installer get crash.

TEST CASE
1. Boot to a Live Session with an Ubuntu Desktop ISO

ACTUAL RESULT:
- At the screen "try/install ubuntu" the panel is not displayed
- There's a line 'segfault error 4 in libindicator3.so.7.0.0" in /var/log/syslog
- and this crash in /var/crash.

EXPECTED RESULT:
Panel is displayed and no crash.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubiquity-frontend-gtk 2.9.11 [modified: usr/share/applications/ubiquity-gtkui.desktop]
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic-pae 3.2.1
Uname: Linux 3.2.0-10-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CasperVersion: 1.300
CrashCounter: 1
Date: Thu Jan 26 17:51:13 2012
ExecutablePath: /usr/lib/ubiquity/panel
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120125)
ProcCmdline: /usr/lib/ubiquity/panel
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb7705090 <indicator_object_get_entries+64>: mov 0xc(%eax),%eax
 PC (0xb7705090) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: ubiquity
StacktraceTop:
 indicator_object_get_entries () from /usr/lib/libindicator3.so.7
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
Title: panel crashed with SIGSEGV in indicator_object_get_entries()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
pawarnitins (pawarnitins) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 indicator_object_get_entries (io=0x0) at /build/buildd/libindicator-0.4.90/./libindicator/indicator-object.c:605
 load_module (menu=0x87ad800, name=<optimized out>) at panel.c:172
 main (argc=1, argv=0xbfd45b34) at panel.c:267

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

This happened to me immediately after booting a live usb stick with persistence and choosing try ubuntu.

visibility: private → public
tags: added: bugpattern-written
Revision history for this message
Doug McMahon (mc3man) wrote :

Also happening on the 1/27 image when trying to install - message is "installer crashed", links to this report
(install fails

Revision history for this message
Chris Peach (peachris+ubuntu) wrote :

This is still happening in the 1/28 live i386 image after booting a live usb stick with persistence and choosing try Ubuntu (German locale, Dell D630 laptop).

Revision history for this message
Chris Peach (peachris+ubuntu) wrote :

PS: This crash occurred on the first and second start of the live system with persistence, but not on the third start (after installing some deb packages).

Revision history for this message
snowShoveler (cjplawc) wrote :

Also happening on the 1/28/2012 daily build of the live CD i386 image after booting and connecting to my wireless network. I've booted twice and it has occured each time.

Revision history for this message
Chris Brody (chris-brody) wrote :

See question 186142. When installing from CD, when I get the chance to select a wireless network, if I hit Back then Back again the installer is getting this crash.

Revision history for this message
Rob Whyte (fudge) wrote :

USB 64 1/30/2012 daily crashes both on install and from live desktop.
Installer proceeds up until where do you want to install Ubuntu page.
Selected something else/manual clicked forward and ubiquity crashes.

Revision history for this message
Rob Whyte (fudge) wrote :

Same problem when using a disk.
Problem seems to only be with manual partitioning.
When selecting side by side installation installer has no problems.
Did try to apt-get isntall --reinstall libparted with no futher success.
Also did note an error when apt-get update is performed.
Belive it is unrelated.

Changed in ubiquity (Ubuntu):
importance: Medium → High
Revision history for this message
Paul Bakulich (palbakulich) wrote :

Installer wouldn't let me customize my partitions the way I'm used to.

Usually you get to choose which partition you want to be root, crashed soon as I asked for manual configuration.

affects: ubiquity (Ubuntu) → libindicator (Ubuntu)
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Reproduced with Ubuntu Desktop 20120130.
Boot to a Live Session from the ISO.

Changed in libindicator (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → precise-alpha-2
tags: added: iso-testing qa-daily-testing
tags: added: rls-mgr-p-tracking
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is an ubiquity one:

static const char* indicators[] = {
 "/usr/lib/indicators3/6/libsession.so",
 // Bluetooth
 "/usr/lib/indicators3/6/libapplication.so",
 "/usr/lib/indicators3/6/libsoundmenu.so",
 NULL
};

that directory needs to be updated for the current so version

affects: libindicator (Ubuntu Precise) → ubiquity (Ubuntu Precise)
Revision history for this message
Martin Pitt (pitti) wrote :

Merge proposal created.

Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Confirmed → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

I cannot push to the packaging branch, so handing over to foundations to process the merge proposal and do the upload. Thanks in advance!

Changed in ubiquity (Ubuntu Precise):
assignee: Martin Pitt (pitti) → Canonical Foundations Team (canonical-foundations)
Martin Pitt (pitti)
Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.14

---------------
ubiquity (2.9.14) precise; urgency=low

  * src/panel/panel.c: Update indicator ABI to 7. (LP: #922052)
 -- Martin Pitt <email address hidden> Mon, 30 Jan 2012 10:26:07 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
tags: added: raring
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers