Some progress messages are inscrutable

Bug #91792 reported by Matt Zimmerman on 2007-03-12
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Colin Watson

Bug Description

Binary package hint: ubiquity

I think these messages may be in other packages, but I'm filing here as a starting point.

During my test install today, I noticed two progress messages which wouldn't make sense to anyone without knowledge of the internals of the installer. Particularly;

"Running 32_gnome_power_manager"
"Loading module '...' for '...'"

I believe Colin fixed the former in bzr already. I haven't reviewed all of the other messages (they don't seem to appear in the log), but there may be others which are visible.

Colin Watson (cjwatson) wrote :

"Loading module '...' for '...'" shouldn't last very long unless something else is wrong, and if that something is wrong, then I'd like to have the message visible so that it's clear *what* is wrong.

On Tue, Mar 13, 2007 at 09:23:29AM -0000, Colin Watson wrote:
> "Loading module '...' for '...'" shouldn't last very long unless
> something else is wrong, and if that something is wrong, then I'd like
> to have the message visible so that it's clear *what* is wrong.

The individual messages persist only for a short time, but there are enough
of them that the common text is persistent.

My understanding is that these modules are not even being loaded at this
point; all of the necessary hardware detection should have been done during
the boot process. If I recall correctly, this step was added in order to
get some side effect, rather than for the sake of loading modules.

--
 - mdz

Colin Watson (cjwatson) wrote :

Maybe the right answer is to tweak hw-detect not to load those modules in ubiquity.

Craig73 (funrun73) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Matt Zimmerman (mdz) wrote :

On Tue, Dec 23, 2008 at 04:15:00PM -0000, Craig73 wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an issue
> for you. Can you try with the latest Ubuntu release? Thanks in advance.

The messages in question are still just as inscrutable today as they were then.

--
 - mdz

Craig73 (funrun73) wrote :

Installing Ubuntu 8.10 into VirtualBox I don't receive this message (I would expect it at the start of the install, but it moves straight to creating the file system and then copying files). Does it require real hardware to trigger this? [I don't have any real hardware available right now to confirm or complete this issue]

Gaetan Nadon (memsize) wrote :

Matt,
I am trying to move this bug report into Confirm, but I cannot reproduce. I tried both Live CD and Alternate CD for the 8.10 version. Could you indicate approximately where during the install you get the questionable messages? The "Select and Install Software" phase was most likely to be it. Any special options you might be using that an "out of the box" user would not think of?
It's also important to be able to verify the fix, eventually.
BugSquad

Changed in ubiquity:
status: New → Incomplete
Colin Watson (cjwatson) wrote :

The alternate install CD is not relevant to this bug report.

These messages will appear towards the end of the desktop CD installation, *after* copying files. Their presence may well be hardware-dependent. They are harmless but annoying.

Changed in ubiquity:
importance: Undecided → Low
status: Incomplete → Triaged
Colin Watson (cjwatson) on 2009-02-23
Changed in ubiquity:
assignee: nobody → cjwatson
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.11.13

---------------
ubiquity (1.11.13) jaunty; urgency=low

  [ Colin Watson ]
  * Add LSB init script header.
  * Hide some excessively detailed progress messages from hw-detect
    (LP: #91792).
  * Automatic update of included source packages: partman-base 128ubuntu8,
    user-setup 1.23ubuntu13.

  [ Roman Shtylman ]
  * kde_ui: Add SVG timezone map
  * kde_ui: add new partition bars
  * kde_ui: in advanced dialogue make grub settings a combo box
  * kde_ui: add "auto login" option

  [ Evan Dandrea ]
  * Give the proper return value in the user-setup component's run
    function.
  * Restore the OS names in partition bars label code that was accidentally
    commented out in a previous commit.
  * Fix the code around showing ubiquity/text/part_auto_comment_*.
  * Refactor the time zone code to avoid a dependency on python-numpy
    (LP: #332978).

 -- Colin Watson <email address hidden> Tue, 24 Feb 2009 02:18:02 +0000

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers