Ubuntu

ubiquity crashed with TypeError in partman_column_format: argument of type 'NoneType' is not iterable

Reported by Kate Stewart on 2012-01-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

Was trying out Ubuntu Precise daily image from USB stick.
Had backed out of the install ubuntu path, when I wasn't sure on how it would be impacting the windows partition.
Pressing back key triggered this.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.10
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic-pae 3.2.0-rc7
Uname: Linux 3.2.0-7-generic-pae i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CasperVersion: 1.296
Date: Thu Jan 5 21:03:13 2012
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120105)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2892/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with AttributeError in _decode_value(): 'NoneType' object has no attribute 'decode'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Kate Stewart (kate.stewart) wrote :
Kate Stewart (kate.stewart) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Jean-Baptiste Lallement (jibel) wrote :

I haven't reproduced the failure but the same problem exists with software-center (bug 905605) and software-properties-gtk (bug 905602)
This is caused by the following change in pygobject
http://git.gnome.org/browse/pygobject/commit/gi/overrides/Gtk.py?id=654711d0f940d7480d0f1cdb25a3dc9996f7a706

Changed in ubiquity (Ubuntu Precise):
importance: Undecided → High
tags: added: rls-mgr-p-tracking
Jean-Baptiste Lallement (jibel) wrote :

I also noticed the following error in your logs:
an 5 21:04:34 ubuntu ntfsresize: ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
Jan 5 21:04:34 ubuntu ntfsresize: The usage of the /f parameter is very IMPORTANT! No modification was
Jan 5 21:04:34 ubuntu ntfsresize: and will be made to NTFS by this software until it gets repaired.
Jan 5 21:04:34 ubuntu partman: Error running 'ntfsresize --info'
Jan 5 21:04:35 ubuntu ubiquity[2892]: Exception in GTK frontend (invoking crash handler):
Jan 5 21:04:35 ubuntu ubiquity[2892]: Traceback (most recent call last):
Jan 5 21:04:35 ubuntu ubiquity[2892]: File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 593, in partman_column_name
Jan 5 21:04:35 ubuntu ubiquity[2892]: if 'id' not in partition:
Jan 5 21:04:35 ubuntu ubiquity[2892]: TypeError: argument of type 'NoneType' is not iterable

which is reported in bug 912031

Colin Watson (cjwatson) on 2012-01-06
Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
Martin Pitt (pitti) wrote :

Note, tracking the wrong None handling in pygobject in bug 905602, but Colin says the value is not supposed to be None, so it nicely exposes a deeper problem here.

Does anyone have a way to reproduce this reliably? I tried the back button in the manual partitioning screen a few times without any crash.

Martin Pitt (pitti) wrote :

In fact, the software-properties-gtk crash exposes exactly the same problem: Stuff _("Other") into the tree model, and None comes out. So I'm 90% sure that this is a perfect duplicate of bug 905602.

Martin Pitt (pitti) wrote :

Sorry, it's not a duplicate after all, I examined bug 905602 more closely and will upload a fix for it now. So we do need a reproducer for this after all.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

The original Traceback.txt here is fixed with bug 905602, retitling for the more interesting partman crash pointed out in comment 4.

summary: - ubiquity crashed with AttributeError in _decode_value(): 'NoneType'
- object has no attribute 'decode'
+ ubiquity crashed with TypeError in partman_column_format: argument of
+ type 'NoneType' is not iterable
tags: added: iso-testing

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/912563

Kate Stewart (kate.stewart) wrote :

This shouldn't be incomplete, given someone else just reproduced it. Please email me directly if you need me to try something out, I still have that netbook with me. It was reproduced in Budapest and the netbook used was there.

Changed in ubiquity (Ubuntu Precise):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

Bug 918797 is similar to this one and should probably be a duplicate of this one. The reporter in that bug says:

"I choose to install in auto resize, then in the resizing window I-ve clicked the little red written that redirect to manual partitioning, then the crash with the installer that still working."

So it seems like going into manual partitioning may cause it.

Colin Watson (cjwatson) wrote :

Kate, I've tried and failed to reproduce this locally. Would it be possible to get ssh remote access to your netbook when it's booted into a live environment?

Kate Stewart (kate.stewart) wrote :

Colin, will down load the latest image tomorrow morning (my time), and see if I can get it to reproduce. If so, will ping you and see what can be set up.

Colin Watson (cjwatson) on 2012-02-02
Changed in ubiquity (Ubuntu Precise):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers