Ubuntu

ubiquity crashed with ValueError in command(): I/O operation on closed file

Reported by Roland Dreier on 2012-01-04
288
This bug affects 48 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Barry Warsaw

Bug Description

Starting the installer from the latest daily live CD (on amd64/desktop)

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.10 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CasperVersion: 1.296
Date: Wed Jan 4 18:12:44 2012
DuplicateOf: https://bugs.launchpad.net/bugs/900077
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120104)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3221/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with ValueError in command(): I/O operation on closed file
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

lp:~barry/ubiquity/bug-792652
Merged into lp:ubiquity at revision 5273
Colin Watson: Approve on 2012-03-19
Evan Dandrea (community): Approve on 2012-03-19
Roland Dreier (roland.dreier) wrote :
tags: removed: need-duplicate-check

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 792652, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Barry Warsaw (barry) on 2012-03-19
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Barry Warsaw (barry)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.30

---------------
ubiquity (2.9.30) precise; urgency=low

  [ Adam Conrad ]
  * Drop gui/qt/images/squares.png and replace it with a single pixel
    transparent PNG as a placeholder for future changes (LP: #942543)

  [ Evan Dandrea ]
  * Lazily unmount partitions in the check for a Windows partition to
    install Wubi on when we have a full partition table (LP: #956531).
  * Add a small program for testing the Gstreamer webcam code.
  * Fix broken test video output in the GI webcam module.

  [ Stéphane Graber ]
  * set_indicator_keymaps() doesn't actually receive a full locale but
    instead just the language code. That means that the code trying to
    guess a layout based on the default country won't work.
    Drop all of that code and replace by a static map to override the
    default keyboard layout/variant for a language. (LP: #956912)
  * Merge and update Alessio Treglia's branch to make the slideshow
    optional depending on (ubiquity/hide_slideshow) (LP: #690912)
  * Also call setxkbmap directly from set_indicator_keymaps() to ensure
    we actually switch to the first layout in the list. (LP: #956912)
  * Properly mark the KeyboardQuery dialog as a child of ubiquity.
    (LP: #955265)

  [ Martin Pitt ]
  * tests/test_migrationassistant.py: Fix to work with pygobject 3.1.92.

  [ Barry Warsaw ]
  * When Try Ubuntu has been clicked once, don't respond to subsequent
    clicks. (LP: #911907)
 -- Stephane Graber <email address hidden> Mon, 19 Mar 2012 18:02:48 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.